[SOLVED] Steam on Wine not working

If none of the more specific forums is the right place to ask

[SOLVED] Steam on Wine not working

Postby jmslew » 2010-12-17 17:53

I am unable to use Steam via Wine. Here is exactly how I have installed Steam (downloaded the sid amd64 .deb from lamaresh.net):
Code: Select all
# dpkg -i wine<tab-completed>.deb
# aptitude install lib32nss-mdns wine
$ cd /tmp/
wget http://download.microsoft.com/download/office97pro/fonts/1/w95/en-us/tahoma32.exe
# aptitude install cabextract
$ cabextract tahoma32.exe
$ mkdir -p ~/.wine/drive_c/windows/fonts
$ mv Tahoma*.TTF ~/.wine/drive_c/windows/fonts/
$ wine start SteamInstall.msi
$ wget http://www.kegel.com/wine/winetricks
# chmod +x winetricks
# mv winetricks /usr/local/bin
# winetricks gecko
# wine iexplore.exe


I can run Steam and am prompted to log in to my account, which apparently works, and then I *sometimes* see the Steam News window (but it just briefly flashes then crashes). This is what the console spits out:
Code: Select all
chris@stealth:~$ wine "C:\\Program Files\\Steam\\Steam.exe"
CellID: Fetching server list from CSDS. . .
fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
err:ntlm:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path.
err:ntlm:SECUR32_initNTLMSP Usually, you can find it in the winbind package of your distribution.
fixme:urlmon:CoInternetSetFeatureEnabled 5, 0x00000002, 1, stub
fixme:urlmon:CoInternetSetFeatureEnabled 10, 0x00000002, 1, stub
fixme:mixer:ALSA_MixerInit No master control found on HD-Audio Generic, disabling mixer
CellID: CSDS returned 169 servers.
CellID: Connecting to 66.77.113.20:27031. . .
CellID: Connect to 66.77.113.20:27031 took 171 MS
CellID: Nothing beat our old best time of 12 MS
err:ole:CoGetClassObject class {77f10cf0-3db5-4966-b520-b7c54fd35ed6} not registered
err:ole:CoGetClassObject no class object {77f10cf0-3db5-4966-b520-b7c54fd35ed6} could be created for context 0x1
fixme:wbemprox:wbem_locator_ConnectServer 0x1c7120, L"ROOT\\CIMV2", (null), (null), (null), 0x00000080, (null), (nil), 0x42bbeb8)
fixme:winhttp:WinHttpGetIEProxyConfigForCurrentUser returning no proxy used
fixme:win:EnumDisplayDevicesW ((null),0,0x33cfa0,0x00000000), stub!
fixme:winhttp:WinHttpGetIEProxyConfigForCurrentUser returning no proxy used
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:winhttp:WinHttpGetIEProxyConfigForCurrentUser returning no proxy used
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported
fixme:threadpool:RtlQueueWorkItem Flags 0x4 not supported


I am using sid amd64.
Last edited by jmslew on 2010-12-19 17:12, edited 3 times in total.
jmslew
 
Posts: 55
Joined: 2009-08-03 00:04

Re: Steam on Wine not working

Postby TobiSGD » 2010-12-17 17:59

According to the wine website http://appdb.winehq.org/objectManager.php?sClass=version&iId=19444 Steam runs good, but in newer wine-versions.
Exactly that is the reason why I have an installation of Arch Linux on my desktop. It is a minimal install with only Openbox and Wine, it gives me the latest wine-versions and all is running fine.
Wheezy on my servers, until I have migrated them to Slackware. I won't run systemd on my production machines.
User avatar
TobiSGD
 
Posts: 746
Joined: 2010-05-08 22:27
Location: Hannover, Germany

Re: Steam on Wine not working

Postby Hornet » 2010-12-17 18:04

This might help you out. Its a walktrough to get you the latest Wine version.
http://www.winehq.org/download/deblenny
Niels Bohr wrote:The best weapon of a dictatorship is secrecy, but the best weapon of a democracy should be the weapon of openness.
User avatar
Hornet
 
Posts: 10
Joined: 2010-12-07 20:08
Location: Belgium

Re: Steam on Wine not working

Postby TobiSGD » 2010-12-17 18:11

Hornet wrote:This might help you out. Its a walktrough to get you the latest Wine version.
http://www.winehq.org/download/deblenny

This is far away from the latest version, the latest version for Debian is 1.2, while it is 1.3.9 in Arch.
Wheezy on my servers, until I have migrated them to Slackware. I won't run systemd on my production machines.
User avatar
TobiSGD
 
Posts: 746
Joined: 2010-05-08 22:27
Location: Hannover, Germany

Re: Steam on Wine not working

Postby Hornet » 2010-12-17 18:18

TobiSGD wrote:the latest version for Debian is 1.2

I was under the impression this was Debian we where talking about.
For what its worth, it works for me.
Niels Bohr wrote:The best weapon of a dictatorship is secrecy, but the best weapon of a democracy should be the weapon of openness.
User avatar
Hornet
 
Posts: 10
Joined: 2010-12-07 20:08
Location: Belgium

Re: Steam on Wine not working

Postby TobiSGD » 2010-12-17 18:52

Hornet wrote:
TobiSGD wrote:the latest version for Debian is 1.2

I was under the impression this was Debian we where talking about.
For what its worth, it works for me.

AFAIK we are talking about getting Steam to work with wine, and the wine website doesn't mention wine 1.2 in their reports for Steam. They in fact only mention wine 1.3.X for Steam, so it may work with older versions, but I doubt. Of course you can try it.
Wheezy on my servers, until I have migrated them to Slackware. I won't run systemd on my production machines.
User avatar
TobiSGD
 
Posts: 746
Joined: 2010-05-08 22:27
Location: Hannover, Germany

Re: Steam on Wine not working

Postby jmslew » 2010-12-17 19:28

Thanks for the quick replies, I was thinking the same thing, since I initially tried the version from the repos, which didn't work, then used the latest .deb from the site and it got me to the login screen and flashes of the Steam News window, but still not fully working. I guess the next option is to download and compile from source...
jmslew
 
Posts: 55
Joined: 2009-08-03 00:04

Re: Steam on Wine not working

Postby jmslew » 2010-12-17 20:02

Ok, so I've downloaded and unpacked the source file and made the following progress:
Code: Select all
# apt-get build-dep wine
# ./configure --enable-win64


And that leaves me here:
Code: Select all
# make


Which returns:
Code: Select all
make: *** No rule to make target `install'.  Stop.


Not sure what to do next...

Edit: Got it working, it's compiling now...
jmslew
 
Posts: 55
Joined: 2009-08-03 00:04

Re: Steam on Wine not working

Postby bugsbunny » 2010-12-17 21:02

Directory listing | Wine (wine-unstable) packages

If you're running testing (squeeze) or sid you can download and install the binaries. Otherwise download the Debianized source: composed of 3 files, there's a .debian.tar.bz2, a .orig.tar.bz2 and a .dsc (all preceded by the current version, currently 1.3.9)

(I assume you have build-essential, fakeroot etc installed)
1) place all the files in their own directory, cd to the directory, unpack the files:
Code: Select all
dpkg-source -x wine-unstable_1.3.9-0.1.dsc
(using the version as of this moment)
2)
Code: Select all
cd wine-unstable-1.3.9

3) you'll probably need some dependencies, and probably aren't sure which ones. So (still in the directory as in 2):
Code: Select all
# aptitude install pbuilder
# /usr/lib/pbuilder/pbuilder-satisfydepends

4) Once that is done all the dependencies should be satisfied so now you compile the package:
Code: Select all
dpkg-buildpackage -rfakeroot -us -uc -b

Go away for a while, maybe go catch a movie (wine takes a while to compile, depending on how fast your system is. Significantly longer than a kernel though.). Once it's done the deb files should be in the same directory as the 3 original source files.
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: Steam on Wine not working

Postby jmslew » 2010-12-17 21:06

Thanks for the help, I will try your method next, since my method yielded the following after compiling:
Code: Select all
# make install


Everything seemed to install and compile fine, but this is the result of trying to install Steam again:
Code: Select all
$ wine start SteamInstall.msi
-bash: wine: command not found


Tab completion got me to see that wine64 is a command, but that gives me this:
Code: Select all
$ wine64 start SteamInstall.msi
wine: '/home/chris/.wine' is a 32-bit installation, it cannot support 64-bit applications.


Next step is to figure out how to uninstall what I just installed and try your method...only I don't know how to uninstall something I installed with
Code: Select all
# make install
jmslew
 
Posts: 55
Joined: 2009-08-03 00:04

Re: Steam on Wine not working

Postby bugsbunny » 2010-12-17 21:11

try
Code: Select all
# make uninstall
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: Steam on Wine not working

Postby bugsbunny » 2010-12-17 21:16

And note that since squeeze is going to go stable very soon now you may want to seriously consider upgrading, at which point the binaries you'll find at the link I gave you should be usable (I still compile because I'm just anal retentive that way sometimes)
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: Steam on Wine not working

Postby jmslew » 2010-12-17 21:27

Thanks for the quick reply, a quick google search brought me to that result and am currently compiling via your method. After it's complete, I need to:
Code: Select all
# dpkg -i wine*.deb

correct?

I will report back with the results, hopefully this works.
jmslew
 
Posts: 55
Joined: 2009-08-03 00:04

Re: Steam on Wine not working

Postby jmslew » 2010-12-17 21:56

I got the following compilation errors
Code: Select all
make: *** [binary-arch] Error 9
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2


And I am left with no .deb files...
jmslew
 
Posts: 55
Joined: 2009-08-03 00:04

Re: Steam on Wine not working

Postby bugsbunny » 2010-12-18 16:55

All I can say is:
1) It works for me ( but I don't have 64 bit on this system)
2) There may be some inherent incompatibilities with Lenny (assuming that's what you're compiling on). They're probably fixable (if that's what it is) but I don't currently have the resources to try and track down what's happening.

You may have better results by following the instructions at the link:
"For further assistance write to debian@carbon-project.org" :)

Otherwise I still strongly recommend an upgrade to squeeze.
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Next

Return to General Questions

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable