KDM Failsafe Session - Not Working ?

Everything about X, Gnome, KDE, ... and everything running on it

KDM Failsafe Session - Not Working ?

Postby Forester » 2011-01-21 00:03

Hi,

What is the Failsafe Session Type that you can select from the KDM login screen supposed to do ?

With Squeeze RC1, if I attempt to log in to a failsafe session, I am returned to the KDM login screen. This does not seem very failsafe to me but then I am not a desktop expert.

With Lenny (5.0.7), I get a single console window, which, I guess, at least gives one a chance of fixing whatever may be stopping the normal KDE session from starting.
Forester
 
Posts: 14
Joined: 2011-01-01 12:56

Re: KDM Failsafe Session - Not Working ?

Postby schmidtbag » 2011-01-23 04:09

it should load the failsafe xorg settings. i'm not sure if it actually logs you in with those settings, it might just revert back to them. if you don't have a failsafe config file in /etc/X11/ then my guess would be that it doesn't work because its trying to load something that doesn't exist, and since the option is supposed to be fail SAFE, signing you in with undefined graphical settings isn't exactly safe.
schmidtbag
 
Posts: 222
Joined: 2010-04-14 20:51
Location: MA

Re: KDM Failsafe Session - Not Working ?

Postby Forester » 2011-01-23 11:42

Thanks schmidtbag for the suggestion. I have tried testing your hypothesis with the default xorg.conf from lenny. It seems to make no difference (neither did the absence of .default.face).

I can't see any errors in the systems logs. I can't see any difference between a failed failsafe login and a successful normal login except in auth.log:

Normal / successful:
Code: Select all
Jan 23 09:24:53 maple kdm: :0[3496]: pam_unix(kdm:session): session opened for user debian by (uid=0)
Jan 23 09:24:53 maple kdm: :0[3496]: pam_ck_connector(kdm:session): nox11 mode, ignoring PAM_TTY :0
Jan 23 09:24:58 maple polkitd(authority=local): Registered Authentication Agent for session /org/freedesktop/ConsoleKit/Session7 (system bus name :1.70 [/usr/lib/kde4/libexec/polkit-kde-authentication-agent-1 -session 10d261706c000129503571800000026180009_1295774675_620129], object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)                             
Jan 23 09:25:27 maple polkitd(authority=local): Unregistered Authentication Agent for session /org/freedesktop/ConsoleKit/Session7 (system bus name :1.70, object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)
Jan 23 09:25:27 maple kdm: :0[3496]: pam_unix(kdm:session): session closed for user debian

Failsafe / failure:
Code: Select all
Jan 23 09:25:39 maple kdm: :0[3983]: pam_unix(kdm:session): session opened for user debian by (uid=0)
Jan 23 09:25:39 maple kdm: :0[3983]: pam_ck_connector(kdm:session): nox11 mode, ignoring PAM_TTY :0
Jan 23 09:25:39 maple kdm: :0[3983]: pam_unix(kdm:session): session closed for user debian

which may mean something to an expert but tells me nothing.

I do think the X-session started correctly for in the user's .xsession-errors I have:
Code: Select all
Xsession: X session started for debian at Sun Jan 23 09:17:37 GMT 2011
konsole(2728)/kdeui (kdelibs): Attempt to use QAction "change-profile" with KXMLGUIFactory!
x-terminal-emulator: Fatal IO error: client killed
kDebugStream called after destruction (from virtual Konsole::SessionManager::~SessionManager() file ../../../../apps/konsole/src/SessionManager.cpp line 301)
Konsole SessionManager destroyed with sessions still alive

This brings me back to my original question.

The trace above suggests Konsole session manager has tried to do something it shouldn't but I am wondering if it should be running at all. Under lenny with KDE 3.5, the output of ps in a failsafe session shows x-terminal-emulator is running but there is no konsole process.

The kdmrc files for both lenny and squeeze contain:
Code: Select all
# The program to run if Session fails.
# Default is "/usr/bin/xterm"
#FailsafeClient=

so I was naïvely surprised that x-terminal-emulator is running and not plain old xterm.

I have tried changing kdmrc to make the 'default' explicit but to no effect. I have tried changing kdmrc under /etc/kde4/kdm and the copy under /var/run/kdm.

The question now becomes is there a way to change what the failsafe session runs and, if so, what is it ?
Forester
 
Posts: 14
Joined: 2011-01-01 12:56

Re: KDM Failsafe Session - Not Working ?

Postby schmidtbag » 2011-01-23 14:23

at this point i have no idea, but honestly at this point would it really matter? usually failsafe is only necessary when you have a fresh new install or if you got ALL new hardware, and even then i find it much easier to use the console login and fix from the command line. from what i recall, i don't remember failsafe working for me either. from a command line, you can easily modify your xorg.conf via nano and just run "startx" from there and you get yourself a more effective failsafe.

keep in mind that even debian's unstable, testing, and experimental repos are still VERY far behind with kde, this issue could actually be fixed but WE will never find out because for some stupid reason the devs are anal about making sure things are stable for them, when the kde devs say something along the lines how kde 4.5 and 4.6 were just simply a massive list of bug fixes and some additional widgets. as soon as something breaks my install, i'm switching to arch because i have absolutely had it with how debian's unstable and testing repos still give us stuff thats literally almost an entire year old at this point.
schmidtbag
 
Posts: 222
Joined: 2010-04-14 20:51
Location: MA

Re: KDM Failsafe Session - Not Working ?

Postby BioTube » 2011-01-23 14:51

Is xterm installed? It doesn't seem to be included by default anymore, so it might be your session's closing when there's nothing to run. As for "failing safe", X should default to vesa or fbdev, both of which are generic drivers guaranteed to work on almost all hardware.
Image
Ludwig von Mises wrote:The elite should be supreme by virtue of persuasion, not by the assistance of firing squads.
User avatar
BioTube
 
Posts: 7551
Joined: 2007-06-01 04:34

Re: KDM Failsafe Session - Not Working ?

Postby Forester » 2011-01-23 18:41

BioTube wrote:Is xterm installed? It doesn't seem to be included by default anymore, so it might be your session's closing when there's nothing to run.

I agree with your point that if xterm (or whatever the failsafe login tries to run) is missing then the session would close immediately and that would explain what I am seeing. I can 't say whether xterm was installed originally but I did succeed in starting a twm session and created an xterm from there and think that was before I installed any extra packages whatsoever. In any case, xterm is certainly installed now and it makes no difference. I installed xdm and found I could get to an xterm based failsafe session that way. I switched back to kdm and I'm back to square 1.

BioTube wrote:As for "failing safe", X should default to vesa or fbdev, both of which are generic drivers guaranteed to work on almost all hardware.

Your statement makes perfect sense to me but that is not what I observed. I started by asking if anyone knew what should happen. There is no point submitting a bug report that is so far from the mark it just gets ignored.

I got into this mess by upgrading lenny to squeeze on a machine with a SIS graphics chip set. It seems the (squeeze) sis driver crashes when a KDE session is closed. After the upgrade, for reasons unknown, the KDM greeter was set to failsafe session. So the first time I attempted to log in the session closed immediately and the X server crashed. This same thing happen with the upgrade of two more machines and it seemed to me KDE was very, very broken. Only when I thought I'll try a failsafe session did I discover that failsafe seemed to be part of the problem.

Now I'm looking into this problem using a machine with an Intel graphics chip set and there is no crash when a KDE session is closed: starting a failsafe session simply returns me to the login screen. If failsafe mode were using vesa or fsdev then I would expect behaviour on the Intel machine to be the same as one the SIS machines (but I'm no expert).

schmidtbag wrote:at this point would it really matter?

To those who know what they are doing, perhaps not, which is why such issues don't get fixed. To someone like myself, so long as I learn something from looking at the problem, it's fine. If I was not interested in learning I might still be using a commercial operating system. To a newbie, what I experienced would be enough for them to submit a bug report that would get laughed and that would be enough to persuade them to go elsewhere.

schmidtbag wrote:from a command line, you can easily modify your xorg.conf via nano and just run "startx" from there

See ... I've learnt something useful. Thank you very much for the tip.

schmidtbag wrote:i'm switching to arch

Perhaps Debian is not the best distribution for KDE fans. In which case, I'm definitely posting in the wrong forum !

If I changed distribution every time something went wrong I'd be installing a new one every week. I might even be trying the Great Brown distribution again. Good grief !
Forester
 
Posts: 14
Joined: 2011-01-01 12:56

Re: KDM Failsafe Session - Not Working ?

Postby BioTube » 2011-01-23 18:51

Forester wrote:Now I'm looking into this problem using a machine with an Intel graphics chip set and there is no crash when a KDE session is closed: starting a failsafe session simply returns me to the login screen. If failsafe mode were using vesa or fsdev then I would expect behaviour on the Intel machine to be the same as one the SIS machines (but I'm no expert).
The server's already loaded when the display manager starts(thus loading whatever driver it's going to load); the failsafe session deals with errors in starting a user session, not bugs in the server itself(although you might want to install a simple window manager like Openbox to use instead).
Image
Ludwig von Mises wrote:The elite should be supreme by virtue of persuasion, not by the assistance of firing squads.
User avatar
BioTube
 
Posts: 7551
Joined: 2007-06-01 04:34

Re: KDM Failsafe Session - Not Working ?

Postby schmidtbag » 2011-01-23 19:03

Forester wrote:
schmidtbag wrote:at this point would it really matter?

To those who know what they are doing, perhaps not, which is why such issues don't get fixed. To someone like myself, so long as I learn something from looking at the problem, it's fine. If I was not interested in learning I might still be using a commercial operating system. To a newbie, what I experienced would be enough for them to submit a bug report that would get laughed and that would be enough to persuade them to go elsewhere.

schmidtbag wrote:from a command line, you can easily modify your xorg.conf via nano and just run "startx" from there

See ... I've learnt something useful. Thank you very much for the tip.

schmidtbag wrote:i'm switching to arch

Perhaps Debian is not the best distribution for KDE fans. In which case, I'm definitely posting in the wrong forum !

If I changed distribution every time something went wrong I'd be installing a new one every week. I might even be trying the Great Brown distribution again. Good grief !


idk, i tend to know what i'm doing but sometimes you just gotta deal with the little problems you encounter. i admire your ambition and willingness to learn, you remind me of myself when i first started using linux. but since linux gets broken so easily, you tend to just need to find alternative solutions which is why i told you about logging into a graphical interface thru the command line. currently, i have issues where kwin compositing constantly causes kwin and xorg to tax the cpu. apparently newer versions of kde 4 don't tend to do this, and compiz doesn't do it either. since there is absolutely nothing i can do with what *i* want as of right now, its either turn off kwin compositing (which i use for practical purposes, not eye candy), use compiz, or somehow get debian to bring kde from 4.4.5 to 4.6.x.

interestingly, your comment about choosing to be ignorant and pick a commercial product is similar to picking a commercial product to avoid the problems you would have questions about in the first place. debian is designed to be stable but packages are modified every day, and the debian dev team has to test them if they're stable enough when in actuality, these newer packages could be much more stable. unfortunately, they're caught behind seeing if the previous version is stable, so debian is always going to be behind. i've been told debian isn't the best choice for kde. as i see it, its the best distro for desktop environments that are either simple or don't get updated often such as xfce, lxde, openbox, kde 3, gnome 2, or any kind of server. but if you want cutting-edge (like what kde 4 or gnome 3 is) then you need to look elsewhere, which is what i'll be doing eventually.
schmidtbag
 
Posts: 222
Joined: 2010-04-14 20:51
Location: MA

Re: KDM Failsafe Session - Not Working ?

Postby Forester » 2011-01-30 23:23

Thanks to you both for your input. I am afraid I don't get much time for this kind of thing during the week.

To summarise (and lay this this topic to rest):

- KDM failsafe login under squeeze most likely isn't working as it should
- the Debian project will only fix issues the project introduced
- if I knew how to prove / disprove this issue is a Debian issue I would not be asking questions on this forum.

Catch 22 but thanks anyway.
Forester
 
Posts: 14
Joined: 2011-01-01 12:56

Re: KDM Failsafe Session - Not Working ?

Postby BryanFRitt » 2014-07-17 18:27

schmidtbag wrote:at this point would it really matter? usually failsafe is only necessary when you have a fresh new install or if you got ALL new hardware, and even then i find it much easier to use the console login and fix from the command line.

I find that games, etc... run faster with only an x console/failsafe session running. (or what ever it's called)
Failsafe isn't working for me either, but...

In /usr/share/xsessions you can put *.desktop that point to scripts in /usr/local/bin

It seams there's problems with keyboard and/or mouse input, etc... for a lot of programs doing it this way, perhaps there's a better way, or a workaround for that.

This workaround seams to work for 'Compiz-kde', 'Descent3', 'gnome-terminal', 'smc', and xterm.
Although, I tried with some others that didn't quite work...
Firefox - menus/toolbar didn't respond to mouse/keyboard.
Konqueror - keyboard didn't work
konsole - keyboard didn't work
XBMC - didn't really work, but didn't try again... maybe it was a one time failure?

In playing with this it seams that *.desktop it seams that the Exec line can't have arguments(like a -d...) or quotes(""), and must point to a file that's in the PATH that's available at login.
I don't know all the details behind *.desktop files, but here's what I've got so far for /usr/share/xsessions

ls /usr/share/xsessions -AFR1
/usr/share/xsessions:

    Compiz-KDE.desktop
    Descent3.desktop
    Descent3Test.desktop
    FireFox.desktop
    XBMC.desktop
    gnome-terminal.desktop
    kde-plasma.desktop
    kfcmclient.desktop
    konsole.desktop
    smc.desktop
    smcDebugGame.desktop
    smcDebugPerformance.desktop
    xterm.desktop

cat /usr/share/xsessions/*.desktop
Code: Select all
[Desktop Entry]
Encoding=UTF-8
Type=Type=Application
Exec=/usr/local/bin/Compiz-KDE.sh
TryExec=/usr/local/bin/Compiz-KDE.sh
Name=Compiz-KDE


Code: Select all
[Desktop Entry]
Encoding=UTF-8
Type=Type=Application
Exec=/usr/local/bin/Descent3.sh
TryExec=/usr/local/bin/Descent3.sh
Name=Descent3


Code: Select all
[Desktop Entry]
Encoding=UTF-8
Type=Type=Application
Exec=/usr/local/bin/Descent3Test.sh
TryExec=/usr/local/bin/Descent3Test.sh
Name=Descent3Test
#Type=XSession


Code: Select all
[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=/usr/bin/iceweasel
TryExec=/usr/bin/iceweasel
Name=Iceweasel


Code: Select all
[Desktop Entry]
Name=XBMC
Comment=This session will start XBMC Media Center
Exec=xbmc-standalone
TryExec=xbmc-standalone
Type=Application


Code: Select all
[Desktop Entry]
Encoding=UTF-8
Name=Gnome Terminal
Comment=
Exec=/usr/bin/gnome-terminal
Type=Application


Code: Select all
[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=/usr/bin/startkde
TryExec=/usr/bin/startkde
Name=KDE Plasma Workspace
Name[ar]=مساحة عمل بلازما كدي
Name[bg]=Работно пространство Plasma на KDE
Name[ca]=Espai de treball del Plasma del KDE
Name[ca@valencia]=Espai de treball del Plasma del KDE
Name[cs]=Pracovní plocha Plasma
Name[da]=KDE Plasma arbejdsområde
Name[de]=KDE-Plasma-Arbeitsbereich
Name[el]=Χώρος εργασίας Plasma KDE
Name[es]=Espacio de trabajo Plasma de KDE
Name[et]=KDE Plasma töötsoon
Name[eu]=KDE Plasma langunea
Name[fi]=KDE Plasma-työtila
Name[fr]=Espace de travail Plasma de KDE
Name[ga]=Spás Oibre KDE Plasma
Name[he]=סביבת עבודה של KDE Plasma
Name[hu]=KDE Plasma munkaterület
Name[ia]=Spatio de labor de Plasma de KDE
Name[is]=KDE Plasma-vinnurými
Name[it]=Spazio di lavoro di KDE Plasma
Name[kk]=KDE Plasma жұмыс орны
Name[ko]=KDE Plasma 작업 공간
Name[lt]=KDE Plasma darbastalio erdvė
Name[lv]=KDE Plasma darba vide
Name[nb]=KDE Plasma arbeidsflate
Name[nds]=KDE-Arbeitrebeet Plasma
Name[nl]=KDE Plasma-werkruimte
Name[pa]=KDE ਪਲਾਜ਼ਮਾ ਵਰਕਸਪੇਸ
Name[pl]=Przestrzeń robocza plazmy KDE
Name[pt]=Área de Trabalho Plasma do KDE
Name[pt_BR]=Espaço de trabalho do Plasma do KDE
Name[ro]=Spațiu de lucru Plasma KDE
Name[ru]=Рабочий стол Plasma
Name[sk]=KDE pracovná plocha Plasma
Name[sr]=КДЕ‑ов плазма радни простор
Name[sr@ijekavian]=КДЕ‑ов плазма радни простор
Name[sr@ijekavianlatin]=KDE‑ov plasma radni prostor
Name[sr@latin]=KDE‑ov plasma radni prostor
Name[sv]=KDE Plasma arbetsyta
Name[tr]=KDE Plasma Çalışma Alanı
Name[ug]=ك د ئې(KDE) پلازما خىزمەت بوشلۇقى
Name[uk]=Робочий простір Плазми KDE
Name[x-test]=xxKDE Plasma Workspacexx
Name[zh_CN]=KDE 离子工作空间
Name[zh_TW]=KDE Plasma 工作空間
Comment=The desktop made by KDE
Comment[ar]=سطح المكتب الذي أنتجته كدي
Comment[bg]=Настолна среда KDE
Comment[ca]=L'escriptori creat pel KDE
Comment[ca@valencia]=L'escriptori creat pel KDE
Comment[cs]=Prostředí od KDE
Comment[da]=Skrivebordet fra KDE
Comment[de]=Die von KDE erstellte Arbeitsfläche
Comment[es]=El escritorio diseñado por KDE
Comment[et]=KDE loodud töölaud
Comment[eu]=KDE-k eginiko mahaigaina
Comment[fi]=KDE:n tekemä työpöytä
Comment[fr]=Le bureau réalisé par KDE
Comment[he]=שולחן העבודה של KDE
Comment[hr]=Radna površina koju je napravio KDE
Comment[hu]=A KDE által készített munkaasztal
Comment[ia]=Le scriptorio facite per KDE
Comment[is]=KDE Skjáborð
Comment[it]=Il desktop fatto da KDE
Comment[kk]=KDE үстелі
Comment[ko]=KDE에서 만든 데스크톱
Comment[lt]=Darbastalis sukurtas su KDE
Comment[lv]=KDE veidota darbvirsma
Comment[nb]=Skrivebordet som KDE laget
Comment[nds]=KDE-Schriefdisch
Comment[nl]=Het bureaublad gemaakt door KDE
Comment[pa]=KDE ਵਲੋਂ ਬਣਾਇਆ ਡੈਸਕਟਾਪ
Comment[pl]=Pulpit stworzony przez KDE
Comment[pt]=O ambiente de trabalho feito pelo KDE
Comment[pt_BR]=O ambiente de trabalho feito pelo KDE
Comment[ro]=Biroul creat de KDE
Comment[ru]=Окружение рабочего стола от команды KDE
Comment[sk]=Pracovná plocha vytvorená KDE
Comment[sr]=Радна површ у изведби КДЕ‑а
Comment[sr@ijekavian]=Радна површ у изведби КДЕ‑а
Comment[sr@ijekavianlatin]=Radna površ u izvedbi KDE‑a
Comment[sr@latin]=Radna površ u izvedbi KDE‑a
Comment[sv]=Skrivbordet skapat av KDE
Comment[tr]=KDE tarafınndan oluşturulan masaüstü
Comment[ug]=بۇ ئۈستەلئۈستى KDE دا ياسالغان
Comment[uk]=Стільниця, створена командою KDE
Comment[x-test]=xxThe desktop made by KDExx
Comment[zh_CN]=KDE 制作的桌面
Comment[zh_TW]=KDE 製作的桌面


Code: Select all
[Desktop Entry]
Encoding=UTF-8
Type=Applcation
Exec=/usr/local/bin/Konqueror.sh
TryExec=/usr/local/bin/Konqueror.sh
Name=Konqueror


Code: Select all
[Desktop Entry]
Encoding=UTF-8
Type=Application
Exec=/usr/local/bin/StartKonsoleSession.sh
TryExec=/usr/local/bin/StartKonsoleSession.sh
Name=Konsole


Code: Select all
[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=/usr/games/smc
TryExec=/usr/games/smc
Name=Secret Maryo Canonicals


Code: Select all
[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=/usr/local/bin/SecretMaryoCanonicalsDebugGameMode.sh
TryExec=/usr/local/bin/SecretMaryoCanonicalsDebugGameMode.sh
Name=Secret Maryo Canonicals Debug Game Mode


Code: Select all
[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=/usr/local/bin/SecretMaryoCanonicalsDebugPerformanceMode.sh
TryExec=/usr/local/bin/SecretMaryoCanonicalsDebugPerformanceMode.sh
Name=Secret Maryo Canonicals Debug Performance Mode


Code: Select all
[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=/usr/bin/xterm
TryExec=/usr/bin/xterm
Name=xterm


---

[comments, etc... only somewhat cleaned up on this...]

cat /usr/local/bin/*.sh
Code: Select all
#!/usr/bin/env bash
export KDEWM="/opt/Compiz-0.9.10-bzr/bin/start-compiz.sh" && startkde

Code: Select all
#!/usr/bin/env bash
LD_PRELOAD=/usr/local/lib/Loki_Compat/libstdc++-3-libc6.2-2-2.10.0.so:/usr/local/lib/Loki_Compat/libsmpeg-0.4.so.0.1.3:/usr/local/lib/Loki_Compat/libGL.so /usr/local/games/Descent3/descent3.dynamic -c -n -F 60 -o -G
#echo "Descent3Test.sh has been run";

Code: Select all
#!/usr/bin/env bash
set -m
ksysguard --geometry=1920x1200+0+0 &
sleep 1
LD_PRELOAD=/usr/local/lib/Loki_Compat/libstdc++-3-libc6.2-2-2.10.0.so:/usr/local/lib/Loki_Compat/libsmpeg-0.4.so.0.1.3:/usr/local/lib/Loki_Compat/libGL.so /usr/local/games/Descent3/descent3.dynamic -c -n -F 60 -o -G;
fg
#ksysguard --geometry=1920x1200+0+0 & nvidia-settings && LD_PRELOAD=...
# && echo "Descent3Test.sh has been run"

Code: Select all
#!/usr/bin/env bash
# works but no keyboard input, can use mouse
dbus-launch --exit-with-session konqueror --geometry=1920x1200+0+0 "/";

Code: Select all
#!/usr/bin/env sh
/usr/games/smc -d game

Code: Select all
#!/usr/bin/env sh
/usr/games/smc -d performance

Code: Select all
#!/usr/bin/env bash
# My attempt to start konsole window from login screen, without it closing right away
# It seams that sessions end automatically if there's nothing in the forground.
# aka if ran with '&' at the end
# and the deskop files can't take arguments, so they have to be put in scripts
# Maybe only one is needed of "--noclose" or "--nofork"?
# "FullScreen" is a konsole profile I made
# with
# /usr/bin/konsole --geometry 1920x1200+0+0 --profile FullScreen --noclose --nofork
# This made konsole window stay open but couldn't type anything in.
# When run manually from a konsole shell in KDE
# Konsole::SessionManager::loadProfile: Could not load profile from  ""
# without "--nofork" it just closed, (or was it without --noclose ?)
# with just "--nofork" or with both "--nofork" and "--noclose" it didn't close by itself, but it didn't accept keyboard input
# with just "--noclose" it closed automatically
# "--background-mode" seams to do everything like before except it waits until F12 is pressed.
#set -m
# Without keyboard input this is pretty much useless :(
# adding this 1st part didn't help any...
#setxkbmap -model latitude -layout us -variant dvorak && sleep 1 &&
/usr/bin/konsole --geometry 1920x1200+0+0 --noclose --nofork
#--background-mode -e "" &
#fg

---

Question(s) still have:
What's the difference between Exec and TryExec ?
Are spaces, etc... in the Exec ok?

--

An easier way to test these is to try out Ctrl+Alt+F1..F6 for editing with sudo nano FILE_TO_EDIT, then come back to Ctrl+Alt+F7..., then Alt+E, and try again. That way you don't have to waste time logging in/out of the kde, etc... :D
BryanFRitt
 
Posts: 21
Joined: 2014-02-08 19:36


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 21 guests

fashionable