Howto: realtek alc888b input and output

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Howto: realtek alc888b input and output

Postby crackbaby » 2011-01-28 15:40

Had to get this info out there somewhere... took me days to figure it out.

MotherBoard: Gigabyte GA-H55M-S2V
Manufacturer claims ALC888B, system reports ALC887

I had sound using the workaround,
Code: Select all
echo "options snd_hda_intel model=generic" >> /etc/modprobe.d/alsa-base.conf


But it was partial support, at best. I had no capture support and mixer was all wrong.

Code: Select all
$ lspci | grep Audio

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)

Got it working, as shown...

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0


Roughly follow these instructions:
http://wiki.debian.org/DebianEeePC/HowTo/Sound#InstallanupdatedAlsadriver

Get bleeding edge alsa-drivers: http://www.alsa-project.org/snapshot/ (alsa-driver-1.0.24.0.g4f822.0.g1a4b1.tar.bz2 at time of writing)
This implements many fixes for HDA: http://www.alsa-project.org/main/index.php/Changes_v1.0.23_v1.0.24#alsa-firmware
Ensure you have linux headers installed.
Code: Select all
$ sudo aptitude install linux-headers-2.6-686
$ tar -xjf alsa-driver-1.0.24.0.g4f822.0.g1a4b1.tar.bz2
$ cd alsa-driver-1.0.24.0.g4f822.0.g1a4b1
$ ./configure ./configure --with-cards=hda-intel --with-card-options=all
$ make -j5 # if you have these problems you probably have a modern quad core
$ sudo make install
$ ls -al `locate snd-hda-intel.ko`
-rw-r--r-- 1 root root 38724 Jan 27 23:05 /lib/modules/2.6.32-5-686/kernel/sound/pci/hda/snd-hda-intel.ko

This should report recent modules timestamp

Finally, clear any options in alsa-base.conf you may have made, the default options pick up the card now.

Now reboot. If you load try to reload modules now you will likely have trouble.
That should do it. Use alsamixer to adjust volume.
crackbaby
 
Posts: 1
Joined: 2011-01-28 15:32

Re: Howto: realtek alc888b input and output

Postby rozhkovdmitriy » 2011-06-12 15:30

Thanks a lot!!!
rozhkovdmitriy
 
Posts: 1
Joined: 2011-06-12 15:28

Howto: realtek alc888b input and output

Postby CertainQuirk » 2012-06-25 05:25

Thank you! After addting the 'options snd_hda_intel model=generic' I was given one master control. Progress :) .

Anyway, after some further research I found this bug report on Ubuntu ( https://bugs.launchpad.net/ubuntu/+sour ... bug/910141 ) with the suggestion to add 'options snd_hda_intel model=auto' and after days of dealing with this, I too have full control of my sound card. Yes!

Will check Debian bugs later and complete a report if it isn't already there.

Thanks again crackbaby.
User avatar
CertainQuirk
 
Posts: 13
Joined: 2008-06-05 03:33
Location: High Dry Plains of Colorado

Re: Howto: realtek alc888b input and output

Postby CertainQuirk » 2012-06-26 04:41

Filed a bug report to Debian alsa-base: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=679056
User avatar
CertainQuirk
 
Posts: 13
Joined: 2008-06-05 03:33
Location: High Dry Plains of Colorado


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable