Help: I can't open my CD

Kernels & Hardware, configuring network, installing services

Help: I can't open my CD

Postby janpla » 2011-03-01 15:44

Is there a way to permanently, completely and utterly disabling the "feature" that stops me from opening my CD drive? I suspect it is the same thing that asks me if I want to play/mount/etc things when I plug them in. I don't - I just want to be allowed to use my computer without silly hindrances and interruptions. What is it that tries to take over my computer in this way?
janpla
 
Posts: 36
Joined: 2007-07-03 08:23

Re: Help: I can't open my CD

Postby eric1959 » 2011-03-01 15:51

Debian Bits And Snips
Squeeze, Gnome, amd64, Intel Core i3-530, Geforce GT330
eric1959
 
Posts: 1299
Joined: 2008-12-15 13:17
Location: Amsterdam

Re: Help: I can't open my CD

Postby janpla » 2011-03-01 16:54

http://ubuntulinuxhelp.com/quick-tip-wh ... r-cd-back/

Code: Select all
Forbidden
You don't have permission to access this server.
Your Details have been logged as:
IP: 92.28.196.183
User Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.0.19) Gecko/2010120923 Iceweasel/3.0.6 (Debian-3.0.6-3)
Referrer:http://forums.debian.net/viewtopic.php?f=5&t=61041
janpla
 
Posts: 36
Joined: 2007-07-03 08:23

Re: Help: I can't open my CD

Postby eric1959 » 2011-03-01 17:55

janpla wrote:http://ubuntulinuxhelp.com/quick-tip-wh ... r-cd-back/

Code: Select all
Forbidden
You don't have permission to access this server.
Your Details have been logged as:
IP: 92.28.196.183
User Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.0.19) Gecko/2010120923 Iceweasel/3.0.6 (Debian-3.0.6-3)
Referrer:http://forums.debian.net/viewtopic.php?f=5&t=61041

You can't reach the page.......?

http://goo.gl/8Z95Y
Debian Bits And Snips
Squeeze, Gnome, amd64, Intel Core i3-530, Geforce GT330
eric1959
 
Posts: 1299
Joined: 2008-12-15 13:17
Location: Amsterdam

Re: Help: I can't open my CD

Postby Sephiroth » 2011-03-01 21:32

That's too time-consuming. You can simply use the USB icon (can't remember the widget name) in KDE4. Just click it, and click the eject icon next to your CDROM. This way root or a shell isn't required.
Intel C2Q 3.06GHz, 8GB PC-10600, Dual 250GB SATA 3.0GBps RAID-0, Dual GTX295 2GB, X-Fi Gamer
P4/3.20GHz HT, 2GB DDR400, 120GB SATA, 7800GS 256MB, Audigy IV w/4.1 Speakers
AMD Turion64x2 1.60GHz, 1GB DDR2(667), 120GB PATA, ATI1100M
Sephiroth
 
Posts: 1012
Joined: 2007-07-05 03:30
Location: North Carolina, USA

Re: Help: I can't open my CD

Postby mslinux » 2011-03-02 03:08

Or open a terminal and execute
Code: Select all
$ eject
MsLinux-

forums.debian.net - where facepalm is the default answer :D

© 2012
║▌║│█║▌│█│║▌║█║▌│█│║▌║│
User avatar
mslinux
 
Posts: 942
Joined: 2010-12-24 05:14

Re: Help: I can't open my CD

Postby janpla » 2011-03-02 05:55

Wow, things happen fast here.

eric: Yes, I can't reach the page - I was in a bit of a hurry and didn't quite look at what I was doing. Or I couldn't, I'll give a try again in a moment.

Sephiroth: I'm still using KDE3; I haven't had the time to learn KDE4 yet. It does certain things differently, and KDE3 sort of sits in my fingers. Apart from that - I really want to get rid of whatever tries to do things for me, like automatically mounting CDs and other stuff.

mslinux: I know "eject"; but a CD that I havn't explicitly mounted should not be locked in the drive so that I can't use the button on the drive directly.
janpla
 
Posts: 36
Joined: 2007-07-03 08:23

Re: Help: I can't open my CD

Postby janpla » 2011-03-02 05:57

eric: I still can't reach http://ubuntulinuxhelp.com/quick-tip-wh ... r-cd-back/ - same error. It is your site? It would seem there are some permission setting that are wrong.
janpla
 
Posts: 36
Joined: 2007-07-03 08:23

Re: Help: I can't open my CD

Postby mslinux » 2011-03-02 08:18

CD that I havn't explicitly mounted should not be locked in the drive

That is wierd. I'm testing it right now.
Put a cd on the drive, close it, it's automounted
Code: Select all
/dev/sr0 on /media/cdrom0 type iso9660 (ro,noexec,nosuid,nodev,user=redbull)

press on eject button...tada...it opens. ( I've been doing it a couple times now. It's kinda fun )

For disabling automounting in KDE, perhaps there is something in here KDE Control Center -> Peripherals -> Storage Media
I don't use KDE so I'm not sure. But your problem is interesting.
MsLinux-

forums.debian.net - where facepalm is the default answer :D

© 2012
║▌║│█║▌│█│║▌║█║▌│█│║▌║│
User avatar
mslinux
 
Posts: 942
Joined: 2010-12-24 05:14

Re: Help: I can't open my CD

Postby eric1959 » 2011-03-02 14:32

janpla wrote:eric: I still can't reach http://ubuntulinuxhelp.com/quick-tip-wh ... r-cd-back/ - same error. It is your site? It would seem there are some permission setting that are wrong.

No, it's not my site......Weird that you cannot reach it....you've tried http://goo.gl/8Z95Y as well ?
So I just copy what the site said :

Just a quick tip I wanted to pass on today. Have you ever had the issue where you want to eject your CD, but it will not eject; no matter how many times you press the eject button? Annoying isn't it? :) I remember when I first started using Linux, years ago, (my OS was RedHat then), I actually would reboot the system just to get the CD out! Obviously, that's not too smart.

One of my friends (a brand new user) just ran into this issue. He phoned me because he thought it was a bug. (It's not). For any new users out there. Here is a quick fix to force the CD to eject:

sudo umount /media/cdrom0/ -l

Just run the above command in a terminal, and you'll get your CD back.
Debian Bits And Snips
Squeeze, Gnome, amd64, Intel Core i3-530, Geforce GT330
eric1959
 
Posts: 1299
Joined: 2008-12-15 13:17
Location: Amsterdam

Re: Help: I can't open my CD

Postby tymonu » 2011-04-01 17:31

i had a similar issue until i removed my cd drive from fstab.
simply (i use the root terminal -- otherwise you will need to su)
Code: Select all
gedit /etc/fstab

or whichever editor you are comfortable with and remove any line under:

sw 0 0

sometimes your cd drive gets added to the fstab list cause that is the media you used to install with.
The line should something similar to
/dev/sr0/********* /media/cdrom0 ****

any line under the
sw 0 0

is probably safe to remove, just be sure not to remove your hard drive partitions or swap partition from this list.
This will also cause your removable media to be mounted under the label name instead of under the sudo folder.
fstab takes control of your drives and poof you loose control under a normal user. Remove the removable media from fstab and poof the problem is gone.
was thinking you were looking for a way not to have to force it to eject everytime you want to unmount a disk.
Most problems are permissions as linux is set to a very strict security permission standard, always check permissions first.
You may have to restart in order for these changes to take effect.
Hope this helps
What's this script do? unzip ; touch ; finger ; mount ; gasp ; yes ; umount ; sleep
Hint for the answer: not everything is computer-oriented. Sometimes you're
in a sleeping bag, camping out with your girlfriend.
-- Frans van der Zande
tymonu
 
Posts: 27
Joined: 2011-02-03 20:09


Return to System configuration

Who is online

Users browsing this forum: No registered users and 21 guests

fashionable