[SOLVED]Authentication failure

If none of the more specific forums is the right place to ask

[SOLVED]Authentication failure

Postby henkoegema » 2011-12-22 15:03

I'm installing Debian 6.0.3 as a server.

At the end of the installation process the system reboots and I must login.
I try to login as root. However the system does not except my password. I get message: Authentication failure. :roll:

Login as normal user is ok.

So, I did a new install and paid extra attention to my password. However the same result. Again I can't login. :(

(my password for root and user are the same. but I've always done that and it always worded fine)
Last edited by henkoegema on 2011-12-22 21:22, edited 1 time in total.
henkoegema
 
Posts: 18
Joined: 2009-06-08 09:09

Re: Authentication failure

Postby edbarx » 2011-12-22 16:48

I think, your problem has to do with the fact that you have identical root and user password. Try to create another user as root and choose another password.
Debian aims for {freedom, reliability, stability, configurability, flexibility, security}
It is hard to get away from CLI tools.
User avatar
edbarx
 
Posts: 4671
Joined: 2007-07-18 06:19
Location: 35° 50 N, 14 º 35 E

Re: Authentication failure

Postby roseway » 2011-12-22 18:31

There's no problem having the same passwords for root and the user.
Eric
User avatar
roseway
 
Posts: 1353
Joined: 2007-12-31 22:50
Location: Kent, UK

Re: Authentication failure

Postby vbrummond » 2011-12-22 18:48

If you are a normal user try to su. Does it work? If not your root password is either different or non-existant.
Code: Select all
su


Next try to use sudo to login as root. Use the password for your normal user. If it does not work, you are not using sudo (this is normal). If it does, you probably disabled the root account during the install somehow.
sudo su


If both do not work try to reboot into recovery mode however even then the password might not work. If you manage to get a root shell open somehow run;
passwd root


Then you can change it to what you want.
vbrummond
 
Posts: 4344
Joined: 2010-03-02 01:42

Re: Authentication failure

Postby henkoegema » 2011-12-22 21:21

In recovery mode I automatically logged in as root.
Than I could set a new password. Now it works OK. :D

Thanks very much.
henkoegema
 
Posts: 18
Joined: 2009-06-08 09:09


Return to General Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable