Problem installing gcc 4.3

Kernels & Hardware, configuring network, installing services

Problem installing gcc 4.3

Postby snowape » 2012-02-24 20:31

I run Debian stable with some packages from backports. When I try to install gcc-4.3 (with apt-get) I get an error complaining about a bunch of dependencies which aren't met. However when I look at those dependencies I see that they actually are met. Whats going on?

Code: Select all
>>>sudo apt-get install gcc-4.3
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gcc-4.3 : Depends: cpp-4.3 (= 4.3.5-4) but it is not going to be installed
           Depends: binutils (>= 2.19.1) but it is not going to be installed
           Depends: libgcc1 (>= 1:4.3.5-4) but it is not going to be installed
           Depends: libgomp1 (>= 4.3.5-4) but it is not going to be installed
           Recommends: libc6-dev (>= 2.5) but it is not going to be installed
 libc6 : Depends: libgcc1 but it is not going to be installed
 libcap2 : Depends: libattr1 (>= 2.4.41-1) but it is not going to be installed
 libice6 : Depends: x11-common but it is not going to be installed
 libpulse0 : Depends: libsndfile1 (>= 1.0.20) but it is not going to be installed
 libsdl1.2debian : Depends: libsdl1.2debian-alsa (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-all (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-esd (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-arts (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-oss (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-nas (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-pulseaudio (= 1.2.14-6.1) but it is not going to be installed
 libsm6 : Depends: libuuid1 (>= 2.16) but it is not going to be installed
 libxcb1 : Depends: libxau6 but it is not going to be installed
           Depends: libxdmcp6 but it is not going to be installed
 libxtst6 : Depends: libxext6 but it is not going to be installed
            Depends: libxi6 but it is not going to be installed
            Depends: x11-common but it is not going to be installed
E: Broken packages

>>>dpkg -l "cpp*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                Version                             Description
+++-===================================-===================================-======================================================================================
ii  cpp                                 4:4.6.2-4                           GNU C preprocessor (cpp)
ii  cpp-4.3                             4.3.5-4                             The GNU C preprocessor
ii  cpp-4.4                             4.4.6-14                            GNU C preprocessor
ii  cpp-4.6                             4.6.2-15                            GNU C preprocessor
un  cpp-doc                             <none>                              (no description available)

>>>dpkg -l "binutils*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                Version                             Description
+++-===================================-===================================-======================================================================================
ii  binutils                            2.22-4                              GNU assembler, linker and binary utilities
un  binutils-doc                        <none>                              (no description available)
un  binutils-gold                       <none>                              (no description available)

>>>dpkg -l "libgcc1*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                Version                             Description
+++-===================================-===================================-======================================================================================
ii  libgcc1                             1:4.6.2-15                          GCC support library
un  libgcc1-dbg                         <none>                              (no description available)

>>>dpkg -l "libgomp1*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                Version                             Description
+++-===================================-===================================-======================================================================================
ii  libgomp1                            4.6.2-15                            GCC OpenMP (GOMP) support library
un  libgomp1-dbg                        <none>                              (no description available)
>
snowape
 
Posts: 10
Joined: 2012-01-18 20:03

Re: Problem installing gcc 4.3

Postby bw123 » 2012-02-24 22:31

take a look in aptitude and see if that helps, it's pretty smart.
wheezy/KDE4, GNU/Linux 3.14-0.bpo.1-amd64
User avatar
bw123
 
Posts: 1839
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Problem installing gcc 4.3

Postby edbarx » 2012-02-24 22:34

Did you try: apt-get install -f?

This can repair your system if there is something broken.
Learning how to learn from the mistakes of others is far more efficient. It's also less painful. (dasein)
Debian = {freedom, reliability, stability, configurability, flexibility, security}
It's hard to get away from apt and the CLI tools!
User avatar
edbarx
 
Posts: 4455
Joined: 2007-07-18 06:19
Location: 35° 50 N, 14 º 35 E

Re: Problem installing gcc 4.3

Postby snowape » 2012-02-24 22:58

Thanks for the tips. I did try apt-get install -f, but it didn't need to fix anything, and running apt-get install gcc-4.3 afterwards gave the same output.

Trying with aptitude also failed:
Code: Select all
>>>sudo aptitude install gcc-4.3
The following NEW packages will be installed:
  gcc-4.3
0 packages upgraded, 1 newly installed, 0 to remove and 170 not upgraded.
Need to get 0 B/2,604 kB of archives. After unpacking 4,334 kB will be used.
The following packages have unmet dependencies:
  libgcc1: Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is to be installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     gcc-4.3 [Not Installed]                           



Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 170 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
                                         


But at least it gives me a hint of whats wrong, it seems gcc wants a version of libgcc1 lower than 4.3.6-1. The version on my system is 4.6.2-15. Is it possible to install multiple versions of libgcc1? I couldn't find them with apt-cache search.
Code: Select all
>>>dpkg -l "libgcc*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                Version                             Description
+++-===================================-===================================-======================================================================================
ii  libgcc1                             1:4.6.2-15                          GCC support library
un  libgcc1-dbg                         <none>                              (no description available)
snowape
 
Posts: 10
Joined: 2012-01-18 20:03

Re: Problem installing gcc 4.3

Postby kmathern » 2012-02-25 02:05

snowape wrote:I run Debian stable with some packages from backports. When I try to install gcc-4.3 (with apt-get) I get an error complaining about a bunch of dependencies which aren't met. However when I look at those dependencies I see that they actually are met. Whats going on?

Code: Select all
>>>sudo apt-get install gcc-4.3
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gcc-4.3 : Depends: cpp-4.3 (= 4.3.5-4) but it is not going to be installed
           Depends: binutils (>= 2.19.1) but it is not going to be installed
           Depends: libgcc1 (>= 1:4.3.5-4) but it is not going to be installed
           Depends: libgomp1 (>= 4.3.5-4) but it is not going to be installed
           Recommends: libc6-dev (>= 2.5) but it is not going to be installed
 libc6 : Depends: libgcc1 but it is not going to be installed
 libcap2 : Depends: libattr1 (>= 2.4.41-1) but it is not going to be installed
 libice6 : Depends: x11-common but it is not going to be installed
 libpulse0 : Depends: libsndfile1 (>= 1.0.20) but it is not going to be installed
 libsdl1.2debian : Depends: libsdl1.2debian-alsa (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-all (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-esd (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-arts (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-oss (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-nas (= 1.2.14-6.1) but it is not going to be installed or
                            libsdl1.2debian-pulseaudio (= 1.2.14-6.1) but it is not going to be installed
 libsm6 : Depends: libuuid1 (>= 2.16) but it is not going to be installed
 libxcb1 : Depends: libxau6 but it is not going to be installed
           Depends: libxdmcp6 but it is not going to be installed
 libxtst6 : Depends: libxext6 but it is not going to be installed
            Depends: libxi6 but it is not going to be installed
            Depends: x11-common but it is not going to be installed
E: Broken packages

>>>dpkg -l "cpp*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                Version                             Description
+++-===================================-===================================-======================================================================================
ii  cpp                                 4:4.6.2-4                           GNU C preprocessor (cpp)
ii  cpp-4.3                             4.3.5-4                             The GNU C preprocessor
ii  cpp-4.4                             4.4.6-14                            GNU C preprocessor
ii  cpp-4.6                             4.6.2-15                            GNU C preprocessor
un  cpp-doc                             <none>                              (no description available)

>>>dpkg -l "binutils*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                Version                             Description
+++-===================================-===================================-======================================================================================
ii  binutils                            2.22-4                              GNU assembler, linker and binary utilities
un  binutils-doc                        <none>                              (no description available)
un  binutils-gold                       <none>                              (no description available)

>>>dpkg -l "libgcc1*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                Version                             Description
+++-===================================-===================================-======================================================================================
ii  libgcc1                             1:4.6.2-15                          GCC support library
un  libgcc1-dbg                         <none>                              (no description available)

>>>dpkg -l "libgomp1*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                Version                             Description
+++-===================================-===================================-======================================================================================
ii  libgomp1                            4.6.2-15                            GCC OpenMP (GOMP) support library
un  libgomp1-dbg                        <none>                              (no description available)
>

You must have had the sid or wheezy repos enabled at some point in time because you have several sid/wheezy version packages. The packages you listed: cpp, cpp-4.4, cpp-4.6, libgcc1, libgomp1 are all at the versions currently in sid & wheezy. The binutils package that you have installed is also a lot newer than the 2.20.1-16 squeeze version. You have version 2.22-4, the sid/wheezy version is currently 2.22-5.

You can try aptitude again. Answer 'no' to the first solution it comes up with and see if it comes up with some other solutions. Depending on what else has been installed & upgraded from sid/wheezy, aptitude may not be able to come up with a solution that doesn't involve removing things.
kmathern
 
Posts: 501
Joined: 2011-02-05 19:20

Re: Problem installing gcc 4.3

Postby vbrummond » 2012-02-25 03:16

The only solution is to remove or manually downgrade all non-squeeze packages; Or full upgrade to wheezy/sid. I recommend the former unless you are not skilled at apt in which case you should backup important files and reinstall. Do not mix sources it simply does not work.
vbrummond
 
Posts: 4344
Joined: 2010-03-02 01:42

Re: Problem installing gcc 4.3

Postby snowape » 2012-02-25 13:53

Yes you're both right, the packages installed from unstable seems to be the problem. I had to install gcc-4.6 to be able to install the nvidia driver for my card, and I will need gcc-4.6 again if I ever upgrade the kernel. I have now downgraded everything which works but I no longer have access to gcc-4.6. Is there any way for gcc-4.6 and gcc-4.3 to coexist on a system?
snowape
 
Posts: 10
Joined: 2012-01-18 20:03


Return to System configuration

Who is online

Users browsing this forum: ZabrielZacob and 14 guests

fashionable