Problems with Sarge to read CD-ROM =(

Help with issues regarding installation of Debian

Problems with Sarge to read CD-ROM =(

Postby junkman » 2006-07-21 08:46

Hello!

I have downloaded and burned the Debian Netinst CD and when I wanted to try it out on my old computer, the installation program went stuck just before the message "Scanning CD-ROM".

I have seen this and I know why it happens (I was an ex-Ubuntu user). THe problem lies in the boot-parameters, where I have to specify "linux pci=off" to have the CD-ROM mounted properly, but then I have the problem that Debian can't find my Ethernet card. :(

Eversince I use the "linux pci=off" boot option, the Ethernet card doesn't work, but my CD-ROM works (mounts).
But if I don't use the "linux pci=off" boot option, then the Ethernet card works, but my CD-ROM doesn't.

Is there any solution?
I am sure there's another boot parameter I need to use but at the moment I don't know what it is.

My computer specs:

Intel Pentium II 350Mhz
192Mb RAM
ATI Rage Pro II

Thank you very much!
I hope to be a happy Debian user, thank you :o
Debian, a mystery..
junkman
 
Posts: 35
Joined: 2006-07-21 08:36

Postby anystupidassname » 2006-08-02 16:00

Sounds like there might be a resource conflict. Try disabling as much as possible in the BIOS and forcing ACPI data to be rebuilt/redetected. You can even try moving PCI devices around to different slots. Alternatively, you could try booting from a floppy such as "bootable CD loader" (http://www.bcdwb.de/bcdw/bcdl150z.zip) and telling it to boot from the CD.
anystupidassname
 
Posts: 26
Joined: 2006-08-02 15:04

Postby Harold » 2006-08-02 22:58

Somewhere in your BIOS setup is a line which says something to the effect of "Are you using a PnP Operating System? [y/n]." The first thing you want to check is that BIOS setting. Linux is not a PnP operating system.

I know this sounds like strange advice, but, if your BIOS already indicates that you are not using a PnP operating system, then try flipping the switch to the other position to see what happens.

If you want more background on this, Google for linux AND bios AND pnp.
Harold
 
Posts: 1502
Joined: 2005-01-07 00:15

Postby junkman » 2006-08-07 15:19

Hi!
Thank you for your replies.
I have already disabled the PnP setting and everyhing else that's not needed. I also have tried to play with my hardware (moving stuff to other slots, etc.)

But nothing worked, I have not yet tried the 'bootable CD loader' but I think it might help me.

Thank you!
Debian, a mystery..
junkman
 
Posts: 35
Joined: 2006-07-21 08:36


Return to Installation

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable