[SOLVED] squeeze boot error - wrongly identified disc

If none of the more specific forums is the right place to ask

[SOLVED] squeeze boot error - wrongly identified disc

Postby fugazz » 2012-05-01 20:52

Hi folks,
I have troubles with upgrading lenny->squeeze. I need your hints, because I stuck.

when I boot into "new" (squeeze) kernel 2.6.32-5-686, I end up in initramfs with next error:
Code: Select all
Gave up waiting for root device.  Common problems:
...
ALERT!  /dev/disk/by-uuid/350b44f4-442e-45ec-85f2-a37cccabf4fe does not exist.
Dropping to shell!


blkid is showing
Code: Select all
/dev/sda: UUID="LSI     ■M-^F'M-C" TYPE="ddf_raid_member"
/dev/sdb: UUID="39c7c093-40f3-6b9f-a77e-69a8a221448e" TYPE="linux_raid_member"
/dev/sdc: UUID="39c7c093-40f3-6b9f-a77e-69a8a221448e" TYPE="linux_raid_member"
/dev/md0p1: UUID="66f5a86b-2280-ade3-01e0-c90ae16560d8" TYPE="linux_raid_member"


Where first line is strange, because /dev/sda is not member of raid. I would expect the same thing that I get when I boot into "old" kernel (lenny 2.6.26-1-686):
Code: Select all
/dev/sda1: UUID="350b44f4-442e-45ec-85f2-a37cccabf4fe" TYPE="ext3"
/dev/sda5: TYPE="swap" UUID="bbbe6e33-8c33-460c-b293-9056171f17bf"
/dev/sdb: UUID="39c7c093-40f3-6b9f-a77e-69a8a221448e" TYPE="linux_raid_member"
/dev/sdc: UUID="39c7c093-40f3-6b9f-a77e-69a8a221448e" TYPE="linux_raid_member"


because /dev/sda is relatively simply partitioned (here is the output of "fdisk -l /dev/sda"):
Code: Select all
Device     Boot    Start    End     Blocks      Id     System
/dev/sda1     *       1   9399     75497436     83     Linux
/dev/sda2          9400   9729     2650725       5     Extended
/dev/sda5          9400   9729     2650693+     82     Linux swap / Solaris

( /dev/sda is 80GB SATA disc, so I cannot use the solution for PATA which is described in different topic on this forum)

I feel, that my problem is somehow linked with mdadm (I have sdb and sdc grouped in raid-1) and its position in initramfs sequence. Maybe your answers on next question could help me:
How to change order of things, that initramfs do?
How to disable mdadm in initramfs? (I do not need raid to boot)
How to tell initramfs not to treat /dev/sda as a member of raid?

Thanks Vlad
Last edited by fugazz on 2012-06-03 18:47, edited 1 time in total.
fugazz
 
Posts: 2
Joined: 2012-05-01 20:11

Re: squeeze boot error - wrongly identified disc

Postby debianfiddler » 2012-05-09 08:04

Do you have a motherboard with both SATA and IDE drives?
I had trouble when squeeze decided that the first ide drive was now /dev/sda, where lenny used the first SATA as /dev/sda, even when the motherboard bios was changed to look at the SATA first.
I also hadn't labelled the disk partitions and once that was done and both /etc/fstab and /boot/grub/menu.lst updated, the that waiting for root device went away.
debianfiddler
 
Posts: 20
Joined: 2012-05-02 10:04

Re: squeeze boot error - wrongly identified disc

Postby fugazz » 2012-06-03 18:46

No, I have only SATA discs. The error was hidden elsewhere. The update of mdadm and lvm2 together damaged the lvm logical discs, that became unreachable. My error was, that my initramfs was set to assemble both raid and logical discs during boot, even though I do not need them to boot. (My user data, not the system are placed on raid array, which is partitioned by lvm.) And the boot stopped on error during assembly of lvm discs, which appeared before recognition of physical disc dev/sda, which is essential for boot.

What I did was uninstall of mdadm and lvm, then I updated initramfs and installed mdadm and lvm back. Now I know, that it was not necessary, dpkg-reconfigure of both would be enough, there is question, whether raid disc and logical discs should be available during boot or not.

I have two lessons - do not use things on place, where you do not need them; and take care about error messages (because the lvm continuously reported, that it is unable to create logical discs).
fugazz
 
Posts: 2
Joined: 2012-05-01 20:11


Return to General Questions

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable