Asterisk installation

If none of the more specific forums is the right place to ask

Asterisk installation

Postby simoncfc » 2012-05-07 15:56

i am attempting to install asterisk 1.8 on debian 6 but receive an error when i try and install ncurses cannot locate ncurses. i have tried to apt-get build-essential but am greeted with a no such command. any ideas? i have tried to install on unbuntu but apparently it does not work so now debian is my last option and i need help
simoncfc
 
Posts: 8
Joined: 2012-05-07 15:50

Re: Asterisk installation

Postby vbrummond » 2012-05-07 16:19

It would help if you researched the correct commands and operating system names. :) The command is apt-get install build-essential. Also if looking for ncurses you probably need apt-get install libncurses5-dev. Though asterisk is already in Debian, in stable it is version 1.6. The version in testing is 1.8. If you specifically need 1.8 you will need to compile it yourself or upgrade (the whole system) to testing. If 1.6 is fine just run (as root)
Code: Select all
apt-get install asterisk
Debian cd image FAQ: https://www.debian.org/CD/faq/ | Always back up your data.
vbrummond
 
Posts: 4219
Joined: 2010-03-02 01:42
Location: USA

Re: Asterisk installation

Postby simoncfc » 2012-05-07 18:33

vbrummond wrote:It would help if you researched the correct commands and operating system names. :) The command is apt-get install build-essential. Also if looking for ncurses you probably need apt-get install libncurses5-dev. Though asterisk is already in Debian, in stable it is version 1.6. The version in testing is 1.8. If you specifically need 1.8 you will need to compile it yourself or upgrade (the whole system) to testing. If 1.6 is fine just run (as root)
Code: Select all
apt-get install asterisk

Apt-get install build essential does not work. I do apologise if my incorrect terminology offends but as I said I'm new to asterisk and Linux
simoncfc
 
Posts: 8
Joined: 2012-05-07 15:50

Re: Asterisk installation

Postby 4D696B65 » 2012-05-07 18:36

Post the contents of /etc/apt/sources.list
User avatar
4D696B65
 
Posts: 1761
Joined: 2009-06-28 06:09

Re: Asterisk installation

Postby vbrummond » 2012-05-07 18:41

simoncfc wrote:Apt-get install build essential does not work.

Of course it works; did it specify any problems? The advice in the above post will be helpful; If my command did not 'work' the likely reason is you do not have any repositories enabled. Or did it just not fix the problem as all this command does is install the core packages required to compile and build software and debian packages. Hardly useful to a beginner.

I do apologise if my incorrect terminology offends but as I said I'm new to asterisk and Linux

You did not offend anyone. Welcome to Debian User Forums. :)
Debian cd image FAQ: https://www.debian.org/CD/faq/ | Always back up your data.
vbrummond
 
Posts: 4219
Joined: 2010-03-02 01:42
Location: USA

Re: Asterisk installation

Postby simoncfc » 2012-05-10 07:46

4D696B65 wrote:Post the contents of /etc/apt/sources.list


deb cdrom:[Debian GNU/Linux 6.0.3 _Squeeze_ - Official i386 CD Binary-1 20111008-13:01]/ squeeze main

deb cdrom:[Debian GNU/Linux 6.0.3 _Squeeze_ - Official i386 CD Binary-1 20111008-13:01]/ squeeze main

deb http://debian.uchigago.edu/debian/ squeeze main contrib
deb-src http://debian.uchigao.edu/debian/ squeeze main contrib

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
deb http://ftp.uk.debian.org/debian/ squeeze-updates main
deb-src http://ftp.uk.debian.org/debian/ squeeze-updates main
as requested and thanks for your help in advance
simoncfc
 
Posts: 8
Joined: 2012-05-07 15:50

Re: Asterisk installation

Postby simoncfc » 2012-05-10 07:50

vbrummond wrote:It would help if you researched the correct commands and operating system names. :) The command is apt-get install build-essential. Also if looking for ncurses you probably need apt-get install libncurses5-dev. Though asterisk is already in Debian, in stable it is version 1.6. The version in testing is 1.8. If you specifically need 1.8 you will need to compile it yourself or upgrade (the whole system) to testing. If 1.6 is fine just run (as root)
Code: Select all
apt-get install asterisk


hi thanks for the advice i followed them to the letter and after removing all asterisk i did as suggested and apt-get install asterisk to be greeted with:


root@debian:/# apt-get install asterisk
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
asterisk : Depends: libc-client2007e but it is not installable
Depends: libcurl3 (>= 7.16.2-1) but it is not going to be installed
Depends: libgmime-2.0-2a but it is not installable
Depends: libiksemel3 but it is not installable
Depends: libopenais3 (>= 1.1.2) but it is not installable
Depends: libopenr2-3 but it is not installable
Depends: libpri1.4 (>= 1.4.10) but it is not installable
Depends: libradiusclient-ng2 but it is not installable
Depends: libresample1 (>= 0.1.3) but it is not installable
Depends: libspandsp2 but it is not installable
Depends: libsqlite0 (>= 2.8.17) but it is not installable
Depends: libss7-1 (>= 1.0) but it is not installable
Depends: libsybdb5 (>= 0.63) but it is not installable
Depends: libtonezone2.0 (>= 1:2.2.1.1) but it is not installable
Depends: libvpb0 (>= 4.2.22) but it is not installable
Depends: unixodbc (>= 2.2.11) but it is not installable
Depends: dahdi but it is not installable
Recommends: sox but it is not installable
E: Broken packages

surely this shouldnt be this difficult even for a numpty like me, im thinking as asterisk course maybe in order
simoncfc
 
Posts: 8
Joined: 2012-05-07 15:50

Re: Asterisk installation

Postby vbrummond » 2012-05-10 13:02

This is odd. I just tested this in a virtualbox of Debian 6 and it works successfully. You might have to manually solve the package dependencies. Try running:
Code: Select all
apt-get -f install

then:
Code: Select all
apt-get install libc-client2007e


Here was my output on a fresh squeeze install:
Code: Select all
kazuma@debian-virtual:~$ sudo apt-get -s install asterisk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.32-5-686 linux-headers-2.6-686 dkms linux-kbuild-2.6.32
  linux-headers-2.6.32-5-common
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  asterisk-config asterisk-core-sounds-en-gsm dahdi dahdi-linux debhelper
  freetds-common fxload html2text libc-client2007e libcorosync4 libcurl3
  libgmime-2.0-2a libiksemel3 liblua5.1-0 libopenais3 libopencore-amrnb0
  libopencore-amrwb0 libopenr2-3 libpq5 libpri1.4 libradiusclient-ng2
  libresample1 libsox-fmt-alsa libsox-fmt-base libsox1b libspandsp2
  libspeexdsp1 libsqlite0 libss7-1 libssh2-1 libsybdb5 libtonezone2.0
  libvorbisfile3 libvpb0 mlock module-assistant odbcinst odbcinst1debian2 sox
  unixodbc vpb-driver-source
Suggested packages:
  asterisk-doc asterisk-dev asterisk-h323 dh-make uw-mailutils libsox-fmt-all
  vpb-utils libmyodbc odbc-postgresql tdsodbc unixodbc-bin
The following NEW packages will be installed:
  asterisk asterisk-config asterisk-core-sounds-en-gsm dahdi dahdi-linux
  debhelper freetds-common fxload html2text libc-client2007e libcorosync4
  libcurl3 libgmime-2.0-2a libiksemel3 liblua5.1-0 libopenais3
  libopencore-amrnb0 libopencore-amrwb0 libopenr2-3 libpq5 libpri1.4
  libradiusclient-ng2 libresample1 libsox-fmt-alsa libsox-fmt-base libsox1b
  libspandsp2 libspeexdsp1 libsqlite0 libss7-1 libssh2-1 libsybdb5
  libtonezone2.0 libvorbisfile3 libvpb0 mlock module-assistant odbcinst
  odbcinst1debian2 sox unixodbc vpb-driver-source
0 upgraded, 42 newly installed, 0 to remove and 0 not upgraded.
Inst mlock (8:2007e~dfsg-3.1 Debian:6.0.4/stable [i386])
Inst libc-client2007e (8:2007e~dfsg-3.1 Debian:6.0.4/stable [i386])
Inst libssh2-1 (1.2.6-1 Debian:6.0.4/stable [i386])
Inst libcurl3 (7.21.0-2.1+squeeze2 Debian-Security:6.0/stable [i386])
Inst libgmime-2.0-2a (2.2.25-2 Debian:6.0.4/stable [i386])
Inst libiksemel3 (1.2-4 Debian:6.0.4/stable [i386])
Inst liblua5.1-0 (5.1.4-5 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Inst libcorosync4 (1.2.1-4 Debian:6.0.4/stable [i386])
Inst libopenais3 (1.1.2-2 Debian:6.0.4/stable [i386])
Inst libtonezone2.0 (1:2.2.1.1-1 Debian:6.0.4/stable [i386])
Inst fxload (0.0.20081013-1 Debian:6.0.4/stable [i386])
Inst dahdi-linux (1:2.3.0.1+dfsg-2 Debian:6.0.4/stable [all])
Inst dahdi (1:2.2.1.1-1 Debian:6.0.4/stable [i386])
Inst libopenr2-3 (1.3.0-2 Debian:6.0.4/stable [i386])
Inst libpq5 (8.4.11-0squeeze1 Debian-Security:6.0/stable [i386])
Inst libpri1.4 (1.4.11.3-1 Debian:6.0.4/stable [i386])
Inst libradiusclient-ng2 (0.5.6-1.1 Debian:6.0.4/stable [i386])
Inst libresample1 (0.1.3-3 Debian:6.0.4/stable [i386])
Inst libspandsp2 (0.0.6~pre12-1 Debian:6.0.4/stable [i386])
Inst libspeexdsp1 (1.2~rc1-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Inst libsqlite0 (2.8.17-6 Debian:6.0.4/stable [i386])
Inst libss7-1 (1.0.2-1 Debian:6.0.4/stable [i386])
Inst freetds-common (0.82-7 Debian:6.0.4/stable [all])
Inst libsybdb5 (0.82-7 Debian:6.0.4/stable [i386])
Inst libvpb0 (4.2.52-2 Debian:6.0.4/stable [i386])
Inst odbcinst (2.2.14p2-1 Debian:6.0.4/stable [i386]) []
Inst odbcinst1debian2 (2.2.14p2-1 Debian:6.0.4/stable [i386])
Inst unixodbc (2.2.14p2-1 Debian:6.0.4/stable [i386])
Inst asterisk-config (1:1.6.2.9-2+squeeze5 Debian-Security:6.0/stable [all])
Inst asterisk-core-sounds-en-gsm (1.4.19-1 Debian:6.0.4/stable [all])
Inst asterisk (1:1.6.2.9-2+squeeze5 Debian-Security:6.0/stable [i386])
Inst html2text (1.3.2a-15 Debian:6.0.4/stable [i386])
Inst debhelper (8.0.0 Debian:6.0.4/stable [all])
Inst libopencore-amrnb0 (0.1.2-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Inst libopencore-amrwb0 (0.1.2-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Inst libsox1b (14.3.1-1 Debian:6.0.4/stable [i386])
Inst libsox-fmt-alsa (14.3.1-1 Debian:6.0.4/stable [i386])
Inst libvorbisfile3 (1.3.1-1+squeeze1 Debian-Security:6.0/stable [i386])
Inst libsox-fmt-base (14.3.1-1 Debian:6.0.4/stable [i386])
Inst module-assistant (0.11.3 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [all])
Inst sox (14.3.1-1 Debian:6.0.4/stable [i386])
Inst vpb-driver-source (4.2.52-2 Debian:6.0.4/stable [all])
Conf mlock (8:2007e~dfsg-3.1 Debian:6.0.4/stable [i386])
Conf libc-client2007e (8:2007e~dfsg-3.1 Debian:6.0.4/stable [i386])
Conf libssh2-1 (1.2.6-1 Debian:6.0.4/stable [i386])
Conf libcurl3 (7.21.0-2.1+squeeze2 Debian-Security:6.0/stable [i386])
Conf libgmime-2.0-2a (2.2.25-2 Debian:6.0.4/stable [i386])
Conf libiksemel3 (1.2-4 Debian:6.0.4/stable [i386])
Conf liblua5.1-0 (5.1.4-5 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Conf libcorosync4 (1.2.1-4 Debian:6.0.4/stable [i386])
Conf libopenais3 (1.1.2-2 Debian:6.0.4/stable [i386])
Conf libtonezone2.0 (1:2.2.1.1-1 Debian:6.0.4/stable [i386])
Conf fxload (0.0.20081013-1 Debian:6.0.4/stable [i386])
Conf dahdi-linux (1:2.3.0.1+dfsg-2 Debian:6.0.4/stable [all])
Conf dahdi (1:2.2.1.1-1 Debian:6.0.4/stable [i386])
Conf libopenr2-3 (1.3.0-2 Debian:6.0.4/stable [i386])
Conf libpq5 (8.4.11-0squeeze1 Debian-Security:6.0/stable [i386])
Conf libpri1.4 (1.4.11.3-1 Debian:6.0.4/stable [i386])
Conf libradiusclient-ng2 (0.5.6-1.1 Debian:6.0.4/stable [i386])
Conf libresample1 (0.1.3-3 Debian:6.0.4/stable [i386])
Conf libspandsp2 (0.0.6~pre12-1 Debian:6.0.4/stable [i386])
Conf libspeexdsp1 (1.2~rc1-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Conf libsqlite0 (2.8.17-6 Debian:6.0.4/stable [i386])
Conf libss7-1 (1.0.2-1 Debian:6.0.4/stable [i386])
Conf freetds-common (0.82-7 Debian:6.0.4/stable [all])
Conf libsybdb5 (0.82-7 Debian:6.0.4/stable [i386])
Conf libvpb0 (4.2.52-2 Debian:6.0.4/stable [i386])
Conf odbcinst1debian2 (2.2.14p2-1 Debian:6.0.4/stable [i386])
Conf odbcinst (2.2.14p2-1 Debian:6.0.4/stable [i386])
Conf unixodbc (2.2.14p2-1 Debian:6.0.4/stable [i386])
Conf asterisk-config (1:1.6.2.9-2+squeeze5 Debian-Security:6.0/stable [all])
Conf asterisk-core-sounds-en-gsm (1.4.19-1 Debian:6.0.4/stable [all])
Conf asterisk (1:1.6.2.9-2+squeeze5 Debian-Security:6.0/stable [i386])
Conf html2text (1.3.2a-15 Debian:6.0.4/stable [i386])
Conf debhelper (8.0.0 Debian:6.0.4/stable [all])
Conf libopencore-amrnb0 (0.1.2-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Conf libopencore-amrwb0 (0.1.2-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Conf libsox1b (14.3.1-1 Debian:6.0.4/stable [i386])
Conf libsox-fmt-alsa (14.3.1-1 Debian:6.0.4/stable [i386])
Conf libvorbisfile3 (1.3.1-1+squeeze1 Debian-Security:6.0/stable [i386])
Conf libsox-fmt-base (14.3.1-1 Debian:6.0.4/stable [i386])
Conf module-assistant (0.11.3 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [all])
Conf sox (14.3.1-1 Debian:6.0.4/stable [i386])
Conf vpb-driver-source (4.2.52-2 Debian:6.0.4/stable [all])
Debian cd image FAQ: https://www.debian.org/CD/faq/ | Always back up your data.
vbrummond
 
Posts: 4219
Joined: 2010-03-02 01:42
Location: USA

Re: Asterisk installation

Postby roseway » 2012-05-10 15:37

simoncfc wrote:Apt-get install build essential does not work. I do apologise if my incorrect terminology offends but as I said I'm new to asterisk and Linux

If that is what you typed, then it won't work. The command is apt-get install build-essential
Eric

Debian Testing, KDE
User avatar
roseway
 
Posts: 1328
Joined: 2007-12-31 22:50
Location: Kent, UK

Re: Asterisk installation

Postby simoncfc » 2012-05-10 17:57

vbrummond wrote:This is odd. I just tested this in a virtualbox of Debian 6 and it works successfully. You might have to manually solve the package dependencies. Try running:
Code: Select all
apt-get -f install

then:
Code: Select all
apt-get install libc-client2007e


Here was my output on a fresh squeeze install:
Code: Select all
kazuma@debian-virtual:~$ sudo apt-get -s install asterisk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.32-5-686 linux-headers-2.6-686 dkms linux-kbuild-2.6.32
  linux-headers-2.6.32-5-common
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  asterisk-config asterisk-core-sounds-en-gsm dahdi dahdi-linux debhelper
  freetds-common fxload html2text libc-client2007e libcorosync4 libcurl3
  libgmime-2.0-2a libiksemel3 liblua5.1-0 libopenais3 libopencore-amrnb0
  libopencore-amrwb0 libopenr2-3 libpq5 libpri1.4 libradiusclient-ng2
  libresample1 libsox-fmt-alsa libsox-fmt-base libsox1b libspandsp2
  libspeexdsp1 libsqlite0 libss7-1 libssh2-1 libsybdb5 libtonezone2.0
  libvorbisfile3 libvpb0 mlock module-assistant odbcinst odbcinst1debian2 sox
  unixodbc vpb-driver-source
Suggested packages:
  asterisk-doc asterisk-dev asterisk-h323 dh-make uw-mailutils libsox-fmt-all
  vpb-utils libmyodbc odbc-postgresql tdsodbc unixodbc-bin
The following NEW packages will be installed:
  asterisk asterisk-config asterisk-core-sounds-en-gsm dahdi dahdi-linux
  debhelper freetds-common fxload html2text libc-client2007e libcorosync4
  libcurl3 libgmime-2.0-2a libiksemel3 liblua5.1-0 libopenais3
  libopencore-amrnb0 libopencore-amrwb0 libopenr2-3 libpq5 libpri1.4
  libradiusclient-ng2 libresample1 libsox-fmt-alsa libsox-fmt-base libsox1b
  libspandsp2 libspeexdsp1 libsqlite0 libss7-1 libssh2-1 libsybdb5
  libtonezone2.0 libvorbisfile3 libvpb0 mlock module-assistant odbcinst
  odbcinst1debian2 sox unixodbc vpb-driver-source
0 upgraded, 42 newly installed, 0 to remove and 0 not upgraded.
Inst mlock (8:2007e~dfsg-3.1 Debian:6.0.4/stable [i386])
Inst libc-client2007e (8:2007e~dfsg-3.1 Debian:6.0.4/stable [i386])
Inst libssh2-1 (1.2.6-1 Debian:6.0.4/stable [i386])
Inst libcurl3 (7.21.0-2.1+squeeze2 Debian-Security:6.0/stable [i386])
Inst libgmime-2.0-2a (2.2.25-2 Debian:6.0.4/stable [i386])
Inst libiksemel3 (1.2-4 Debian:6.0.4/stable [i386])
Inst liblua5.1-0 (5.1.4-5 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Inst libcorosync4 (1.2.1-4 Debian:6.0.4/stable [i386])
Inst libopenais3 (1.1.2-2 Debian:6.0.4/stable [i386])
Inst libtonezone2.0 (1:2.2.1.1-1 Debian:6.0.4/stable [i386])
Inst fxload (0.0.20081013-1 Debian:6.0.4/stable [i386])
Inst dahdi-linux (1:2.3.0.1+dfsg-2 Debian:6.0.4/stable [all])
Inst dahdi (1:2.2.1.1-1 Debian:6.0.4/stable [i386])
Inst libopenr2-3 (1.3.0-2 Debian:6.0.4/stable [i386])
Inst libpq5 (8.4.11-0squeeze1 Debian-Security:6.0/stable [i386])
Inst libpri1.4 (1.4.11.3-1 Debian:6.0.4/stable [i386])
Inst libradiusclient-ng2 (0.5.6-1.1 Debian:6.0.4/stable [i386])
Inst libresample1 (0.1.3-3 Debian:6.0.4/stable [i386])
Inst libspandsp2 (0.0.6~pre12-1 Debian:6.0.4/stable [i386])
Inst libspeexdsp1 (1.2~rc1-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Inst libsqlite0 (2.8.17-6 Debian:6.0.4/stable [i386])
Inst libss7-1 (1.0.2-1 Debian:6.0.4/stable [i386])
Inst freetds-common (0.82-7 Debian:6.0.4/stable [all])
Inst libsybdb5 (0.82-7 Debian:6.0.4/stable [i386])
Inst libvpb0 (4.2.52-2 Debian:6.0.4/stable [i386])
Inst odbcinst (2.2.14p2-1 Debian:6.0.4/stable [i386]) []
Inst odbcinst1debian2 (2.2.14p2-1 Debian:6.0.4/stable [i386])
Inst unixodbc (2.2.14p2-1 Debian:6.0.4/stable [i386])
Inst asterisk-config (1:1.6.2.9-2+squeeze5 Debian-Security:6.0/stable [all])
Inst asterisk-core-sounds-en-gsm (1.4.19-1 Debian:6.0.4/stable [all])
Inst asterisk (1:1.6.2.9-2+squeeze5 Debian-Security:6.0/stable [i386])
Inst html2text (1.3.2a-15 Debian:6.0.4/stable [i386])
Inst debhelper (8.0.0 Debian:6.0.4/stable [all])
Inst libopencore-amrnb0 (0.1.2-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Inst libopencore-amrwb0 (0.1.2-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Inst libsox1b (14.3.1-1 Debian:6.0.4/stable [i386])
Inst libsox-fmt-alsa (14.3.1-1 Debian:6.0.4/stable [i386])
Inst libvorbisfile3 (1.3.1-1+squeeze1 Debian-Security:6.0/stable [i386])
Inst libsox-fmt-base (14.3.1-1 Debian:6.0.4/stable [i386])
Inst module-assistant (0.11.3 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [all])
Inst sox (14.3.1-1 Debian:6.0.4/stable [i386])
Inst vpb-driver-source (4.2.52-2 Debian:6.0.4/stable [all])
Conf mlock (8:2007e~dfsg-3.1 Debian:6.0.4/stable [i386])
Conf libc-client2007e (8:2007e~dfsg-3.1 Debian:6.0.4/stable [i386])
Conf libssh2-1 (1.2.6-1 Debian:6.0.4/stable [i386])
Conf libcurl3 (7.21.0-2.1+squeeze2 Debian-Security:6.0/stable [i386])
Conf libgmime-2.0-2a (2.2.25-2 Debian:6.0.4/stable [i386])
Conf libiksemel3 (1.2-4 Debian:6.0.4/stable [i386])
Conf liblua5.1-0 (5.1.4-5 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Conf libcorosync4 (1.2.1-4 Debian:6.0.4/stable [i386])
Conf libopenais3 (1.1.2-2 Debian:6.0.4/stable [i386])
Conf libtonezone2.0 (1:2.2.1.1-1 Debian:6.0.4/stable [i386])
Conf fxload (0.0.20081013-1 Debian:6.0.4/stable [i386])
Conf dahdi-linux (1:2.3.0.1+dfsg-2 Debian:6.0.4/stable [all])
Conf dahdi (1:2.2.1.1-1 Debian:6.0.4/stable [i386])
Conf libopenr2-3 (1.3.0-2 Debian:6.0.4/stable [i386])
Conf libpq5 (8.4.11-0squeeze1 Debian-Security:6.0/stable [i386])
Conf libpri1.4 (1.4.11.3-1 Debian:6.0.4/stable [i386])
Conf libradiusclient-ng2 (0.5.6-1.1 Debian:6.0.4/stable [i386])
Conf libresample1 (0.1.3-3 Debian:6.0.4/stable [i386])
Conf libspandsp2 (0.0.6~pre12-1 Debian:6.0.4/stable [i386])
Conf libspeexdsp1 (1.2~rc1-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Conf libsqlite0 (2.8.17-6 Debian:6.0.4/stable [i386])
Conf libss7-1 (1.0.2-1 Debian:6.0.4/stable [i386])
Conf freetds-common (0.82-7 Debian:6.0.4/stable [all])
Conf libsybdb5 (0.82-7 Debian:6.0.4/stable [i386])
Conf libvpb0 (4.2.52-2 Debian:6.0.4/stable [i386])
Conf odbcinst1debian2 (2.2.14p2-1 Debian:6.0.4/stable [i386])
Conf odbcinst (2.2.14p2-1 Debian:6.0.4/stable [i386])
Conf unixodbc (2.2.14p2-1 Debian:6.0.4/stable [i386])
Conf asterisk-config (1:1.6.2.9-2+squeeze5 Debian-Security:6.0/stable [all])
Conf asterisk-core-sounds-en-gsm (1.4.19-1 Debian:6.0.4/stable [all])
Conf asterisk (1:1.6.2.9-2+squeeze5 Debian-Security:6.0/stable [i386])
Conf html2text (1.3.2a-15 Debian:6.0.4/stable [i386])
Conf debhelper (8.0.0 Debian:6.0.4/stable [all])
Conf libopencore-amrnb0 (0.1.2-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Conf libopencore-amrwb0 (0.1.2-1 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [i386])
Conf libsox1b (14.3.1-1 Debian:6.0.4/stable [i386])
Conf libsox-fmt-alsa (14.3.1-1 Debian:6.0.4/stable [i386])
Conf libvorbisfile3 (1.3.1-1+squeeze1 Debian-Security:6.0/stable [i386])
Conf libsox-fmt-base (14.3.1-1 Debian:6.0.4/stable [i386])
Conf module-assistant (0.11.3 Debian GNU/Linux 6.0.1a _Squeeze_ - Official Multi-architecture i386/amd64/source DVD #1 20110322-16:29, Debian:6.0.4/stable [all])
Conf sox (14.3.1-1 Debian:6.0.4/stable [i386])
Conf vpb-driver-source (4.2.52-2 Debian:6.0.4/stable [all])


i agree this is odd i did as suggested and guess what nadah! i was responded with:


root@debian:/home/simon# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@debian:/home/simon# apt-get install libc-client2007e
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libc-client2007e is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libc-client2007e' has no installation candidate

im thinking my source list is pants maybe re-installing debian would be the way forward? what source list should i use? and how to change the source would be helpful or maybe i should just give up and go back to cables???? ha
simoncfc
 
Posts: 8
Joined: 2012-05-07 15:50

Re: Asterisk installation

Postby vbrummond » 2012-05-10 18:04

It looks right to me. I use:
Code: Select all
deb http://http.debian.net/debian squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free


You might just need to update with:
Code: Select all
apt-get update
Debian cd image FAQ: https://www.debian.org/CD/faq/ | Always back up your data.
vbrummond
 
Posts: 4219
Joined: 2010-03-02 01:42
Location: USA

Re: Asterisk installation

Postby simoncfc » 2012-05-11 06:27

vbrummond wrote:It looks right to me. I use:
Code: Select all
deb http://http.debian.net/debian squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free


You might just need to update with:
Code: Select all
apt-get update


thanks i have done the update and upgrade several times but no joy. thanks for the repo's but how do i add them? i can read my source list obviously with cat but how do i add the source? sorry for being such a noob i can do most things haha
simoncfc
 
Posts: 8
Joined: 2012-05-07 15:50

Re: Asterisk installation

Postby vbrummond » 2012-05-11 06:31

You can edit it with synaptic or any text editor as root. Such as this from the terminal:
Code: Select all
nano /etc/apt/sources.list

(ctrl+x then y to save)
Debian cd image FAQ: https://www.debian.org/CD/faq/ | Always back up your data.
vbrummond
 
Posts: 4219
Joined: 2010-03-02 01:42
Location: USA

Re: Asterisk installation

Postby simoncfc » 2012-05-11 09:46

vbrummond wrote:You can edit it with synaptic or any text editor as root. Such as this from the terminal:
Code: Select all
nano /etc/apt/sources.list

(ctrl+x then y to save)


you wont believe this vbrummond the code you gave and if i had thought about it nano duh worked perfectly started to install the asterisk and this appeared?

Media change: please insert the disc labeled
'Debian GNU/Linux 6.0.3 _Squeeze_ - Official i386 CD Binary-1 20111008-13:01'
in the drive '/media/cdrom/' and press enter

im guessing maybe an upgrade? or will i n need to do anything in media/cdrom? sorry for all the questions especially dumb ones like nano how thick am i
simoncfc
 
Posts: 8
Joined: 2012-05-07 15:50

Re: Asterisk installation

Postby mmuratov » 2012-05-11 09:51

simoncfc wrote:
vbrummond wrote:You can edit it with synaptic or any text editor as root. Such as this from the terminal:
Code: Select all
nano /etc/apt/sources.list

(ctrl+x then y to save)


you wont believe this vbrummond the code you gave and if i had thought about it nano duh worked perfectly started to install the asterisk and this appeared?

Media change: please insert the disc labeled
'Debian GNU/Linux 6.0.3 _Squeeze_ - Official i386 CD Binary-1 20111008-13:01'
in the drive '/media/cdrom/' and press enter

im guessing maybe an upgrade? or will i n need to do anything in media/cdrom? sorry for all the questions especially dumb ones like nano how thick am i

you need to comment out these two lines:
Code: Select all
deb cdrom:[Debian GNU/Linux 6.0.3 _Squeeze_ - Official i386 CD Binary-1 20111008-13:01]/ squeeze main

deb cdrom:[Debian GNU/Linux 6.0.3 _Squeeze_ - Official i386 CD Binary-1 20111008-13:01]/ squeeze main

in your /etc/apt/sources.list
# deb cdrom:[Debian GNU/Linux 6.0.3 _Squeeze_ - Official i386 CD Binary-1 20111008-13:01]/ squeeze main

# deb cdrom:[Debian GNU/Linux 6.0.3 _Squeeze_ - Official i386 CD Binary-1 20111008-13:01]/ squeeze main
Last edited by mmuratov on 2012-05-11 09:56, edited 1 time in total.
"Today is the tomorrow that you were worried about yesterday."
- What's your excuse now?
mmuratov
 
Posts: 24
Joined: 2010-02-21 12:18
Location: Labin, Croatia

Next

Return to General Questions

Who is online

Users browsing this forum: PhillBrown and 16 guests

fashionable