"E: Unable to locate package" What does this mean?

New to Debian (Or Linux in general)? Ask your questions here!

"E: Unable to locate package" What does this mean?

Postby danilondr » 2012-05-18 10:04

Hallo, i'm trying to install SVN (subversion) on debian 6 64-bit but this message appears:

"E: Unable to locate package"

What should i do to solve? Do i need to find additional repository?
danilondr
 
Posts: 5
Joined: 2012-04-27 19:47

Re: "E: Unable to locate package" What does this mean?

Postby mmuratov » 2012-05-18 10:20

paste here your /etc/apt/sources.list output
what did you type in terminal?

here is a tutorial for configuring svn
http://www.howtoforge.com/debian_subversion_websvn
and here is a package you need:
http://packages.debian.org/squeeze/subversion
download it for your architecture and just run it with dpkg -i package name.deb
"Today is the tomorrow that you were worried about yesterday."
- What's your excuse now?
mmuratov
 
Posts: 24
Joined: 2010-02-21 12:18
Location: Labin, Croatia

Re: "E: Unable to locate package" What does this mean?

Postby danilondr » 2012-05-18 11:53

here the /etc/apt/sources.list

Code: Select all
#

# deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official amd64 CD Binary-1 20120128-13:42]/ squeeze main

deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official amd64 CD Binary-1 20120128-13:42]/ squeeze main

deb http://ftp.uk.debian.org/debian/ squeeze main
deb-src http://ftp.uk.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
deb http://ftp.uk.debian.org/debian/ squeeze-updates main
deb-src http://ftp.uk.debian.org/debian/ squeeze-updates main


i typed:

Code: Select all
apt-get install svn
danilondr
 
Posts: 5
Joined: 2012-04-27 19:47

Re: "E: Unable to locate package" What does this mean?

Postby cynwulf » 2012-05-18 12:03

Comment out the second "deb cdrom:" line from your sources, then:

Code: Select all
# apt-get update


Code: Select all
# apt-get install subversion
cynwulf
 
Posts: 2397
Joined: 2008-09-25 08:49

Re: "E: Unable to locate package" What does this mean?

Postby danilondr » 2012-05-18 12:12

Thanks, apt-get install subversion works.
danilondr
 
Posts: 5
Joined: 2012-04-27 19:47


Return to Beginners Questions

Who is online

Users browsing this forum: el_puberino, peter_irich and 12 guests

fashionable