["solved"] debian wheezy new install: mp4 problems

Everything about X, Gnome, KDE, ... and everything running on it

["solved"] debian wheezy new install: mp4 problems

Postby agrimstad » 2012-06-28 19:12

I've just installed debian wheezy and things are pretty much working in the multimedia area. In particular, CDs and DVDs are playing. But I've run into troubles with mp4 files. VLC plays them, but the audio is terrible and the video is a bit worse than I remember in squeeze. Totem does nothing at all with these files. I presume there's some library out there that I need to load, but I don't know which one. I've added

deb http://www.deb-multimedia.org wheezy main non-free

to /etc/apt/sources.list

and the following packages are present:

gstreamer0.10-ffmpeg/wheezy uptodate 1:0.10.13-0.2
gstreamer0.10-fluendo-mp3/wheezy uptodate 0.10.15.debian-1
gstreamer0.10-gconf/wheezy uptodate 0.10.31-3
gstreamer0.10-nice/wheezy uptodate 0.1.2-1
gstreamer0.10-plugins-bad/wheezy uptodate 0.10.23-6
gstreamer0.10-plugins-base/wheezy uptodate 0.10.36-1
gstreamer0.10-plugins-good/wheezy uptodate 0.10.31-3
gstreamer0.10-plugins-really-bad/wheezy uptodate 0.10.23-0.0
gstreamer0.10-plugins-ugly/wheezy uptodate 0.10.19-2+b2
gstreamer0.10-pulseaudio/wheezy uptodate 0.10.31-3
gstreamer0.10-x/wheezy uptodate 0.10.36-1
libgstreamer0.10-0/wheezy uptodate 0.10.36-1

Something seems to have changed between squeeze and wheezy. Any clues what?

-- al
Last edited by agrimstad on 2012-07-01 10:52, edited 2 times in total.
agrimstad
 
Posts: 74
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Re: debian wheezy new install: mp4 problems

Postby agrimstad » 2012-06-28 19:19

As a postscript to this question, I probably should mention that my wheezy installation is amd64. My squeeze installation--where mp4 works--was i386. -- al
agrimstad
 
Posts: 74
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Re: debian wheezy new install: mp4 problems

Postby vbrummond » 2012-06-28 19:36

You do not need D-M to play mp4 so perhaps the problem is from there? Mp4 files play fine here stock wheezy. Make sure you have libav-tools/ffmpeg installed and gstreamer0.10-ffmpeg.
vbrummond
 
Posts: 4109
Joined: 2010-03-02 01:42
Location: USA

Re: debian wheezy new install: mp4 problems

Postby agrimstad » 2012-06-28 19:48

The gstreamer0.10-ffmpeg package is installed (see list). Regarding libav-tools/ffmpeg, I did install the lib-avtools package. No change. I'm not parsing "libav-tools/ffmpeg". apt-cache search didn't turn up something resembling that, so I'm not sure what you mean. Since I DO need, I think, D-M for codecs, I'm not sure what to do about it. -- al
agrimstad
 
Posts: 74
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Re: debian wheezy new install: mp4 problems

Postby vbrummond » 2012-06-28 19:59

Edit: 3000th post.

I doubt it. I am sure DM can play something regular debian can't but not much. Either way it is simpler to solve this with DM enabled. Anyway ffmpeg/libav means either not this whole string combined. I just wanted to make sure you have the whole libav* stack installed. I would say if we can narrow this down it will be easier. Try installing mplayer2. If it still has the issue with mp4 files its either the file or the libavcodec etc packages from D-M have a bug. If so you should report it to the dev there.

Anyway to install mplayer2 just run as root:
Code: Select all
apt-get install mplayer2


As normal user play the mp4 file:
Code: Select all
mplayer /path/to/file.mp4


It should also print debugging information about the file.
vbrummond
 
Posts: 4109
Joined: 2010-03-02 01:42
Location: USA

Re: debian wheezy new install: mp4 problems

Postby agrimstad » 2012-06-28 20:24

OK, mplayer installed. It played my mp4 file perfectly. But the installation didn't bring in any libraries to help totem or vlc with their problems, which seem unchanged.
agrimstad
 
Posts: 74
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Re: debian wheezy new install: mp4 problems

Postby craigevil » 2012-06-28 21:30

no issues with mp4 on sid.

Code: Select all
$ dpkg -l | grep gstreamer
ii  gstreamer0.10-alsa:i386               0.10.36-1                          GStreamer plugin for ALSA
ii  gstreamer0.10-ffmpeg                  1:0.10.13-0.2                      FFmpeg plugin for GStreamer
ii  gstreamer0.10-gconf:i386              0.10.31-3                          GStreamer plugin for getting the sink/source information from GConf
ii  gstreamer0.10-plugins-bad:i386        0.10.23-6                          GStreamer plugins from the "bad" set
ii  gstreamer0.10-plugins-base:i386       0.10.36-1                          GStreamer plugins from the "base" set
ii  gstreamer0.10-plugins-good:i386       0.10.31-3                          GStreamer plugins from the "good" set
ii  gstreamer0.10-plugins-really-bad:i386 0.10.23-dmo2                       GStreamer plugins from the "bad" set
ii  gstreamer0.10-plugins-ugly:i386       0.10.19-2+b2                       GStreamer plugins from the "ugly" set
ii  gstreamer0.10-qapt                    1.3.0-2                            GStreamer plugin to install codecs using QApt
ii  gstreamer0.10-x:i386                  0.10.36-1                          GStreamer plugins for X11 and Pango
ii  libgstreamer-plugins-bad0.10-0:i386   0.10.23-6                          GStreamer development files for libraries from the "bad" set
ii  libgstreamer-plugins-base0.10-0:i386  0.10.36-1                          GStreamer libraries from the "base" set
ii  libgstreamer0.10-0:i386               0.10.36-1                          Core GStreamer libraries and elements
ii  libqtgstreamer-0.10-0:i386            0.10.2-2                           C++ bindings library for GStreamer with a Qt-style API
ii  phonon-backend-gstreamer:i386         4:4.6.0.0-2                        Phonon GStreamer 0.10.x backend



$ apt-cache policy vlc
vlc:
Installed: 1:2.0.1-dmo3
Candidate: 1:2.0.1-dmo3
Version table:
*** 1:2.0.1-dmo3 0
500 http://www.deb-multimedia.org/ sid/main i386 Packages
100 /var/lib/dpkg/status
2.0.1-4+b3 0
500 http://mirrors.kernel.org/debian/ unstable/main i386 Packages


$ apt-cache policy mplayer
mplayer:
Installed: 3:1.1-dmo3
Candidate: 3:1.1-dmo3
Version table:
*** 3:1.1-dmo3 0
500 http://www.deb-multimedia.org/ sid/main i386 Packages
100 /var/lib/dpkg/status
2:1.0~rc4.dfsg1+svn34540-1+b2 0
500 http://mirrors.kernel.org/debian/ unstable/main i386 Packages


$ apt-cache policy ffmpeg
ffmpeg:
Installed: 7:0.11.1-dmo2
Candidate: 7:0.11.1-dmo2
Version table:
*** 7:0.11.1-dmo2 0
500 http://www.deb-multimedia.org/ sid/main i386 Packages
100 /var/lib/dpkg/status
6:0.8.3-4 0
500 http://mirrors.kernel.org/debian/ unstable/main i386 Packages

For totem make sure you have:
totem-plugins - Plugins for the Totem media player
as well as the various gstreamer plugins

vlc uses its own plugins, mplayer uses ffmpeg
Debian Sid KDE 4.8 Kernel 3.7 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5149
Joined: 2006-09-17 03:17
Location: down the rabbit hole

Re: debian wheezy new install: mp4 problems

Postby agrimstad » 2012-06-28 22:09

OK, let's see what's different.

Code: Select all
# dpkg -l|grep gstreamer
ii  gir1.2-gstreamer-0.10                                0.10.36-1
ii  gstreamer0.10-ffmpeg                              1:0.10.13-0.2
ii  gstreamer0.10-fluendo-mp3                     0.10.15.debian-1
ii  gstreamer0.10-gconf:amd64                     0.10.31-3
ii  gstreamer0.10-nice:amd64                       0.1.2-1
ii  gstreamer0.10-plugins-bad:amd64           0.10.23-6
ii  gstreamer0.10-plugins-base:amd64        0.10.36-1
ii  gstreamer0.10-plugins-good:amd64        0.10.31-3
ii  gstreamer0.10-plugins-really-bad              0.10.23-0.0
ii  gstreamer0.10-plugins-ugly:amd64            0.10.19-2+b2
ii  gstreamer0.10-pulseaudio:amd64             0.10.31-3
ii  gstreamer0.10-x:amd64                              0.10.36-1
ii  libgstreamer-plugins-bad0.10-0:amd64     0.10.23-6
ii  libgstreamer-plugins-base0.10-0:amd64    0.10.36-1
ii  libgstreamer0.10-0:amd64                            0.10.36-1


I don't seem to have gstreamer0.10-alsa.

Code: Select all
# apt-cache policy vlc
vlc:
  Installed: 2.0.1-4+b2
  Candidate: 1:2.0.1-dmo3
  Version table:
     1:2.0.1-dmo3 0
        500 http://www.deb-multimedia.org/ wheezy/main amd64 Packages
     2.0.1-4+b3 0
        500 http://ftp.us.debian.org/debian/ wheezy/main amd64 Packages
 *** 2.0.1-4+b2 0
        100 /var/lib/dpkg/status


Hmm.

Code: Select all
# apt-cache policy mplayer
mplayer:
  Installed: (none)
  Candidate: 3:1.0~rc4+svn20120601-dmo1
  Version table:
     3:1.0~rc4+svn20120601-dmo1 0
        500 http://www.deb-multimedia.org/ wheezy/main amd64 Packages
     2:1.0~rc4.dfsg1+svn34540-1+b2 0
        500 http://ftp.us.debian.org/debian/ wheezy/main amd64 Packages


Code: Select all
# apt-cache policy ffmpeg
ffmpeg:
  Installed: (none)
  Candidate: 7:0.11.1-dmo2
  Version table:
     7:0.11.1-dmo2 0
        500 http://www.deb-multimedia.org/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status
     6:0.8.3-1+b1 0
        500 http://ftp.us.debian.org/debian/ wheezy/main amd64 Packages


Code: Select all
# dpkg -l|grep totem
ii  gir1.2-totem-1.0                        3.0.1-8
ii  gir1.2-totem-plparser-1.0         3.4.2-1
ii  libtotem-plparser17                  3.4.2-1
ii  libtotem0                                   3.0.1-8
ii  totem                                         3.0.1-8
ii  totem-common                         3.0.1-8
ii  totem-plugins                            3.0.1-8


Mostly I'm just seeing different versions of things, sid versus wheezy, I suppose. -- al
agrimstad
 
Posts: 74
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Re: debian wheezy new install: mp4 problems

Postby Bulkley » 2012-06-28 22:58

Thank you for this thread. I've had the same problem for a few months. It came with an upgrade. I ran a thread about it at the time with no resolution. Miro and Totem will not play mp4 while smplayer will. I have assumed that another upgrade would solve this but, so far, none has. My guess, and it's only a guess, is that there is some out dated configuration somewhere that is incompatible with up-to-date Wheezy.
Bulkley
 
Posts: 3708
Joined: 2006-02-11 18:35

Re: debian wheezy new install: mp4 problems

Postby craigevil » 2012-06-28 23:50

Other threads with the same issue or similar issue:
Debian User Forums • View topic - Wheezy totem/minitube no mp4 playback : viewtopic.php?f=6&t=76983

Debian User Forums • View topic - Can't play .mp4 files using totem in squeeze : viewtopic.php?f=6&t=60939

Debian User Forums • View topic - Miro won't play mp4 : viewtopic.php?f=6&t=78085

[SOLVED] Watching an MP4 video on Totem : http://www.linuxquestions.org/questions ... em-923674/

Linux Mint Forums • View topic - No mp4 with VLC in Mint 12 : http://forums.linuxmint.com/viewtopic.php?f=48&t=90750

VLC has a mp4 plugin:
/usr/lib/vlc/plugins/demux/libmp4_plugin.so

gstreamer pm4 plugin
/usr/lib/i386-linux-gnu/gstreamer-0.10/libgstisomp4.so

w32codecs
/usr/lib/codecs/ubvmp4d.dll

/home/craig/.local/share/mime/audio/x-mp4.xml
<?xml version="1.0" encoding="utf-8"?>
<mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="audio/x-mp4">
<!--Created automatically by update-mime-database. DO NOT EDIT!-->
<comment>MPEG 4 audio</comment>
<icon name="x-kde-nsplugin-generated"/>
</mime-type>

/usr/share/mime/video/mp4.xml
Code: Select all
<glob pattern="*.mp4"/>
  <glob pattern="*.m4v"/>
  <glob pattern="*.f4v"/>
  <alias type="video/x-m4v"/>


KDE System Settings>File Associations shows
Description MPEG-4 video
Dragonplayer
Gnome mplayer
VLC
Smplayer

Anyone that has the problem do you have gstreamer0.10-plugins-really-bad installed?
This package contains plugins from the "bad" set, a set of non-free
plug-ins that might pose distribution problems.
.
Bad plugins are faac, mpeg2enc, mplex, vdpau and xvid.


FAAC currently supports MPEG-4 LTP, MAIN and LOW COMPLEXITY object types
and MAIN and LOW MPEG-2 object types. It also supports multichannel and
gapless encoding.
Debian Sid KDE 4.8 Kernel 3.7 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5149
Joined: 2006-09-17 03:17
Location: down the rabbit hole

Re: debian wheezy new install: mp4 problems

Postby Bulkley » 2012-06-29 02:13

Anyone that has the problem do you have gstreamer0.10-plugins-really-bad installed?


I have 'bad' but not 'really bad'. I can't find 'really bad' in Wheezy sources, free or non.
Bulkley
 
Posts: 3708
Joined: 2006-02-11 18:35

Re: debian wheezy new install: mp4 problems

Postby craigevil » 2012-06-29 02:42

Bulkley wrote:
Anyone that has the problem do you have gstreamer0.10-plugins-really-bad installed?


I have 'bad' but not 'really bad'. I can't find 'really bad' in Wheezy sources, free or non.


You won't it is in the deb-multimedia.org repo.

$ apt-cache policy gstreamer0.10-plugins-really-bad
gstreamer0.10-plugins-really-bad:
Installed: 0.10.23-dmo2
Candidate: 0.10.23-dmo2
Version table:
*** 0.10.23-dmo2 0
500 http://www.deb-multimedia.org/ sid/main i386 Packages
100 /var/lib/dpkg/status
Debian Sid KDE 4.8 Kernel 3.7 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5149
Joined: 2006-09-17 03:17
Location: down the rabbit hole

Re: debian wheezy new install: mp4 problems

Postby agrimstad » 2012-06-29 09:44

Re: debian wheezy new install: mp4 problems

Unread postby craigevil » 2012-06-28 18:50
Other threads with the same issue or similar issue:
Debian User Forums • View topic - Wheezy totem/minitube no mp4 playback : viewtopic.php?f=6&t=76983

Debian User Forums • View topic - Can't play .mp4 files using totem in squeeze : viewtopic.php?f=6&t=60939

Debian User Forums • View topic - Miro won't play mp4 : viewtopic.php?f=6&t=78085

[SOLVED] Watching an MP4 video on Totem : http://www.linuxquestions.org/questions ... em-923674/


Before posting I did some searching on this issue and didn't find anything that helped me. Have you read that "solved" thread? The "solution" was to boot into another distribution where playing mp4s worked! And the analysis was speculative and unconvincing.
agrimstad
 
Posts: 74
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Re: debian wheezy new install: mp4 problems

Postby agrimstad » 2012-06-29 09:59

I want to mention again something I said early on. My wheezy installation is amd64, not i386, e.g., I have this plugin:

/usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstisomp4.so

not this one:

/usr/lib/i386-linux-gnu/gstreamer-0.10/libgstisomp4.so

There have been a couple of "works for me" posters to this thread. Anyone have mp4 working in 64-bit wheezy?
agrimstad
 
Posts: 74
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Re: debian wheezy new install: mp4 problems

Postby agrimstad » 2012-06-29 11:12

The mp4s I'm using as tests were produced by ffmpeg. It turns out that I didn't have it installed yet, so I installed it. This causes libav-tools to be removed, for what it's worth. This hasn't changed anything, but I do want to be a bit more precise. VLC shows the video pretty much OK; my memory that it used to be a bit better was wrong. It's the audio that's the problem. It has an annoying hiss. Totem remains completely helpless with my mp4 files.
agrimstad
 
Posts: 74
Joined: 2007-10-05 00:55
Location: Hollis, NH, USA

Next

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable