Debian 6.0.4 Fresh Install No flash sound in browser

Everything about X, Gnome, KDE, ... and everything running on it

Debian 6.0.4 Fresh Install No flash sound in browser

Postby Alleghenia » 2012-07-22 01:03

I just installed Debian 6.0.4 Gnome from the live CD. There is no sound whatsoever playing flash from youtube, vimeo, etc.

GNU (gnash) player and alsa sound were installed by default from the live cd. I uninstalled gnash, removed alsa, installed pulseaudio, went through pulseaudio settings, and installed adobe-flash-nonfree. Still no sound in flash video. Video plays well, frame rate looks smooth.

Using Epiphany and Iceweasel browsers renders no flash sound. When downloading the .flv file, and playing in Media Player, sound works fine.

Notebook Specs:
Acer Aspire 7560 Sb416
AMD Quad Core A6-3400M Turbo Core
AMD Radeon HD 6520G

I have run into this issue with every install of Debian. No support instructions that I have found has resolved the issue.
Want to help me troubleshoot? Then shoot.
Alleghenia
 
Posts: 12
Joined: 2012-02-06 11:15

Re: Debian 6.0.4 Fresh Install No flash sound in browser

Postby vbrummond » 2012-07-22 01:08

You can't remove alsa. As far as I know pulseaudio uses alsa.

Edit: So no sound on flash even before pulse? Sometimes flash can 'steal the sound' but I am not sure why it would just not work. There is a script here to get alsa information: http://www.alsa-project.org/alsa-info.sh
vbrummond
 
Posts: 4344
Joined: 2010-03-02 01:42

Re: Debian 6.0.4 Fresh Install No flash sound in browser

Postby Alleghenia » 2012-07-22 01:26

vbrummond wrote:You can't remove alsa. As far as I know pulseaudio uses alsa.

Edit: So no sound on flash even before pulse? Sometimes flash can 'steal the sound' but I am not sure why it would just not work. There is a script here to get alsa information: http://www.alsa-project.org/alsa-info.sh


Thanks. I There was no sound immediately upon a fresh install. I tinkered by removing alsa and gnash, and alsa is reinstalled, but no gnash. This has to be a sound issue. Like a ghost soundcard or something like that is getting the sound. I ran the script you provided. Here is the output. Also uploaded output on second run of script to: http://www.alsa-project.org/db/?f=7f75c ... 11dacdbf15
Last edited by Alleghenia on 2012-07-22 01:57, edited 1 time in total.
Alleghenia
 
Posts: 12
Joined: 2012-02-06 11:15

Re: Debian 6.0.4 Fresh Install No flash sound in browser

Postby vbrummond » 2012-07-22 01:33

Sometimes it is possible to enable/disable integrated soundcards in the bios (not sure it will help). Also make sure you do not have volume muted by running this in a terminal:
Code: Select all
alsamixer -c0
vbrummond
 
Posts: 4344
Joined: 2010-03-02 01:42

Re: Debian 6.0.4 Fresh Install No flash sound in browser

Postby Alleghenia » 2012-07-22 01:49

I am thinking that somehow my flash browser sound is being pointed to a ghost or non-functioning duplicate sound card. I think the linux kernel probably cannot play on my HDMI channel, and somehow I need to capture all sound and route it to the Analog channel only. Just a guess, and I would have no idea how to proceed. the board won't let me upload screen shots from running "alsamixer -c0" so I'll describe: Info for card0 is displayed as Item s/pdif and has a little sqare in the center with [00] and [mm] depending on how I toggle with "M" on the keboard. when I press F6 and select HD Audio Generic 1 instead of 0, I get a graphical display with green white and red bars, above the labels, MASTER, HEADPHONE, SPEAKER, PCM. Any suggestions? I looked around to edit asound.conf or .asoundrc and neither are in my /etc folder. Stumped.
Alleghenia
 
Posts: 12
Joined: 2012-02-06 11:15

Re: Debian 6.0.4 Fresh Install No flash sound in browser

Postby pendrachken » 2012-07-22 23:43

Flash uses snd0 ALWAYS. You will have to look in /proc/asound/cards and find your card ID for the onboard / non-HDMI audio and look up on google ( I forget exactly what files you need to set the default cards order in) how to set that as your default sound card.


Most likely right now you are using the HDMI sound card as your "default" card so flash sound is playing through that while media players are a tad bit more intelligent and will output the the sound card you are actually using.
fortune -o
Your love life will be... interesting.
:twisted: How did it know?

The U.S. uses the metric system too, we have tenths, hundredths and thousandths of inches :-P
pendrachken
 
Posts: 1049
Joined: 2007-03-04 21:10
Location: U.S.A. - WI.

Re: Debian 6.0.4 Fresh Install No flash sound in browser

Postby lizbeth » 2012-10-22 23:04

Install Linux Mint Debian Edition http://www.linuxmint.com/download_lmde.php and ALL your troubles will disappear in a FLASH :mrgreen: It's based on wheezy. I have the same AMD A6 Vision Quad-Core CPU as you have with the same AMD Radeon 6520G GPU on chip as you and it works great with Linux Mint Debian Edition.

Just one thing you should know about your laptop and all Linux versions you might try: DO NOT install the AMD Proprietary Drives for the on chip graphics card or you will have problems with flash. Linux Mint Debian Edition comes with free drivers for your card which do not interfere with flash and will play flash in full screen with sound and video. This was a hard lesson for me to learn. DO NOT install any FGLRX DRIVERS or you will have problems with flash. Google Chrome comes with pepper flash 11.4 and is the only up to date flash for any Linux there is as Adobe, the makers of Flash have stopped developing Flash for Linux as of ver 11.1. Firefox can not use pepper flash 11.4, so if you want the most up to date Flash experience you will have to use Google Chrome also.
Toshiba Satellite Laptop, AMD A6-3420M Quad-Core CPU, AMD Radeon 6520G On Chip HD GPU, Toshiba 500 Gig HD, 6 gigs Ram

Linux Mint Debian Sid, Liquorix 3.6 Kernel, Cinnamon 1.6.4 Desktop
User avatar
lizbeth
 
Posts: 67
Joined: 2012-10-20 12:15

Re: Debian 6.0.4 Fresh Install No flash sound in browser

Postby gsnoorky » 2013-12-23 17:47

I have this problem in Wheezy LXDE 7: Streaming .wav files for VOIP from Firefox/Chromium/Chrome. I may download the files and play via Rhythmbox and VLC, though--Quod Libet and lxmusic--apparently many others as well--won't work. Apparently, neither Google-related browser nor Iceweasel works for streaming .wav files, now. This is my office PC--I'm currently using onboard analog sound through PC speakers.

To tell you honestly, I don't believe that this ever has worked in linux--no biggie: I don't get that many calls here. Someone in another thread indicated this: 'Why doesn't a browser automatically attach to and play through the user-chosen default player for that format?' Tacitly implied: Why not just go ahead and seamlessly download to temp storage, then process? (Given user assent via setting default for that, of course.) It has something to do with "remote sound,' I suppose, as well. Security is a concern, of course.

(Another issue mentioned here late in 2012: As for passing through HDMI from my other PC, the open source AMD driver (cheapo Radeon 5450) just can't seem to perform that--that software's video is much improved now, though--it almost works--without sound, no cigar. Reluctantly, I did end up installing distro-based fglrx. I'm willing to try open source again for HDMI--if some Debian-junkie may tell me the tricks needed.)
gsnoorky
 
Posts: 15
Joined: 2013-05-30 14:01

Re: Debian 6.0.4 Fresh Install No flash sound in browser

Postby gsnoorky » 2013-12-23 17:58

Alleghenia wrote:I am thinking that somehow my flash browser sound is being pointed to a ghost or non-functioning duplicate sound card. I think the linux kernel probably cannot play on my HDMI channel, and somehow I need to capture all sound and route it to the Analog channel only. Just a guess, and I would have no idea how to proceed. the board won't let me upload screen shots from running "alsamixer -c0" so I'll describe: Info for card0 is displayed as Item s/pdif and has a little sqare in the center with [00] and [mm] depending on how I toggle with "M" on the keboard. when I press F6 and select HD Audio Generic 1 instead of 0, I get a graphical display with green white and red bars, above the labels, MASTER, HEADPHONE, SPEAKER, PCM. Any suggestions? I looked around to edit asound.conf or .asoundrc and neither are in my /etc folder. Stumped.


This is very belated: I looked it up--your laptop is AMD APU-related. As touched upon in my previous post, I think that you must use fglrx to enable sound via HDMI--it's likely that you must give in to AMD on this--or resort to analog. I believe that the files you mentioned are in proc/asound--not etc.
gsnoorky
 
Posts: 15
Joined: 2013-05-30 14:01


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable