Iceweasel not starting [SOLVED]

Everything about X, Gnome, KDE, ... and everything running on it

Iceweasel not starting [SOLVED]

Postby ckosloff » 2012-07-25 13:23

After d-u today I got following error:

Code: Select all
ckosloff@papimalo:~$ iceweasel
Error: Platform version '10.0.6' is not compatible with
minVersion >= 10.0.5
maxVersion <= 10.0.5
ckosloff@papimalo:~$
Last edited by ckosloff on 2012-07-26 03:51, edited 1 time in total.
User avatar
ckosloff
 
Posts: 244
Joined: 2011-12-29 15:08
Location: South Florida, USA

Re: Iceweasel not starting

Postby cynwulf » 2012-07-25 13:43

Code: Select all
$ aptitude search ~iicewea ~ixulrun
cynwulf
 
Posts: 2397
Joined: 2008-09-25 08:49

Re: Iceweasel not starting

Postby ckosloff » 2012-07-25 14:05

Code: Select all
ckosloff@papimalo:~$ aptitude search ~iicewea ~ixulrun
i   iceweasel                           - Web browser based on Firefox                 
i A xulrunner-10.0                      - XUL + XPCOM application runner     
User avatar
ckosloff
 
Posts: 244
Joined: 2011-12-29 15:08
Location: South Florida, USA

Re: Iceweasel not starting

Postby ckosloff » 2012-07-25 14:44

Code: Select all
ckosloff@papimalo:~$ apt-cache policy iceweasel
iceweasel:
  Installed: 10.0.5esr-1
  Candidate: 10.0.5esr-1
  Package pin: (not found)
  Version table:
     10.0.6esr-1 700
        500 http://ftp.us.debian.org/debian/ wheezy/main amd64 Packages
        500 http://http.us.debian.org/debian/ wheezy/main amd64 Packages
 *** 10.0.5esr-1 700
        100 /var/lib/dpkg/status

I think that there is a mismatch in wheezy, definitely a bug in wheezy.
User avatar
ckosloff
 
Posts: 244
Joined: 2011-12-29 15:08
Location: South Florida, USA

Re: Iceweasel not starting

Postby cynwulf » 2012-07-25 15:11

Code: Select all
$ apt-cache policy xulrunner-10.0

(should be 10.0.6esr-1 - hence the mismatch between iceweasel and xulrunner)

According to your apt-cache policy output there is an upgrade available...

Code: Select all
# apt-get dist-upgrade


If that won't upgrade, then likely package holds/pinning are interfering...

Code: Select all
# apt-get install iceweasel=10.0.6esr-1


You also seem to have duplicate sources.
cynwulf
 
Posts: 2397
Joined: 2008-09-25 08:49

Re: Iceweasel not starting [SOLVED]

Postby ckosloff » 2012-07-26 03:52

It was all my mistake.
I had iceweasel from experimental in this system, later decided to do only wheezy, while keeping experimental on other machines.
So, on this machine I commented out experimental sources, but forgot to delete the preferences file in /etc/apt/preferences.d.
Once I did, everything went back to normal.
Soooo sorry.
User avatar
ckosloff
 
Posts: 244
Joined: 2011-12-29 15:08
Location: South Florida, USA


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable