[SOLVED] segfault errors

New to Debian (Or Linux in general)? Ask your questions here!

[SOLVED] segfault errors

Postby silverx » 2013-01-12 17:32

Hi all ,
I am new to debian which i have just started to get used to . But an issue here continues to pain me
After i boot my system and try launching chrome , it simply fails to launch with the below logs. I have to keep restarting my system till the problem ceases to occur ..
I am at my wit's end trying to fix this ..any help here would be much appreciated.


logs as below
Jan 6 14:53:19 sp kernel: [ 55.570401] chromium-browse[2132]: segfault at 7f17ced600a0 ip 00007f152ba06d49 sp 00007fff1f433420 error 4 in libflashplayer.so[7f152b259000+117b000]
Jan 6 14:54:54 sp kernel: [ 47.978799] chromium-browse[2079]: segfault at fffffffffffffff8 ip 00007f73c1e62ddb sp 00007fffae1a6f80 error 4 in libstdc++.so.6.0.13[7f73c1dba000+f6000]
Jan 6 14:58:36 sp kernel: [ 270.002906] chromium-browse[2294]: segfault at fffffffffffffff8 ip 00007ff6826e7ddb sp 00007fff396fca50 error 4 in libstdc++.so.6.0.13[7ff68263f000+f6000]

Regs
Silver
Last edited by silverx on 2013-02-01 01:52, edited 2 times in total.
silverx
 
Posts: 25
Joined: 2013-01-12 17:20

Re: segfault errors

Postby verahill » 2013-01-13 06:27

What version of debian are you running? How did you install Chrome (or are you using Chromium?)? And how did you install the flash player? Have you got issues with any other browser? What does your /etc/apt/sources.list look like?

Your first course action should probably be to disable flash and see if that solves it.

What puzzles me is this:
I have to keep restarting my system till the problem ceases to occur ..

So it works some of the time -- just not most (50%? 90%? 99%?) of the time?
--------------------------------------------------
http://verahill.blogspot.com
OPs: don't forget to mark your (first) post as solved when the issue has been resolved.
User avatar
verahill
 
Posts: 327
Joined: 2012-05-29 07:03
Location: Australia

Re: segfault errors

Postby silverx » 2013-01-13 13:39

hi .. thanks for replying
i am using debian release 6.0.6 (squeeze) kernel linux 2.6.32.-5 Gnome 2.30.2
Oh yes . i am using chromium not chrome.. installed using software centre ..
installed flash using this command -- Install flashplugin-nonfree
I have no other issue issue with my browser except the one that I reported .. when this problem crops up in chromium , ice weasel too fails to launch ..
most of the times it works on restart but sometimes i have to restart twice or thrice ..
haven't tried the option of disabling flash yet ..
have attached sources list below

#

# deb cdrom:[Debian GNU/Linux 6.0.5 _Squeeze_ - Official amd64 CD Binary-1 20120512-14:34]/ squeeze main

deb cdrom:[Debian GNU/Linux 6.0.5 _Squeeze_ - Official amd64 CD Binary-1 20120512-14:34]/ squeeze main

deb http://ftp.iitm.ac.in/debian/ squeeze main
deb-src http://ftp.iitm.ac.in/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
deb http://ftp.iitm.ac.in/debian/ squeeze-updates main
deb-src http://ftp.iitm.ac.in/debian/ squeeze-updates main

#SQUEEZE-BACKPORTS
deb http://backports.debian.org/debian-backports squeeze-backports main

Regs
Silver
silverx
 
Posts: 25
Joined: 2013-01-12 17:20

Re: segfault errors

Postby llivv » 2013-01-13 18:41

all your http:// sources.list entries all work.
Personally, I would comment out the second CD-ROM entry.

# deb cdrom:[Debian GNU/Linux 6.0.5 _Squeeze_ - Official amd64 CD Binary-1 20120512-14:34]/ squeeze main

deb cdrom:[Debian GNU/Linux 6.0.5 _Squeeze_ - Official amd64 CD Binary-1 20120512-14:34]/ squeeze main

and if you ever want to use the CD you installed from again you can just uncomment one of the
CD-ROM entries.

After that I would run as root using su or sudo
Code: Select all
aptitude -f install

from which ever terminal program you have installed.

it that command shows you something you don't understand
paste as much of it as you can in your next post.
in the kitchen with Julia ....
[...]
Get on the D bus to B Can ....
[...]
User avatar
llivv
 
Posts: 5585
Joined: 2007-02-14 18:10
Location: willo the tree

Re: segfault errors

Postby silverx » 2013-01-17 01:44

tried disabling flash and also commenting the cdrom sources from the sources.list

Did not help ..faced the same problem with software center and epiphany browser when i started my machine this morning .. however .. it worked fine after a restart


Please help :(
Logs below

Jan 17 07:25:58 sp kernel: [ 84.652174] software-center[2085] general protection ip:7fcf567c1af0 sp:7fffa0a33208 error:7fcc in libwebkit-1.0.so.2.17.9[7fcf5634a000+1083000]
Jan 17 07:26:36 sp kernel: [ 123.417656] epiphany-browse[2223]: segfault at 41e ip 00007f1d8fc4acd5 sp 00007fffb4194038 error 4 in libwebkit-1.0.so.2.17.9[7f1d8f843000+1083000]

Regs
Silver
silverx
 
Posts: 25
Joined: 2013-01-12 17:20

Re: segfault errors

Postby verahill » 2013-01-17 09:32

Someone else probably has a better idea of what's going on here than I do.

I don't think the libwebkit message necessarily is relevant since you said that both webkit (epiphany, chrome/ium) and gecko-based (firefox/iceweasel) browser have the same problem.

Again, the fact that rebooting helps makes me suspicious of a hardware error or that there's another program that's interfering, somehow. Does fsck run or do you get any disk-related errors on boot? Have you installed anything from sources other than the repositories? Are you using nvidia or amd drivers? (might sound ridiculous, but look at this post where the nvidia drivers kept on bringing down Evolution of all things: http://verahill.blogspot.com.au/2012/02 ... -real.html)

Also, start iceweasel/epiphany using strace and valgrind to see what's happening when the browsers crash. There'll be a lot of output, but you're specifically looking for warnings and errors. You might want to paste those here (not all the output though).

Is there anything we should know about the hardware and setup -- is the hardware very old? Very new? Are you dual-booting? Is this a problem which has persisted since day one? Or did it suddenly start one fateful morning?
--------------------------------------------------
http://verahill.blogspot.com
OPs: don't forget to mark your (first) post as solved when the issue has been resolved.
User avatar
verahill
 
Posts: 327
Joined: 2012-05-29 07:03
Location: Australia

Re: segfault errors

Postby silverx » 2013-01-19 16:46

hi ..
fsck runs every 31 restarts. I do get some inode related errors during the fsck run .. but they get fixed automatically right then.
not using any of nvidia or AMD drivers .. using the ones that came with the debian installation( nouveau for display)

Will soon send the strace logs for browser crashes ...

This is an assembled desktop bought in 2007
hardware specs as below
M2N-MX mother board
1Gb RAM
1TB hdd seagate
Processor (dual) : AMD athlon 64X2 Dual Core Processor 3600 +

I had other kinds of problems with my previous linux installations - mint and Ubuntu i.e of restart failing with the error /tmp not found or something and press F to continue .. Debian never had such issues .. so settled down on this .. i had windows more than a year ago .. where i had restarts going into some kind of error every time...


Does all this indicate a problem with the Mother board or the RAM ? Did read somewhere that segmentation errors can be caused by faulty RAMs too ..If so, how do I know that the RAM is the culprit ? ( but then again wouldn't faulty RAMs cause issues of a far more serious nature i.e blue screens , freezes .. failure to boot up .. than just seg faults ? )


Regs
Silver
silverx
 
Posts: 25
Joined: 2013-01-12 17:20

Re: segfault errors

Postby llivv » 2013-01-19 17:06

did you try uninstalling chromium?
if not try it.
But I have never even seen software center
so I can't help you with that.

So I would recommend you run this command from a terminal first and paste
what it tells you here before you actually uninstall the package.
Code: Select all
aptitude -s purge chromium

in case this is not self explanatory,
(n,y,q)
n = next solution
y = choose this solution (which will show you a simulation of what aptitude would do)
q = quit now
in the kitchen with Julia ....
[...]
Get on the D bus to B Can ....
[...]
User avatar
llivv
 
Posts: 5585
Joined: 2007-02-14 18:10
Location: willo the tree

Re: segfault errors

Postby silverx » 2013-01-20 04:55

hi
i ran the command .. It came back to the command prompt after choosing 'Y'

root@sp:/home/xxxx# aptitude -s purge chromium
The following packages will be REMOVED:
fonts-opensymbol{u} libbase-java-openoffice.org{u}
libboost-filesystem1.42.0{u} libboost-system1.42.0{u}
libboost-thread1.42.0{u} libcommons-logging-java{u} libhyphen0{u}
libjaxp1.3-java{u} libjaxp1.3-java-gcj{u} libmikmod2{u}
libsdl-mixer1.2{u} libsdl-ttf2.0-0{u}
libserializer-java-openoffice.org{u} libsmpeg0{u} libtextcat-data-utf8{u}
libtorrent-rasterbar5{u} libxerces2-java{u} libxerces2-java-gcj{u}
python-libtorrent{u} python-pygame{u} xfonts-mathml{u}
0 packages upgraded, 0 newly installed, 21 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 25.1 MB will be freed.
Do you want to continue? [Y/n/?] y
Would download/install/remove packages.
root@sp:/home/xxxx#


regs
Silver
silverx
 
Posts: 25
Joined: 2013-01-12 17:20

Re: segfault errors

Postby llivv » 2013-01-20 09:11

Good:
Please do the same as above ( run an aptitude simulation) for
libwebkit-1.0-2 , epiphany-browser and software-center
and post what it shows you.
Code: Select all
aptitude -s purge libwebkit-1.0-2

Code: Select all
aptitude -s purge epiphany-browser

Code: Select all
aptitude -s purge software-center
in the kitchen with Julia ....
[...]
Get on the D bus to B Can ....
[...]
User avatar
llivv
 
Posts: 5585
Joined: 2007-02-14 18:10
Location: willo the tree

Re: segfault errors

Postby silverx » 2013-01-20 09:34

hi
have run all the three .. please find below

the first one
root@sp:/home/xxxx# aptitude -s purge libwebkit-1.0-2
The following packages will be REMOVED:
fonts-opensymbol{u} libbase-java-openoffice.org{u}
libboost-filesystem1.42.0{u} libboost-system1.42.0{u}
libboost-thread1.42.0{u} libcommons-logging-java{u} libhyphen0{u}
libjaxp1.3-java{u} libjaxp1.3-java-gcj{u} libmikmod2{u}
libsdl-mixer1.2{u} libsdl-ttf2.0-0{u}
libserializer-java-openoffice.org{u} libsmpeg0{u} libtextcat-data-utf8{u}
libtorrent-rasterbar5{u} libwebkit-1.0-2{p} libxerces2-java{u}
libxerces2-java-gcj{u} python-libtorrent{u} python-pygame{u}
xfonts-mathml{u}
0 packages upgraded, 0 newly installed, 22 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 44.0 MB will be freed.
The following packages have unmet dependencies:
libseed0: Depends: libwebkit-1.0-2 (>= 1.1.1) but it is not going to be installed.
epiphany-browser: Depends: libwebkit-1.0-2 (>= 1.2.2) but it is not going to be installed.
empathy: Depends: libwebkit-1.0-2 (>= 1.1.15) but it is not going to be installed.
shotwell: Depends: libwebkit-1.0-2 (>= 1.1.1) but it is not going to be installed.
python-webkit: Depends: libwebkit-1.0-2 (>= 1.1.14) but it is not going to be installed.
epiphany-extensions: Depends: libwebkit-1.0-2 (>= 1.1.15) but it is not going to be installed.
gimp: Depends: libwebkit-1.0-2 (>= 1.1.1) but it is not going to be installed.
yelp: Depends: libwebkit-1.0-2 (>= 1.1.1) but it is not going to be installed.
liferea: Depends: libwebkit-1.0-2 (>= 1.1.1) but it is not going to be installed.
nautilus-sendto-empathy: Depends: libwebkit-1.0-2 (>= 1.1.15) but it is not going to be installed.
The following actions will resolve these dependencies:

Remove the following packages:
1) empathy
2) epiphany-browser
3) epiphany-extensions
4) gimp
5) gnome
6) gnome-accessibility
7) gnome-core
8) gnome-desktop-environment
9) gnome-user-guide
10) libseed0
11) liferea
12) nautilus-sendto-empathy
13) python-webkit
14) rhythmbox-plugins
15) shotwell
16) software-center
17) yelp

Leave the following dependencies unresolved:
18) gnome-control-center recommends gnome-user-guide
19) ekiga recommends yelp
20) empathy-common recommends yelp
21) epiphany-browser-data recommends epiphany-browser
22) evolution recommends yelp
23) gcalctool recommends yelp
24) gimp-data recommends gimp
25) libgimp2.0 recommends gimp
26) gnome-terminal recommends yelp
27) gucharmap recommends yelp
28) gnome recommends liferea | evolution-rss | blam
29) rhythmbox recommends yelp
30) rhythmbox recommends rhythmbox-plugins


Accept this solution? [Y/n/q/?] Y
The following packages will be REMOVED:
apache2.2-bin{u} aptdaemon{u} baobab{u} binfmt-support{u} bluez{u}
bogofilter{u} bogofilter-bdb{u} bogofilter-common{u} cheese{u}
cheese-common{u} cli-common{u} dasher{u} dasher-data{u}
dmz-cursor-theme{u} ekiga{u} empathy{a} empathy-common{u} eog{u}
epiphany-browser{a} epiphany-extensions{a} espeak{u} espeak-data{u}
evolution{u} evolution-common{u} evolution-exchange{u}
evolution-plugins{u} evolution-webcal{u} file-roller{u}
fonts-opensymbol{u} freedesktop-sound-theme{u} freeglut3{u} gcalctool{u}
gconf-defaults-service{u} gconf-editor{u} gdebi{u} gdebi-core{u} gedit{u}
gedit-common{u} gedit-plugins{u} geoclue{u} geoclue-hostip{u}
geoclue-localnet{u} geoclue-manual{u} geoclue-yahoo{u} gimp{a} gnome{a}
gnome-accessibility{a} gnome-accessibility-themes{u} gnome-backgrounds{u}
gnome-bluetooth{u} gnome-cards-data{u} gnome-codec-install{u}
gnome-core{a} gnome-desktop-environment{a} gnome-disk-utility{u}
gnome-games{u} gnome-games-data{u} gnome-games-extra-data{u} gnome-mag{u}
gnome-nettool{u} gnome-orca{u} gnome-screensaver{u} gnome-screenshot{u}
gnome-search-tool{u} gnome-session-canberra{u} gnome-system-log{u}
gnome-system-tools{u} gnome-themes{u} gnome-themes-extras{u}
gnome-themes-more{u} gnome-user-guide{a} gnome-user-share{u} gnuchess{u}
gnuchess-book{u} gok{u} gstreamer0.10-ffmpeg{u} gstreamer0.10-nice{u}
gstreamer0.10-tools{u} gtk2-engines{u} gtk2-engines-pixbuf{u}
gtk2-engines-smooth{u} gucharmap{u} guile-1.8-libs{u} gvfs-bin{u}
hamster-applet{u} libapache2-mod-dnssd{u} libapr1{u} libaprutil1{u}
libaprutil1-dbd-sqlite3{u} libaprutil1-ldap{u} libart2.0-cil{u}
libavahi-ui0{u} libbase-java-openoffice.org{u}
libboost-filesystem1.42.0{u} libboost-python1.42.0{u}
libboost-system1.42.0{u} libboost-thread1.42.0{u} libbrlapi0.5{u}
libcap-ng0{u} libchamplain-0.4-0{u} libchamplain-gtk-0.4-0{u}
libcheese-gtk18{u} libclutter-gtk-0.10-0{u} libcolorblind0{u}
libcommons-logging-java{u} libcryptui0{u} libdiscid0{u} libepc-1.0-2{u}
libepc-common{u} libepc-ui-1.0-2{u} libespeak1{u} libevolution{u}
libfreerdp-plugins-standard{u} libfreerdp0{u} libgail-gnome-module{u}
libgalago3{u} libgconf2.0-cil{u} libgdata-common{u} libgdata7{u}
libgdu-gtk0{u} libgee2{u} libgeoclue0{u} libgexiv2-0{u}
libglade2.0-cil{u} libglib2.0-cil{u} libgmime2.4-cil{u}
libgnome-bluetooth7{u} libgnome-mag2{u} libgnome-speech7{u}
libgnome-vfs2.0-cil{u} libgnome2.24-cil{u} libgnomepanel2.24-cil{u}
libgpod-common{u} libgpod4{u} libgsl0ldbl{u} libgssdp-1.0-2{u}
libgstfarsight0.10-0{u} libgtk2.0-cil{u} libgtkglext1{u}
libgtkhtml-editor-common{u} libgtkhtml-editor0{u} libgtkhtml3.14-19{u}
libgtkimageview0{u} libgtksourceview2.0-0{u}
libgtksourceview2.0-common{u} libgtkspell0{u} libgupnp-1.0-3{u}
libgupnp-igd-1.0-3{u} libhyphen0{u} libjaxp1.3-java{u}
libjaxp1.3-java-gcj{u} liblouis-data{u} liblouis2{u} liblqr-1-0{u}
libmagickcore3{u} libmagickwand3{u} libmikmod2{u}
libmono-addins-gui0.2-cil{u} libmono-addins0.2-cil{u}
libmono-cairo2.0-cil{u} libmono-corlib2.0-cil{u}
libmono-i18n-west2.0-cil{u} libmono-posix2.0-cil{u}
libmono-security2.0-cil{u} libmono-sharpzip2.84-cil{u}
libmono-system2.0-cil{u} libmusicbrainz3-6{u}
libndesk-dbus-glib1.0-cil{u} libndesk-dbus1.0-cil{u} libneon27-gnutls{u}
libnet1{u} libnice0{u} libopal3.6.8{u} libopenobex1{u} libportaudio2{u}
libpt2.6.7{u} libsdl-mixer1.2{u} libsdl-ttf2.0-0{u} libseed0{a}
libserializer-java-openoffice.org{u} libsmpeg0{u} libspeexdsp1{u}
libsrtp0{u} libtelepathy-farsight0{u} libtelepathy-glib0{u}
libtextcat-data-utf8{u} libtidy-0.99-0{u} libtorrent-rasterbar5{u}
libwebkit-1.0-2{p} libxerces2-java{u} libxerces2-java-gcj{u} liferea{a}
liferea-data{u} media-player-info{u} mesa-utils{u}
mobile-broadband-provider-info{u} mono-2.0-gac{u} mono-gac{u}
mono-runtime{u} mousetweaks{u} nautilus-sendto{u}
nautilus-sendto-empathy{a} network-manager-gnome{u} obex-data-server{u}
obexd-client{u} pkg-config{u} python-aptdaemon{u} python-aptdaemon-gtk{u}
python-axiom{u} python-beautifulsoup{u} python-brlapi{u}
python-bugbuddy{u} python-clientform{u} python-coherence{u}
python-configobj{u} python-crypto{u} python-epsilon{u}
python-evolution{u} python-feedparser{u} python-gdata{u} python-gdbm{u}
python-gst0.10{u} python-gtkglext1{u} python-gtksourceview2{u}
python-httplib2{u} python-libtorrent{u} python-louie{u} python-louis{u}
python-mako{u} python-markupsafe{u} python-mechanize{u} python-nevow{u}
python-opengl{u} python-openssl{u} python-pam{u} python-pkg-resources{u}
python-pyasn1{u} python-pyatspi{u} python-pygame{u} python-pysqlite2{u}
python-rdflib{u} python-serial{u} python-tagpy{u} python-twisted-bin{u}
python-twisted-conch{u} python-twisted-core{u} python-twisted-web{u}
python-utidylib{u} python-vte{u} python-webkit{a} python-xdg{u}
python-zope.interface{u} remmina{u} remmina-plugin-data{u}
remmina-plugin-rdp{u} remmina-plugin-vnc{u} rhythmbox{u}
rhythmbox-plugin-cdrecorder{u} rhythmbox-plugins{a} seahorse{u}
seahorse-plugins{u} shotwell{a} software-center{a} sound-juicer{u}
tcptraceroute{u} telepathy-gabble{u} telepathy-mission-control-5{u}
telepathy-salut{u} tomboy{u} totem{u} totem-coherence{u} totem-common{u}
totem-mozilla{u} totem-plugins{u} transmission-common{u}
transmission-gtk{u} update-manager-core{u} update-manager-gnome{u}
update-notifier{u} update-notifier-common{u} vino{u} xdg-user-dirs{u}
xdg-user-dirs-gtk{u} xfonts-mathml{u} yelp{a}
0 packages upgraded, 0 newly installed, 285 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 760 MB will be freed.
Do you want to continue? [Y/n/?] y
Would download/install/remove packages.
root@sp:/home/xxxx#


the second one
root@sp:/home/xxxx# aptitude -s purge epiphany-browser
The following packages will be REMOVED:
epiphany-browser{p} fonts-opensymbol{u} libbase-java-openoffice.org{u}
libboost-filesystem1.42.0{u} libboost-system1.42.0{u}
libboost-thread1.42.0{u} libcommons-logging-java{u} libhyphen0{u}
libjaxp1.3-java{u} libjaxp1.3-java-gcj{u} libmikmod2{u}
libsdl-mixer1.2{u} libsdl-ttf2.0-0{u}
libserializer-java-openoffice.org{u} libsmpeg0{u} libtextcat-data-utf8{u}
libtorrent-rasterbar5{u} libxerces2-java{u} libxerces2-java-gcj{u}
python-libtorrent{u} python-pygame{u} xfonts-mathml{u}
0 packages upgraded, 0 newly installed, 22 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 26.2 MB will be freed.
The following packages have unmet dependencies:
epiphany-extensions: Depends: epiphany-browser (>= 2.30.2) but it is not going to be installed.
Depends: epiphany-browser (< 2.31) but it is not going to be installed.
The following actions will resolve these dependencies:

Remove the following packages:
1) epiphany-extensions
2) gnome

Leave the following dependencies unresolved:
3) epiphany-browser-data recommends epiphany-browser


Accept this solution? [Y/n/q/?] Y
The following packages will be REMOVED:
aptdaemon{u} binfmt-support{u} cli-common{u} epiphany-browser{p}
epiphany-extensions{a} evolution-exchange{u} fonts-opensymbol{u} gdebi{u}
gdebi-core{u} gedit-plugins{u} gnome{a} gnome-codec-install{u}
gnome-themes-extras{u} gnome-themes-more{u} gtk2-engines-smooth{u}
libart2.0-cil{u} libbase-java-openoffice.org{u}
libboost-filesystem1.42.0{u} libboost-system1.42.0{u}
libboost-thread1.42.0{u} libcommons-logging-java{u} libgconf2.0-cil{u}
libgee2{u} libgexiv2-0{u} libglade2.0-cil{u} libglib2.0-cil{u}
libgmime2.4-cil{u} libgnome-vfs2.0-cil{u} libgnome2.24-cil{u}
libgnomepanel2.24-cil{u} libgpod-common{u} libgpod4{u} libgtk2.0-cil{u}
libgtkspell0{u} libhyphen0{u} libjaxp1.3-java{u} libjaxp1.3-java-gcj{u}
libmikmod2{u} libmono-addins-gui0.2-cil{u} libmono-addins0.2-cil{u}
libmono-cairo2.0-cil{u} libmono-corlib2.0-cil{u}
libmono-i18n-west2.0-cil{u} libmono-posix2.0-cil{u}
libmono-security2.0-cil{u} libmono-sharpzip2.84-cil{u}
libmono-system2.0-cil{u} libndesk-dbus-glib1.0-cil{u}
libndesk-dbus1.0-cil{u} libsdl-mixer1.2{u} libsdl-ttf2.0-0{u}
libserializer-java-openoffice.org{u} libsmpeg0{u} libtextcat-data-utf8{u}
libtorrent-rasterbar5{u} libxerces2-java{u} libxerces2-java-gcj{u}
liferea{u} liferea-data{u} media-player-info{u}
mobile-broadband-provider-info{u} mono-2.0-gac{u} mono-gac{u}
mono-runtime{u} network-manager-gnome{u} python-aptdaemon{u}
python-aptdaemon-gtk{u} python-libtorrent{u} python-mako{u}
python-markupsafe{u} python-pygame{u} python-vte{u} python-webkit{u}
rhythmbox{u} rhythmbox-plugin-cdrecorder{u} rhythmbox-plugins{u}
shotwell{u} software-center{u} tomboy{u} totem-mozilla{u}
transmission-common{u} transmission-gtk{u} update-manager-core{u}
update-manager-gnome{u} update-notifier{u} update-notifier-common{u}
xfonts-mathml{u}
0 packages upgraded, 0 newly installed, 87 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 154 MB will be freed.
Do you want to continue? [Y/n/?] Y
Would download/install/remove packages.

The third one
root@sp:/home/xxxx# aptitude -s purge software-center
The following packages will be REMOVED:
fonts-opensymbol{u} libbase-java-openoffice.org{u}
libboost-filesystem1.42.0{u} libboost-system1.42.0{u}
libboost-thread1.42.0{u} libcommons-logging-java{u} libhyphen0{u}
libjaxp1.3-java{u} libjaxp1.3-java-gcj{u} libmikmod2{u}
libsdl-mixer1.2{u} libsdl-ttf2.0-0{u}
libserializer-java-openoffice.org{u} libsmpeg0{u} libtextcat-data-utf8{u}
libtorrent-rasterbar5{u} libxerces2-java{u} libxerces2-java-gcj{u}
python-libtorrent{u} python-pygame{u} software-center{p} xfonts-mathml{u}
0 packages upgraded, 0 newly installed, 22 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 27.4 MB will be freed.
The following packages have unmet dependencies:
gnome: Depends: software-center but it is not going to be installed.
The following actions will resolve these dependencies:

Remove the following packages:
1) gnome



Accept this solution? [Y/n/q/?] Y
The following packages will be REMOVED:
aptdaemon{u} binfmt-support{u} cli-common{u} epiphany-extensions{u}
evolution-exchange{u} fonts-opensymbol{u} gdebi{u} gdebi-core{u}
gedit-plugins{u} gnome{a} gnome-codec-install{u} gnome-themes-extras{u}
gnome-themes-more{u} gtk2-engines-smooth{u} libart2.0-cil{u}
libbase-java-openoffice.org{u} libboost-filesystem1.42.0{u}
libboost-system1.42.0{u} libboost-thread1.42.0{u}
libcommons-logging-java{u} libgconf2.0-cil{u} libgee2{u} libgexiv2-0{u}
libglade2.0-cil{u} libglib2.0-cil{u} libgmime2.4-cil{u}
libgnome-vfs2.0-cil{u} libgnome2.24-cil{u} libgnomepanel2.24-cil{u}
libgpod-common{u} libgpod4{u} libgtk2.0-cil{u} libgtkspell0{u}
libhyphen0{u} libjaxp1.3-java{u} libjaxp1.3-java-gcj{u} libmikmod2{u}
libmono-addins-gui0.2-cil{u} libmono-addins0.2-cil{u}
libmono-cairo2.0-cil{u} libmono-corlib2.0-cil{u}
libmono-i18n-west2.0-cil{u} libmono-posix2.0-cil{u}
libmono-security2.0-cil{u} libmono-sharpzip2.84-cil{u}
libmono-system2.0-cil{u} libndesk-dbus-glib1.0-cil{u}
libndesk-dbus1.0-cil{u} libsdl-mixer1.2{u} libsdl-ttf2.0-0{u}
libserializer-java-openoffice.org{u} libsmpeg0{u} libtextcat-data-utf8{u}
libtorrent-rasterbar5{u} libxerces2-java{u} libxerces2-java-gcj{u}
liferea{u} liferea-data{u} media-player-info{u}
mobile-broadband-provider-info{u} mono-2.0-gac{u} mono-gac{u}
mono-runtime{u} network-manager-gnome{u} python-aptdaemon{u}
python-aptdaemon-gtk{u} python-libtorrent{u} python-mako{u}
python-markupsafe{u} python-pygame{u} python-vte{u} python-webkit{u}
rhythmbox{u} rhythmbox-plugin-cdrecorder{u} rhythmbox-plugins{u}
shotwell{u} software-center{p} tomboy{u} totem-mozilla{u}
transmission-common{u} transmission-gtk{u} update-manager-core{u}
update-manager-gnome{u} update-notifier{u} update-notifier-common{u}
xfonts-mathml{u}
0 packages upgraded, 0 newly installed, 86 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 153 MB will be freed.
Do you want to continue? [Y/n/?] Y
Would download/install/remove packages.

Regards
Silver
silverx
 
Posts: 25
Joined: 2013-01-12 17:20

Re: segfault errors

Postby llivv » 2013-01-20 19:08

Code: Select all
aptitude purge chromium-browser

it's been depreciated.

run the aptitude purge command while you have Debian User Forums
open in a browser other then Chromium or Epiphany.
and post what aptitude shows.

it's always possible that there are other problems not showing up so far.
in the kitchen with Julia ....
[...]
Get on the D bus to B Can ....
[...]
User avatar
llivv
 
Posts: 5585
Joined: 2007-02-14 18:10
Location: willo the tree

Re: segfault errors

Postby silverx » 2013-01-22 15:24

hi
i ran the aptitude command without the -s ... hope that doesnt change the output .. if it did let me know will do it all over again


root@sp:/home/xxxx# aptitude purge chromium-browser
The following packages will be REMOVED:
chromium-browser{p} fonts-opensymbol{u} libbase-java-openoffice.org{u} libboost-filesystem1.42.0{u} libboost-system1.42.0{u} libboost-thread1.42.0{u}
libcommons-logging-java{u} libhyphen0{u} libjaxp1.3-java{u} libjaxp1.3-java-gcj{u} libmikmod2{u} libsdl-mixer1.2{u} libsdl-ttf2.0-0{u}
libserializer-java-openoffice.org{u} libsmpeg0{u} libtextcat-data-utf8{u} libtorrent-rasterbar5{u} libxerces2-java{u} libxerces2-java-gcj{u}
python-libtorrent{u} python-pygame{u} xfonts-mathml{u}
0 packages upgraded, 0 newly installed, 22 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 63.0 MB will be freed.
Do you want to continue? [Y/n/?] y
(Reading database ... 130415 files and directories currently installed.)
Removing chromium-browser ...
Purging configuration files for chromium-browser ...
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for menu ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
(Reading database ... 130383 files and directories currently installed.)
Removing fonts-opensymbol ...
Removing libserializer-java-openoffice.org ...
Removing libbase-java-openoffice.org ...
Removing python-libtorrent ...
Removing libtorrent-rasterbar5 ...
ldconfig: /usr/lib32/libxcb-render-util.so.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib32/libxcb-render-util.so.0 is not a symbolic link

Removing libboost-filesystem1.42.0 ...
ldconfig: /usr/lib32/libxcb-render-util.so.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib32/libxcb-render-util.so.0 is not a symbolic link

Removing libboost-system1.42.0 ...
ldconfig: /usr/lib32/libxcb-render-util.so.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib32/libxcb-render-util.so.0 is not a symbolic link

Removing libboost-thread1.42.0 ...
ldconfig: /usr/lib32/libxcb-render-util.so.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib32/libxcb-render-util.so.0 is not a symbolic link

Removing libcommons-logging-java ...
Removing libhyphen0 ...
ldconfig: /usr/lib32/libxcb-render-util.so.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib32/libxcb-render-util.so.0 is not a symbolic link

Removing libxerces2-java-gcj ...
Removing libxerces2-java ...
Removing libjaxp1.3-java-gcj ...
Removing libjaxp1.3-java ...
Removing python-pygame ...
Removing libsdl-mixer1.2 ...
ldconfig: /usr/lib32/libxcb-render-util.so.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib32/libxcb-render-util.so.0 is not a symbolic link

Removing libmikmod2 ...
ldconfig: /usr/lib32/libxcb-render-util.so.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib32/libxcb-render-util.so.0 is not a symbolic link

Removing libsdl-ttf2.0-0 ...
ldconfig: /usr/lib32/libxcb-render-util.so.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib32/libxcb-render-util.so.0 is not a symbolic link

Removing libsmpeg0 ...
Removing libtextcat-data-utf8 ...
Removing xfonts-mathml ...
Segmentation fault
Invalid fonts.scale in /usr/share/fonts/X11/Type1/.
Processing triggers for fontconfig ...
Processing triggers for python-support ...

Regards
Silver
silverx
 
Posts: 25
Joined: 2013-01-12 17:20

Re: segfault errors

Postby llivv » 2013-01-22 15:33

post results from
Code: Select all
aptitude -f install



I reread the first few posts to double check which release you're using.
squeeze and squeeze-backposrts
poligies chromium-browser is isn't depreciated until wheezy is released.
But, that shouldn't be an issue ATM
Last edited by llivv on 2013-01-22 15:47, edited 1 time in total.
in the kitchen with Julia ....
[...]
Get on the D bus to B Can ....
[...]
User avatar
llivv
 
Posts: 5585
Joined: 2007-02-14 18:10
Location: willo the tree

Re: segfault errors

Postby silverx » 2013-01-22 15:37

Hi
i accept the solution ?

root@sp:/home/xxxx# aptitude -f install
The following NEW packages will be installed:
browser-plugin-gnash deluge-common{b} deluge-gtk gnash gnash-common{b} gnome-office{b} inkscape{b} libcommons-beanutils-java{b}
libcommons-collections3-java libcommons-compress-java libcommons-digester-java{b} libdb-je-java libdb4.7-java libdb4.7-java-gcj libgc1c2 libicu4j-java
libjtidy-java{b} liblucene2-java libregexp-java libreoffice libreoffice-base{b} libreoffice-base-core{b} libreoffice-calc{b} libreoffice-common{b}
libreoffice-core{b} libreoffice-draw{b} libreoffice-emailmerge libreoffice-filter-binfilter{b} libreoffice-filter-mobiledev libreoffice-impress
libreoffice-java-common{b} libreoffice-math{b} libreoffice-report-builder-bin{b} libreoffice-style-galaxy libreoffice-writer{b} openoffice.org{b}
openoffice.org-base-core{b} openoffice.org-common openoffice.org-emailmerge openoffice.org-evolution{b} openoffice.org-filter-mobiledev
openoffice.org-gnome{b} openoffice.org-gtk{b} openoffice.org-help-en-us{b} openoffice.org-java-common openoffice.org-officebean{b}
openoffice.org-report-builder-bin{b} openoffice.org-style-galaxy{b} openoffice.org-style-tango{b} python-uno{b} ttf-sil-gentium-basic uno-libs3 ure
w3m
The following packages will be REMOVED:
chromium-browser-inspector{u} libglewmx1.5{u} libgraphite3{u} libmythes-1.2-0{u} libv8-2.2.24{u} ttf-opensymbol{u}
The following packages are RECOMMENDED but will NOT be installed:
graphicsmagick-imagemagick-compat graphicsmagick-libmagick-dev-compat gstreamer0.10-fluendo-mp3 imagemagick libcommons-logging-java
libtextcat-data-utf8 libwmf-bin openoffice.org-core openoffice.org-filter-binfilter perlmagick pstoedit python-pygame ttf-sil-gentium xfonts-mathml
0 packages upgraded, 54 newly installed, 6 to remove and 0 not upgraded.
Need to get 200 MB of archives. After unpacking 624 MB will be used.
The following packages have unmet dependencies:
libreoffice-draw: Depends: uno-libs3 (>= 3.5.0~beta) but 1.6.1+OOo3.2.1-11+squeeze8 is to be installed.
openoffice.org-evolution: Depends: openoffice.org-core (= 1:3.2.1-11+squeeze8) but it is not going to be installed.
Depends: openoffice.org-base but it is not going to be installed.
openoffice.org-officebean: Depends: openoffice.org-core (= 1:3.2.1-11+squeeze8) but it is not going to be installed.
libjtidy-java: Depends: libjaxp1.3-java but it is not going to be installed.
libcommons-beanutils-java: Depends: libcommons-logging-java but it is not going to be installed.
openoffice.org-base-core: Depends: openoffice.org-core (= 1:3.2.1-11+squeeze8) but it is not going to be installed.
openoffice.org-help-en-us: Depends: openoffice.org-writer but it is not going to be installed. or
language-support-translations-en which is a virtual package.
libreoffice-report-builder-bin: Depends: uno-libs3 (>= 1.7.0) but 1.6.1+OOo3.2.1-11+squeeze8 is to be installed.
libreoffice-math: Depends: fonts-opensymbol but it is not going to be installed.
openoffice.org-report-builder-bin: Depends: openoffice.org-core (> 1:2.3.0~oog680m1) but it is not going to be installed.
Depends: openoffice.org-base (>= 2.3.0~src680m225) but it is not going to be installed.
openoffice.org-gtk: Depends: openoffice.org-core (= 1:3.2.1-11+squeeze8) but it is not going to be installed.
libreoffice-common: Conflicts: openoffice.org-common (< 1:3.3.0~) but 1:3.2.1-11+squeeze8 is to be installed.
deluge-common: Depends: python-libtorrent (>= 0.14.9) but it is not going to be installed.
gnash-common: Depends: libboost-date-time1.42.0 (>= 1.42.0-1) but it is not going to be installed.
Depends: libboost-thread1.42.0 (>= 1.42.0-1) but it is not going to be installed.
python-uno: Depends: openoffice.org-core (= 1:3.2.1-11+squeeze8) but it is not going to be installed.
openoffice.org: Depends: openoffice.org-core (= 1:3.2.1-11+squeeze8) but it is not going to be installed.
Depends: openoffice.org-writer but it is not going to be installed.
Depends: openoffice.org-calc but it is not going to be installed.
Depends: openoffice.org-impress but it is not going to be installed.
Depends: openoffice.org-draw but it is not going to be installed.
Depends: openoffice.org-math but it is not going to be installed.
Depends: openoffice.org-base but it is not going to be installed.
libreoffice-base-core: Depends: uno-libs3 (>= 1.7.0) but 1.6.1+OOo3.2.1-11+squeeze8 is to be installed.
openoffice.org-style-tango: Depends: openoffice.org-core (>= 1:3.2.0~beta) but it is not going to be installed.
libreoffice-base: Depends: uno-libs3 (>= 1.7.0) but 1.6.1+OOo3.2.1-11+squeeze8 is to be installed.
Depends: ure (>= 3.5.4~) but 1.6.1+OOo3.2.1-11+squeeze8 is to be installed.
libreoffice-calc: Depends: uno-libs3 (>= 3.5.0~beta) but 1.6.1+OOo3.2.1-11+squeeze8 is to be installed.
gnome-office: Depends: simple-scan but it is not going to be installed.
libreoffice-java-common: Depends: libjaxp1.3-java but it is not going to be installed.
Depends: libserializer-java-openoffice.org but it is not going to be installed.
Depends: libxerces2-java but it is not going to be installed.
openoffice.org-style-galaxy: Depends: openoffice.org-core (>= 1:3.2.0~beta) but it is not going to be installed.
libreoffice-filter-binfilter: Depends: uno-libs3 (>= 3.5.0~beta) but 1.6.1+OOo3.2.1-11+squeeze8 is to be installed.
libcommons-digester-java: Depends: libcommons-logging-java but it is not going to be installed.
openoffice.org-gnome: Depends: openoffice.org-core (= 1:3.2.1-11+squeeze8) but it is not going to be installed.
inkscape: Depends: libmagick++3 (>= 7:6.6.0.4) but it is not going to be installed.
libreoffice-core: Depends: fonts-opensymbol but it is not going to be installed.
Depends: libhyphen0 (>= 2.4) but it is not going to be installed.
Depends: uno-libs3 (>= 3.5.0~beta) but 1.6.1+OOo3.2.1-11+squeeze8 is to be installed.
Depends: ure (>= 3.5.4~) but 1.6.1+OOo3.2.1-11+squeeze8 is to be installed.
libreoffice-writer: Depends: uno-libs3 (>= 1.7.0) but 1.6.1+OOo3.2.1-11+squeeze8 is to be installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) browser-plugin-gnash [Not Installed]
2) deluge-common [Not Installed]
3) deluge-gtk [Not Installed]
4) gnash [Not Installed]
5) gnash-common [Not Installed]
6) gnome-office [Not Installed]
7) inkscape [Not Installed]
8) libcommons-beanutils-java [Not Installed]
9) libcommons-digester-java [Not Installed]
10) libjtidy-java [Not Installed]
11) libreoffice [Not Installed]
12) libreoffice-base [Not Installed]
13) libreoffice-base-core [Not Installed]
14) libreoffice-calc [Not Installed]
15) libreoffice-common [Not Installed]
16) libreoffice-core [Not Installed]
17) libreoffice-draw [Not Installed]
18) libreoffice-emailmerge [Not Installed]
19) libreoffice-filter-binfilter [Not Installed]
20) libreoffice-filter-mobiledev [Not Installed]
21) libreoffice-impress [Not Installed]
22) libreoffice-java-common [Not Installed]
23) libreoffice-math [Not Installed]
24) libreoffice-report-builder-bin [Not Installed]
25) libreoffice-style-galaxy [Not Installed]
26) libreoffice-writer [Not Installed]
27) openoffice.org [Not Installed]
28) openoffice.org-base-core [Not Installed]
29) openoffice.org-common [Not Installed]
30) openoffice.org-emailmerge [Not Installed]
31) openoffice.org-evolution [Not Installed]
32) openoffice.org-filter-mobiledev [Not Installed]
33) openoffice.org-gnome [Not Installed]
34) openoffice.org-gtk [Not Installed]
35) openoffice.org-help-en-us [Not Installed]
36) openoffice.org-java-common [Not Installed]
37) openoffice.org-officebean [Not Installed]
38) openoffice.org-report-builder-bin [Not Installed]
39) openoffice.org-style-galaxy [Not Installed]
40) openoffice.org-style-tango [Not Installed]
41) python-uno [Not Installed]

Leave the following dependencies unresolved:
42) liblucene2-java recommends libcommons-beanutils-java (>= 1.7.0)
43) liblucene2-java recommends libcommons-digester-java (>= 1.7)
44) liblucene2-java recommends libjtidy-java (>= 7+svn20070309)
45) openoffice.org-help-en-us recommends openoffice.org-java-common
46) libreoffice-writer recommends libreoffice-filter-binfilter
47) libreoffice-writer recommends libreoffice-math


Accept this solution? [Y/n/q/?]

Regards
Silver
silverx
 
Posts: 25
Joined: 2013-01-12 17:20

Next

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable