Help installing Flash 10 in Etch XFCE

Desktop Environments and Multimedia
Post Reply
Posts: 53
Joined: 2008-07-30 20:01

Help installing Flash 10 in Etch XFCE

#1 Post by timzak »

I tried installing Flash 10 (I first uninstalled the Mozilla Flash plugin from the multimedia repositories) with gdebi, and had some errors (see my post in General regarding gdebi). So I then tried installing Flash 10 via .tar.gz, following Adobe's instructions. It doesn't appear to be working as Flash sites are telling me I don't have Flash installed.

Any help would be greatly appreciated. Should Flash 10 work properly in Etch?

Posts: 32
Joined: 2008-10-18 17:24

#2 Post by k9wazere »

If you're using 64-bit Debian there's a large thread just under yours which describes in detail the steps you need to take.

Posts: 53
Joined: 2008-07-30 20:01

#3 Post by timzak »

No, not 64 bit, but thanks. This is an old 32 bit machine, Celeron 466 with 256MB ram.

Posts: 32
Joined: 2008-10-18 17:24

#4 Post by k9wazere »

The only file you need then is

Stick that in $HOME/.mozilla/plugins

and it should register when you re-load your browser.

Posts: 53
Joined: 2008-07-30 20:01

#5 Post by timzak »

I already had in the appropriate spot. I recopied it in from the flash 10 .tar.gz just in case, but it still doesn't work. Youtube tells me that I either have JavaScript turned off or an old version of Adobe's Flash Player.

Youtube works fine with the Flash9 plugin from Debian multimedia repos. I'm trying to use Flash 10 instead, though. It works fine on my Ubuntu machine, but not on this Etch machine.

Any other ideas?

Edit: should I have the mozilla flash plugin from the multimedia repos installed or not installed prior to installing flash10?

Posts: 32
Joined: 2008-10-18 17:24

#6 Post by k9wazere »

The flashplugin-nonfree package simply installs to /usr/lib/mozila/plugins, I believe. So if you intend to use the one downloaded from Adobe, you should probably get rid of the Debian one ;)

If you have both installed, you can check which one got loaded if you type about:plugins into the address bar.

Posts: 53
Joined: 2008-07-30 20:01

#7 Post by timzak »

Actually, the Debian package I had installed was not flash-plugin-nonfree, it was mozilla-flash-plugin (whatever it's called, but it's not called flash-plugin-nonfree).

After removing the above package, I could not get flash10 to work, so I tried reinstalling above package then simply replacing it's file with flash10's version. It seems to be working now, though I don't understand why removing the mozilla plugin prevents flash10 from working.

User avatar
Posts: 7551
Joined: 2007-06-01 04:34

#8 Post by BioTube »

Probably symlinks.
Ludwig von Mises wrote:The elite should be supreme by virtue of persuasion, not by the assistance of firing squads.

Posts: 1
Joined: 2008-11-07 15:55
Location: Vejle, Denmark

no luck in debin either

#9 Post by Hamsjael »

Tried several things:

installed and uninstalled from mutimedia repo.

when i copy either in the user dir or the global one. it just doesnt show up.

Debian etch (x86), with

Adblock +
Danish dictionary
DOM insp.
Google toolbar

User avatar
Posts: 303
Joined: 2008-10-22 13:44

#10 Post by anarchyinc666 »

Version: 3.12
GIT d- s: a- C++++ UL++++ P+ L+++ E-- W+++ N- o-- K- w++
O- M-- V-- PS+++ PE+++ Y PGP+++ t-- 5-- X+++ R* tv+++ b DI++++ D
G e+ h---- r+++ y++++

Debian-SID Xfce

Posts: 16
Joined: 2008-11-10 15:39

#11 Post by sedusg »

Same problem here.
It seems that iceweasel in etch do NOT support flashplayer 10.
I really hate flashplayer 9.It caused 100% CPU usage here.
I used to use ubuntu 8.04 with flashplayer 10 without 100% CPU problem.

Posts: 14
Joined: 2006-06-12 19:56

#12 Post by redchair »

I have been having the same problem with installing Adobe Flash Player 10 on an etch system. I use Firefox as downloaded directly from Mozilla. I have always used the .tar.gz method and copied the file directly to my ~/.mozilla/plugins directory up until the last version of Flash Player 9 with success. Success is defined as having Flash Player appear in about:plugins, and being able to play flash content such as Youtube.

It is important to note that Flash Player 10 is detected by Firefox but doesn't load as a plugin. The only evidence that the plugin is detected is that the browser adds the following entry and value to the about:config list; trying to reset the value does not work until Flash Plugin 10 is removed from the plugins directory and firefox is restarted:
user_pref("plugin.soname.list", "");

I have found some clues on google that an "updated system" is necessary for success with Flash Player 10, and it may be related to needing libgtk2.1 (I currently have libgtk2.0). My system is a 32 bit system with all 32 bit applications.

I would like to request that a few other people post with the output of the hash below to make sure we are all using the same "broken" version of Flash Player 10.
$ openssl dgst -sha1 install_flash_player_10_linux.tar.gz
SHA1(install_flash_player_10_linux.tar.gz)= 3590bf257b5d20b23f1668b1b789595d452db039
Adobe Flash Player version
.tar.gz for Linux (x86) | 3.7MB

Posts with people trying to install flash 10 on etch using the .tar.gz and copy method. ... etch+flash ... etch+flash

Posts: 25
Joined: 2008-05-21 14:54
Location: Oregon

#13 Post by tak »

You may want to remove from /usr/lib/mozilla/plugins
that's what worked for me. I then installed flash 10 with the deb file available on the Adobe website

I used the one for Ubuntu 8.04 and it worked (probably b/c all that the deb does is to put the plugin file in /usr/lib/mozilla/plugins/
Inspiron 5150 - Lenny - XFCE

Posts: 14
Joined: 2006-06-12 19:56

#14 Post by redchair »

Thanks for the suggestion, tak. However since my firefox install was done using the installer from mozilla (a long time ago), it never created the directory /usr/lib/mozilla/plugins (all firefox-related directories are in my home directory). Also running a full disk search for doesn't turn up anything.

Since the end result of using the .deb as you describe is to copy the new .so file to the plugins directory, I think I'll keep my focus on doing the copying manually from the .tar.gz file.

Posts: 1
Joined: 2006-07-02 15:33

too old libc version in 4.0 (etch)

#15 Post by qhublan »

The problem with flash player 10 and debian etch is caused by the fact
that the so library is build against `GLIBC_2.4' version while in etch (4.0)
the libc version is 2.3.6

ldd output:

Code: Select all

"./ /lib/tls/i686/cmov/ version `GLIBC_2.4' not found (required by ./"

Post Reply