Problem with CUPS

New to Debian (Or Linux in general)? Ask your questions here!
Post Reply
Message
Author
ekso
Posts: 2
Joined: 2011-08-19 20:57

Problem with CUPS

#1 Post by ekso »

Hi
I'm installed CUPS:

1. apt-get install cups cups-client hplip
2. /etc/init.d/cups start
3. localhost:631

When I try to add "New Printer" I see the message on the screen:
Unable to add printer: Forbidden

In log file message:

failed to CreateProfile: org.freedesktop.DBus.Error.NoReply:Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
[CGI] CUPS-Get-Devices request failed with status 401: Forbidden

How can I fix it? thanks...

Revenger
Posts: 383
Joined: 2010-11-16 11:47

Re: Problem with CUPS

#2 Post by Revenger »

Make sure your user is in lpadmin group.
Next time someone says 'Go to hell' to me, I come right here.

Do you need bad help?

ekso
Posts: 2
Joined: 2011-08-19 20:57

Re: Problem with CUPS

#3 Post by ekso »

Thank you!!!!
After adding user to group it worked!

martin
Posts: 1
Joined: 2013-10-26 22:02

Re: Problem with CUPS

#4 Post by martin »

I solved this one by changing /etc/cups/cupsd.conf to

<Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default CUPS-Get-Devices>
# AuthType Default
# Require user @SYSTEM
Order deny,allow
Allow from localhost
</Limit>

User avatar
esp7
Posts: 178
Joined: 2013-06-23 20:31
Has thanked: 2 times
Been thanked: 4 times

Re: Problem with CUPS

#5 Post by esp7 »

Revenger wrote:Make sure your user is in lpadmin group.

confirmed, i had a similar issue some weeks ago. this command as root solved it...

Code: Select all

usermod -a -G lpadmin USER
ThinkPad X220: i5-2520M CPU 2.5GHz - 8GB RAM 1333 MHz - SSD 860 EVO 250GB - Debian - ME_cleaned
ThinkPad X230: i5-3320M CPU 3.3GHz - 8GB RAM 1600 MHz - SSD 860 EVO 500GB - Debian - ME_cleaned

Post Reply