Search found 8 matches

by vincent-
2021-03-07 21:35
Forum: Installation
Topic: [SOLVED] PXE installation - unable to load preseed over HTTP
Replies: 5
Views: 2908

Re: PXE installation - unable to load preseed over HTTP

Apparently, auto is not the same as auto=true priority=critical . This is the kernel command line I needed to use: auto=true priority=critical interface=eno1 url=http://fake-domain/preseed.cfg Thanks to the priority=critical option no questions are asked at the beginning. Therefore the installation ...
by vincent-
2021-03-06 22:42
Forum: Installation
Topic: [SOLVED] PXE installation - unable to load preseed over HTTP
Replies: 5
Views: 2908

Re: PXE installation - unable to load preseed over HTTP

Thanks for taking your time to answer my post.

That's exactly the same documentation I've been using all the time. Did I miss something from it? Some explanation instead of just posting a URL would be more helpful.
by vincent-
2021-03-06 15:54
Forum: Installation
Topic: [SOLVED] PXE installation - unable to load preseed over HTTP
Replies: 5
Views: 2908

Re: PXE installation - unable to load preseed over HTTP

I've managed to get a little bit further by using this kernel command line: language=en country=GB locale=en_GB.UTF-8 keymap=us interface=eno1 auto url=http://fake-domain/preseed.cfg Now the first steps of the Debian installer are automated thanks to those kernel command line options. It manages to ...
by vincent-
2021-03-06 14:36
Forum: Installation
Topic: [SOLVED] PXE installation - unable to load preseed over HTTP
Replies: 5
Views: 2908

[SOLVED] PXE installation - unable to load preseed over HTTP

Context I'm trying to automate a Debian Buster installation booting the machine from PXE and using a "preseed.cfg". What has been done I am booting from PXE using the kernel ("linux" file) and the initramfs ("inird.gz" file) from here: https://deb.debian.org/debian/dis...
by vincent-
2018-10-14 08:45
Forum: System and Network configuration
Topic: [SOLVED] Fail to suspend and hibernate
Replies: 4
Views: 3339

Re: [SOLVED] Fail to suspend and hibernate

I have updated my laptop's BIOS and now both suspend and hibernate work fine using the latest Debian kernel.
by vincent-
2018-10-14 07:33
Forum: System and Network configuration
Topic: [SOLVED] Fail to suspend and hibernate
Replies: 4
Views: 3339

Re: Fail to suspend and hibernate

I have built an even older kernel version and then tried to suspend. It failed as well, but this time it displayed a message in the console: ahci 0000:00:1f.2: BIOS update required for suspend/resume pci_legacy_suspend(): ahci_pci_device_suspend+0x0/0x60 [ahci] returns -5 dpm_run_callback(): pci_pm_...
by vincent-
2018-10-12 10:06
Forum: System and Network configuration
Topic: [SOLVED] Fail to suspend and hibernate
Replies: 4
Views: 3339

Re: Fail to suspend and hibernate

Adding more information to this topic. I downloaded the latest version of the 4.4.x Linux kernel series (at the moment of writing this post is 4.4.160) and I followed these steps to build Debian packages for it: - Download the kernel tarball - Unpack it in /usr/src/ - Copy the config file of the ker...
by vincent-
2018-10-04 07:10
Forum: System and Network configuration
Topic: [SOLVED] Fail to suspend and hibernate
Replies: 4
Views: 3339

[SOLVED] Fail to suspend and hibernate

Hello, I have a fresh and updated installation of Debian Stretch on my HP Pavilion dv5, and I cannot figure out why I cannot suspend or hibernate using the following commands: systemctl suspend systemctl hibernate Here are the logs for suspend : $ journalctl -r -u suspend.target -- Logs begin at Wed...