[Solved] X won't start on Buster, Asus TP210S

If none of the more specific forums is the right place to ask
Post Reply
Message
Author
noober1983
Posts: 71
Joined: 2012-04-03 00:12
Location: MX

[Solved] X won't start on Buster, Asus TP210S

#1 Post by noober1983 »

Hello all.
I installed Testing on an Asus TP210S (ISO file downloaded from https://ftp.acc.umu.se/cdimage/unoffici ... 64/iso-cd/, not the "edu" one), but X won't start. Here's Xorg.0.log from that laptop: https://pastebin.com/u8nJc5pr.
I installed the packages intel-microcode and firmware-misc-nonfree but it still doesn't start X.
When I query "lsmod|grep -i vga" nothing is returned. The package xserver-xorg-video-intel is installed; I report on this because the last time I had this problem on another laptop, it was solved by installing this package.
On running "inxi -Gx" I found out that the driver loaded is modsetting, and it marks fbdev, vesa as unloaded; when trying to load vesa I get the error "FATAL: Module vesa not found in directory /lib/modules/4.19.0-4-amd64/"; when I try loading fbdev no error is produced but then I run lsmod|grep fbdev and nothing appears. Here's the output of "lsmod|grep -i video": https://pastebin.com/nahAuKFi
Two other things:
1. Whenever I start the laptop, one of the first messages on screen is "Resuming from hibernation", which is quite odd because I just installed the system and haven't enabled hibernation (and I'm not planning on doing it).
2. If left to itself, after about 5 minutes without a login, the laptop will automatically shutdown.
Any suggestions? I really want to install Testing on this one, specifically because of the more updated version of TeXLive, and because I bought this laptop to use at the office.
Last edited by noober1983 on 2019-05-05 23:11, edited 1 time in total.
Quid non intellegas aut tace aut disce.

User avatar
4D696B65
Site admin
Site admin
Posts: 2627
Joined: 2009-06-28 06:09
Been thanked: 5 times

Re: X won't start on Buster, Asus TP210S

#2 Post by 4D696B65 »

noober1983 wrote: When I query "lsmod|grep -i vga" nothing is returned.
What about

Code: Select all

lspci|grep -i vga

Dai_trying
Posts: 960
Joined: 2016-01-07 12:25

Re: X won't start on Buster, Asus TP210S

#3 Post by Dai_trying »

I think this line is relevant

Code: Select all

[    29.163] (EE) modeset(0): failed to set mode: Invalid argument
I have the same problem with my dell laptop and the workaround I used was to create an xorg.conf file and place it in any of the relevant places (I used /usr/share/X11/xorg.conf.d/)

User avatar
Head_on_a_Stick
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: X won't start on Buster, Asus TP210S

#4 Post by Head_on_a_Stick »

And try the RC1 installer instead of the alpha version.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

noober1983
Posts: 71
Joined: 2012-04-03 00:12
Location: MX

Re: X won't start on Buster, Asus TP210S

#5 Post by noober1983 »

4D696B65 wrote:
noober1983 wrote: When I query "lsmod|grep -i vga" nothing is returned.
What about

Code: Select all

lspci|grep -i vga
Yeah, sorry:

Code: Select all

00:02.0 VGA Compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev 35)
Also, this is the output of inxi -Gx --display on a normal user (no root):

Code: Select all

Graphics:  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics driver: i915 v: kernel 
           Display: tty server: X.org 1.20.3 driver: modesetting unloaded: fbdev,vesa tty: 170x48 
           Message: No advanced graphics data found on this system. 
Dai_trying wrote:I think this line is relevant

Code: Select all

[    29.163] (EE) modeset(0): failed to set mode: Invalid argument
I have the same problem with my dell laptop and the workaround I used was to create an xorg.conf file and place it in any of the relevant places (I used /usr/share/X11/xorg.conf.d/)
Hi, thanks. What did you put on your xorg.conf file?
Head_on_a_Stick wrote:And try the RC1 installer instead of the alpha version.
Should I try the "edu" version? It says it's designed specifically for Intel 64-bit machines.

Thank you all!
Quid non intellegas aut tace aut disce.

User avatar
Head_on_a_Stick
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: X won't start on Buster, Asus TP210S

#6 Post by Head_on_a_Stick »

noober1983 wrote:
Head_on_a_Stick wrote:And try the RC1 installer instead of the alpha version.
Should I try the "edu" version?
Not unless you want a version designed for schools & colleges.

To force the Intel DDX driver, create a file at /etc/X11/xorg.conf.d/20-intel.conf with this content:

Code: Select all

Section "Device"
   Identifier "Intel Graphics"
   Driver "intel"
   #Option "TearFree" "yes"
EndSection
If you get any screen tearing then un-comment the Option line.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

Dai_trying
Posts: 960
Joined: 2016-01-07 12:25

Re: X won't start on Buster, Asus TP210S

#7 Post by Dai_trying »

What I did was to boot by editing the grub entry (press e at grub screen) and add "single" (without the quotes) to the end of the line that starts "Linux" and then press ctrl+x or F10 and when prompted enter the root password.
Then I entered the command

Code: Select all

Xorg -configure
which should create an xorg.conf file (xorg.conf.new) you can copy and rename it to xorg.conf

Code: Select all

cp xorg.conf.new /usr/share/X11/xorg.conf.d/xorg.conf
then type "exit" and it should get you into the gui (fingers crossed).

noober1983
Posts: 71
Joined: 2012-04-03 00:12
Location: MX

Re: X won't start on Buster, Asus TP210S

#8 Post by noober1983 »

Dai_trying wrote:What I did was to boot by editing the grub entry (press e at grub screen) and add "single" (without the quotes) to the end of the line that starts "Linux" and then press ctrl+x or F10 and when prompted enter the root password.
Then I entered the command

Code: Select all

Xorg -configure
which should create an xorg.conf file (xorg.conf.new) you can copy and rename it to xorg.conf

Code: Select all

cp xorg.conf.new /usr/share/X11/xorg.conf.d/xorg.conf
then type "exit" and it should get you into the gui (fingers crossed).
This worked! Thanks a lot!
Quid non intellegas aut tace aut disce.

Dai_trying
Posts: 960
Joined: 2016-01-07 12:25

Re: [Solved] X won't start on Buster, Asus TP210S

#9 Post by Dai_trying »

You're welcome :D

Post Reply