Delaying a startup app

If none of the more specific forums is the right place to ask
Message
Author
Lonewolf71
Posts: 50
Joined: 2021-06-30 21:38
Been thanked: 2 times

Delaying a startup app

#1 Post by Lonewolf71 »

I installed Tilda, on my Debian 10 box, but unlike Mint It has no delay option available. I would like to give it a 60 sec delay so all my programs can load before it starts up.

User avatar
wizard10000
Posts: 196
Joined: 2019-04-16 23:15
Location: southeastern us
Has thanked: 18 times
Been thanked: 6 times

Re: Delaying a startup app

#2 Post by wizard10000 »

Lonewolf71 wrote: 2021-07-15 13:08 I installed Tilda, on my Debian 10 box, but unlike Mint It has no delay option available. I would like to give it a 60 sec delay so all my programs can load before it starts up.
IME if you start tilda too quickly it fails to read its own configuration and creates a new default one. grumble.

Here's how I do it in ~/.config/openbox/autostart -

Code: Select all

sleep 3 && tilda &
I think the easiest way to get where you want to be is to rename tilda's .desktop file in ~/.config/autostart since they're started alphabetically (force it to start last) and then add your sleep to the .desktop file something like this -

Code: Select all

Exec= sh -c 'sleep X && tilda'
You can replace the X with the sleep value that works best for you.

Hope this helps -
we see things not as they are, but as we are.
-- anais nin

Lonewolf71
Posts: 50
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Delaying a startup app

#3 Post by Lonewolf71 »

family@hp-lin:~$ Exec= sh -c 'sleep 60 && tilda'
Tilda has started. Press F2 to pull down the window.

Is this correct?

EDIT: Not working

jakoline1
Posts: 41
Joined: 2021-07-06 00:49
Been thanked: 1 time

Re: Delaying a startup app

#4 Post by jakoline1 »

#Thanks to @wizard10000 for pointing me towards this solution.
#Note that on my system I don't need to delay Tilda as it's not causing any problems for me.

1- First you should add Tilda to your list of auto-start applications from control center or system settings for example

2- In your home directory find .config/autostart/tilda.desktop (you will need to enable show hidden files).

3- Once you've found the file, open it using a plain text editor, DO NOT DOUBLE CLICK, use right click then open with, pick a plain text editor like Pluma or Gedit not LibreOffice.

4- Add the following line to the end of the file, but replace 100 with the number of seconds you want to delay Tilda for

Code: Select all

Exec= sh -c 'sleep 100 && tilda'
Your file should look similar (but not necessarily identical) to this:

Image

5- Restart to see if the delay is working as expected or not.

Recommended Customizations:

Here is how I customized my Tilda. Notice how I've set some options ON and some OFF according to my likings.
Pull-down Tilda (the default key for that should be F1), then right click on it and choose preferences.

1- In general tab
Start Tilda hidden is probably what you're looking for.

Image

2- In appearance tab

Image

3- In Key Bindings tab

Image

Click on the action you wanna edit then press from your keyboard the shortcut you wish to bind with that action, for example Ctrl and the letter T.

Image

You can also set a key binding to Add and Close Tabs, but for me Tilda is just a way to launch simple commands and see results in a quick manner, when I need many tabs I use the real terminal. Also know that Tilda is buggy so if you're facing issues you're not the only one.

Let us know how Tilda is working for you or if you face any problems.
Last edited by jakoline1 on 2021-07-15 19:03, edited 2 times in total.

User avatar
wizard10000
Posts: 196
Joined: 2019-04-16 23:15
Location: southeastern us
Has thanked: 18 times
Been thanked: 6 times

Re: Delaying a startup app

#5 Post by wizard10000 »

Lonewolf71 wrote: 2021-07-15 15:45 family@hp-lin:~$ Exec= sh -c 'sleep 60 && tilda'
Tilda has started. Press F2 to pull down the window.

Is this correct?

EDIT: Not working
F2? Should be F12 unless you changed it :)
we see things not as they are, but as we are.
-- anais nin

Lonewolf71
Posts: 50
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Delaying a startup app

#6 Post by Lonewolf71 »

jakoline1 wrote: 2021-07-15 18:02 #Thanks to @wizard10000 for pointing me towards this solution.
#Note that on my system I don't need to delay Tilda as it's not causing any problems for me.

1- First you should add Tilda to your list of auto-start applications from control center or system settings for example

2- In your home directory find .config/autostart/tilda.desktop (you will need to enable show hidden files).

3- Once you've found the file, open it using a plain text editor, DO NOT DOUBLE CLICK, use right click then open with, pick a plain text editor like Pluma or Gedit not LibreOffice.

4- Add the following line to the end of the file, but replace 100 with the number of seconds you want to delay Tilda for

Code: Select all

Exec= sh -c 'sleep 100 && tilda'
Your file should look similar (but not necessarily identical) to this:

Image

5- Restart to see if the delay is working as expected or not.

Recommended Customizations:

Here is how I customized my Tilda. Notice how I've set some options ON and some OFF according to my likings.
Pull-down Tilda (the default key for that should be F1), then right click on it and choose preferences.

1- In general tab
Start Tilda hidden is probably what you're looking for.

Image

2- In appearance tab

Image

3- In Key Bindings tab

Image

Click on the action you wanna edit then press from your keyboard the shortcut you wish to bind with that action, for example Ctrl and the letter T.

Image

You can also set a key binding to Add and Close Tabs, but for me Tilda is just a way to launch simple commands and see results in a quick manner, when I need many tabs I use the real terminal. Also know that Tilda is buggy so if you're facing issues you're not the only one.

Let us know how Tilda is working for you or if you face any problems.
Image

Lonewolf71
Posts: 50
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Delaying a startup app

#7 Post by Lonewolf71 »

wizard10000 wrote: 2021-07-15 18:26
Lonewolf71 wrote: 2021-07-15 15:45 family@hp-lin:~$ Exec= sh -c 'sleep 60 && tilda'
Tilda has started. Press F2 to pull down the window.

Is this correct?

EDIT: Not working
F2? Should be F12 unless you changed it :)
I changed that to F1

jakoline1
Posts: 41
Joined: 2021-07-06 00:49
Been thanked: 1 time

Re: Delaying a startup app

#8 Post by jakoline1 »

You needn't open the file as root, it's located in your home directory no need for any permissions.

Open terminal and type nano "path-to-file" without quotation marks

Code: Select all

nano ~/.config/autostart/tilda.desktop
Then add the new line and press (Ctrl+X) then (Y) to save changes then hit Enter

Is it working now?

Lonewolf71
Posts: 50
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Delaying a startup app

#9 Post by Lonewolf71 »

jakoline1 wrote: 2021-07-16 11:07 You needn't open the file as root, it's located in your home directory no need for any permissions.

Open terminal and type nano "path-to-file" without quotation marks

Code: Select all

nano ~/.config/autostart/tilda.desktop
Then add the new line and press (Ctrl+X) then (Y) to save changes then hit Enter

Is it working now?
Yes! Thanks!

Image

Lonewolf71
Posts: 50
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Delaying a startup app

#10 Post by Lonewolf71 »

jakoline1 wrote: 2021-07-16 11:07 You needn't open the file as root, it's located in your home directory no need for any permissions.

Open terminal and type nano "path-to-file" without quotation marks

Code: Select all

nano ~/.config/autostart/tilda.desktop
Then add the new line and press (Ctrl+X) then (Y) to save changes then hit Enter

Is it working now?
That's the way it is, how do I open Pluma as a standard user?

jakoline1
Posts: 41
Joined: 2021-07-06 00:49
Been thanked: 1 time

Re: Delaying a startup app

#11 Post by jakoline1 »

I can't imagine a reason that makes Pluma launch as superuser by default, maybe you're logged in as root?
Perhaps someone else can help in this.

Lonewolf71
Posts: 50
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Delaying a startup app

#12 Post by Lonewolf71 »

jakoline1 wrote: 2021-07-16 16:50 I can't imagine a reason that makes Pluma launch as superuser by default, maybe you're logged in as root?
Perhaps someone else can help in this.
Let me ask this...If I am logged in as root/superuser all the time, wouldn't my terminal open as root automatically instead of my normal account?


https://sendvid.com/7ord35rb

jakoline1
Posts: 41
Joined: 2021-07-06 00:49
Been thanked: 1 time

Re: Delaying a startup app

#13 Post by jakoline1 »

I saw the video, it seems every graphical application is automatically launched in superuser mode, and it seems also you don't have the permissions required to read a file in home even when Pluma is superuser, Either you did something you can't remember, or the .iso file you used is corrupted hence making you face hard-to-diagnose issues.

If I were you, I would write down anything important on a piece of paper, names of user-installed apps, themes, icons, fonts, browser addons, passwords, and any user-made configuration that you need to remember, then re-install Debian using a healthy .iso file with an MD5SUM that matches, via a healthy installation medium.
But since Debian 11 release date is predicated to be within the next couple of months, I suggest you wait.

If you still wanna fight read this https://wiki.archlinux.org/title/Runnin ... ns_as_root
Search for "Permanently allow root access" or read the whole article, Arch Wiki in general is known to be comprehensive and always a good place to look for information.

Or create a new thread specifically for this issue and see if someone can help.

Lonewolf71
Posts: 50
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Delaying a startup app

#14 Post by Lonewolf71 »

jakoline1 wrote: 2021-07-17 12:14 I saw the video, it seems every graphical application is automatically launched in superuser mode, and it seems also you don't have the permissions required to read a file in home even when Pluma is superuser, Either you did something you can't remember, or the .iso file you used is corrupted hence making you face hard-to-diagnose issues.

If I were you, I would write down anything important on a piece of paper, names of user-installed apps, themes, icons, fonts, browser addons, passwords, and any user-made configuration that you need to remember, then re-install Debian using a healthy .iso file with an MD5SUM that matches, via a healthy installation medium.
But since Debian 11 release date is predicated to be within the next couple of months, I suggest you wait.

If you still wanna fight read this https://wiki.archlinux.org/title/Runnin ... ns_as_root
Search for "Permanently allow root access" or read the whole article, Arch Wiki in general is known to be comprehensive and always a good place to look for information.

Or create a new thread specifically for this issue and see if someone can help.
I checked my Linux Mint on my Laptop and it does the same thing! As you can see at the top it shows superuser.

Image

jakoline1
Posts: 41
Joined: 2021-07-06 00:49
Been thanked: 1 time

Re: Delaying a startup app

#15 Post by jakoline1 »

Then you should start a new thread and describe your problem there. Or ask at Debian mailing lists https://lists.debian.org/
In the meantime, if graphical applications are failing you, use the terminal. I still recommend you read that Arch Wiki article.

Lonewolf71
Posts: 50
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Delaying a startup app

#16 Post by Lonewolf71 »

jakoline1 wrote: 2021-07-18 15:36 Then you should start a new thread and describe your problem there. Or ask at Debian mailing lists https://lists.debian.org/
In the meantime, if graphical applications are failing you, use the terminal. I still recommend you read that Arch Wiki article.
I have a thread open on the Mint forums, since my Mint is showing the same thing.
re-install Debian using a healthy .iso file with an MD5SUM that matches, via a healthy installation medium.
Can you please send me a link to a debian iso with the new calamares installer? that page is so confusing :?

jakoline1
Posts: 41
Joined: 2021-07-06 00:49
Been thanked: 1 time

Re: Delaying a startup app

#17 Post by jakoline1 »

As you know there are many options to download Debian, right now Calamares is only available in Debian live (titled try Debian live before installing)

Here is the link for the fully-free .iso files
https://cdimage.debian.org/debian-cd/cu ... bt-hybrid/

And here is the link for the non-free firmware .iso files
https://cdimage.debian.org/images/unoff ... bt-hybrid/

Both links directs to Debian 10.10 amd64, pick your favourite desktop environment and make sure to verify MD5SUM before burning.
If your machine does not require non-free firmware to run then avoid the non-free version as it comes bundled with other annoying software and feels much less stable.

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3655
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 3 times
Been thanked: 4 times

Re: Delaying a startup app

#18 Post by sunrat »

jakoline1 wrote: 2021-07-18 16:43If your machine does not require non-free firmware to run then avoid the non-free version as it comes bundled with other annoying software and feels much less stable.
Considering the non-free installer only contains extra firmware which will just do nothing except use disk space if not used, I question whether it could actually make the system less stable.
I agree that if you don't need it, use the free installer. Personally I use the free version and just add the couple of firmware packages I need post-install. I don't use wi-fi for installation though which is the prime reason one may need the non-free installer.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

jakoline1
Posts: 41
Joined: 2021-07-06 00:49
Been thanked: 1 time

Re: Delaying a startup app

#19 Post by jakoline1 »

sunrat wrote: 2021-07-19 01:19 Considering the non-free installer only contains extra firmware which will just do nothing except use disk space if not used, I question whether it could actually make the system less stable.
Debian live = Bundled annoying software and much less stable
Debian non-free = Only less stable (as far as my experience goes)

That's what I got when I tested them out, especially Debian-live, I guess there is a reason why it's not the preferred installation method.

Lonewolf71
Posts: 50
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Delaying a startup app

#20 Post by Lonewolf71 »

I have seen videos where Debian has a store, but it was on Gnome, is that strictly for Gnome? I have yet to see a store for MATE :?
I normally install the Debian installer where it offers all the DE's.

Post Reply