how to upgrade mysql

If none of the more specific forums is the right place to ask
Post Reply
Message
Author
gangiyanrohit
Posts: 20
Joined: 2006-07-07 05:38

how to upgrade mysql

#1 Post by gangiyanrohit »

hi

i have debian3.1 , i want to update my sql
i use apt-get upgrade and update

in/etc/apt/sources.list add
deb http://www.backports.org/debian stable mysql-dfsg
as mainstion in debian

but my sql was not update
any other method to update mysql ?


then give me solution for that

debian:/usr/local/mysql# mysql start
ERROR 2002: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

but in /var/run NOT exist mysql folder.


thanks in advance
Rohit

ajdlinux
Posts: 2480
Joined: 2006-04-23 09:37
Location: Port Macquarie, NSW, Australia

#2 Post by ajdlinux »

The line should be:

deb http://www.backports.org/debian stable sarge-backports

gangiyanrohit
Posts: 20
Joined: 2006-07-07 05:38

#3 Post by gangiyanrohit »

ajdlinux wrote:The line should be:

deb http://www.backports.org/debian stable sarge-backports


hi
when we update apt-get ,it flash
an error

Failed to fetch http://www.backports.org/debian/dists/s ... ackages.gz 404 Not Found
Failed to fetch http://www.backports.org/debian/dists/s ... ackages.gz 404 Not Found


thanks in advance
Rohit

ajdlinux
Posts: 2480
Joined: 2006-04-23 09:37
Location: Port Macquarie, NSW, Australia

#4 Post by ajdlinux »

Sorry, got it the wrong way.

deb http://backports.org sarge-backports main

gangiyanrohit
Posts: 20
Joined: 2006-07-07 05:38

#5 Post by gangiyanrohit »

ajdlinux wrote:Sorry, got it the wrong way.

deb http://backports.org sarge-backports main

hi
i matry that but error are flash

Failed to fetch http://backports.org/dists/sarge-backpo ... ackages.gz 404 Not Found

thanks in advance
Rohit

ajdlinux
Posts: 2480
Joined: 2006-04-23 09:37
Location: Port Macquarie, NSW, Australia

#6 Post by ajdlinux »

Sorry! The line is still wrong, here's the official one off the website:

deb http://www.backports.org/debian/ sarge-backports main contrib non-free

gangiyanrohit
Posts: 20
Joined: 2006-07-07 05:38

#7 Post by gangiyanrohit »

ajdlinux wrote:Sorry! The line is still wrong, here's the official one off the website:

deb http://www.backports.org/debian/ sarge-backports main contrib non-free

hi
i do that but my sql was not update

it show
debian:/usr/src/gnudialer# mysql -V
mysql Ver 12.22 Distrib 4.0.24, for pc-linux-gnu (i386)


what method to update it (4.0 to 4.1.19) ,
ok
thanks in advance
rohit

ajdlinux
Posts: 2480
Joined: 2006-04-23 09:37
Location: Port Macquarie, NSW, Australia

#8 Post by ajdlinux »

You need to install mysql-client-5.0. 4.0 and 4.1 are no longer available, so you must use 5.0.

gangiyanrohit
Posts: 20
Joined: 2006-07-07 05:38

#9 Post by gangiyanrohit »

ajdlinux wrote:You need to install mysql-client-5.0. 4.0 and 4.1 are no longer available, so you must use 5.0.
hi
thanks for help

but how to find it ,please give me that link
which putin /etc/apt/source.list

thanks in advance
rohit

ajdlinux
Posts: 2480
Joined: 2006-04-23 09:37
Location: Port Macquarie, NSW, Australia

#10 Post by ajdlinux »

It's in backports.

gangiyanrohit
Posts: 20
Joined: 2006-07-07 05:38

#11 Post by gangiyanrohit »

ajdlinux wrote:It's in backports.
hi

but add link in my sourcelist file
deb http://www.backports.org/debian/ sarge-backports main contrib non-free

means it ,install it through apt-get command
but my problem was not solve
thanks iin advance
Rohit

gangiyanrohit
Posts: 20
Joined: 2006-07-07 05:38

#12 Post by gangiyanrohit »

gangiyanrohit wrote:
ajdlinux wrote:It's in backports.
hi

but add link in my sourcelist file
deb http://www.backports.org/debian/ sarge-backports main contrib non-free

means it ,install it through apt-get command
but my problem was not solve


but my problem was not solved I.e how to update my sql 4.0 to 4.1

give me command for that OR how to do that.

thanks in advance
Rohit

gangiyanrohit
Posts: 20
Joined: 2006-07-07 05:38

#13 Post by gangiyanrohit »

gangiyanrohit wrote:
gangiyanrohit wrote:
ajdlinux wrote:It's in backports.
hi

but add link in my sourcelist file
deb http://www.backports.org/debian/ sarge-backports main contrib non-free

means it ,install it through apt-get command
but my problem was not solve


but my problem was not solved I.e how to update my sql 4.0 to 4.1

give me command for that OR how to do that.



i install
apt-get install mysql-common mysql-client mysql-server
and check through

debian:/usr/src/gnudialer# mysql -V
mysql Ver 14.12 Distrib 5.0.22, for pc-linux-gnu (i386) using readline 5.0

its means mysql is update??? or not ??
if yes then how to start it???

thanks in advance
Rohit

gangiyanrohit
Posts: 20
Joined: 2006-07-07 05:38

#14 Post by gangiyanrohit »

hi

i update my sql
but it get an error

debian:~# ps aux | grep mysqld
root 4265 0.0 0.5 3676 1392 ? S 23:26 0:00 /bin/sh /usr/bin/ mysqld_safe
mysql 4326 0.0 6.7 118204 16736 ? S 23:26 0:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/ mysqld.pid --skip-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
root 4327 0.0 0.2 2648 548 ? S 23:26 0:00 logger -p daemon. err -t mysqld_safe -i -t mysqld
debian:~# mysql -u root -ppassw0rd
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

how to solve it

thanks in advance
Rohit

Lavene
Site admin
Site admin
Posts: 5095
Joined: 2006-01-04 04:26
Location: Oslo, Norway

#15 Post by Lavene »

For a more detailed instructions on how to use backports you can take a look at the howto at http://forums.debian.net/viewtopic.php?t=4525

As for mysql-client, version 4.1 is in teh standard sarge repos:
# apt-cache policy mysql-client-4.1
mysql-client-4.1:
Installed: (none)
Candidate: 4.1.11a-4sarge2
Versiontable:
4.1.11a-4sarge2 0
500 ftp://ftp.no.debian.org stable/main Packages
So just doing

Code: Select all

apt-get install mysql-client-4.1
should upgrade your 4.0 to 4.1 I think.

Tina

Post Reply