Thank button feature question

Code of conduct, suggestions, and information on forums.debian.net.
Post Reply
Message
Author
mm3100
Posts: 318
Joined: 2020-10-21 21:39
Has thanked: 6 times
Been thanked: 12 times

Thank button feature question

#1 Post by mm3100 »

Hello there,
Since thanks button has been added to thank user who posted a reply I noticed that on some posts such function was absent.

I have seen few other question why it seems to be missing, so I checked through various boards and found that thanks button feature, for me at least, is missing on these boards:
General Questions
Installation
Debian News, and Announcements
News & Announcements

All other boards have that option on every post in them that I checked.

I am using Firefox ESR on Debian stable, and am just wondering if it was made that way by design or something is wobbly on my end?

Edit: Just to add I am using AllanStyle-SUBSILVER board style, if that somehow can influence things.

User avatar
donald
Debian Developer, Site Admin
Debian Developer, Site Admin
Posts: 259
Joined: 2021-03-30 20:08
Has thanked: 45 times
Been thanked: 49 times

Re: Thank button feature question

#2 Post by donald »

Hi,

I changed to your style and loaded up Firefox ESR and can see the icons in those forums. Some of the posts in those forums show users being thanked. Do you have any extensions running? Perhaps clear your cache?

User avatar
wizard10000
Posts: 287
Joined: 2019-04-16 23:15
Location: southeastern us
Has thanked: 32 times
Been thanked: 15 times

Re: Thank button feature question

#3 Post by wizard10000 »

mm3100 wrote: 2021-11-24 18:36...is missing on these boards:
General Questions
Installation
Debian News, and Announcements
News & Announcements
I checked the first two with Edge (I'm on a Windows machine) and can confirm.

edit: Pretty sure it is the AllanStyle-SUBSILVER style - I switched to prosilver and those boards work as they should now.
we see things not as they are, but as we are.
-- anais nin

mm3100
Posts: 318
Joined: 2020-10-21 21:39
Has thanked: 6 times
Been thanked: 12 times

Re: Thank button feature question

#4 Post by mm3100 »

I have tried clearing cache, and in new profile. Of extensions I have privacy badger and no script, but both don't have any issues with debian forums, disabling both doesn't help either.

I didn't had luck seeing thanks button on both new clear profile and on new board style. I am really not sure as to why... I can see that use has been thanked but no thank button on its own.

User avatar
donald
Debian Developer, Site Admin
Debian Developer, Site Admin
Posts: 259
Joined: 2021-03-30 20:08
Has thanked: 45 times
Been thanked: 49 times

Re: Thank button feature question

#5 Post by donald »

mm3100 wrote: 2021-11-25 09:38 I have tried clearing cache, and in new profile. Of extensions I have privacy badger and no script, but both don't have any issues with debian forums, disabling both doesn't help either.

I didn't had luck seeing thanks button on both new clear profile and on new board style. I am really not sure as to why... I can see that use has been thanked but no thank button on its own.
I wish I could assist you more on this one, I've tried each of the user styles and across several Internet browsers (Firefox-ESR, Opera, and even Konqueror but I cannot duplicate this at all. :(

If you could try with a few different browsers and Konqueror I'd appreciate the feedback, if the issue remains I can reset the forums Cache Queue which will force a reload of all the icons, etc ... as I understand it. Minor drastic but not crazy. :) Let me know.

mm3100
Posts: 318
Joined: 2020-10-21 21:39
Has thanked: 6 times
Been thanked: 12 times

Re: Thank button feature question

#6 Post by mm3100 »

Thanks for trying, but I am starting to believe it is on my side, even though it doesn't make much sense.

I have tried with Konqueror and got same result. But there is another thing, new firefox profile and Konqueror both loaded with AllanStyle-SUBSILVER style. I am not sure what is default one for forum. If it isn't that then it should be something wrong on my side. Will try later this weekend on other device.

User avatar
wizard10000
Posts: 287
Joined: 2019-04-16 23:15
Location: southeastern us
Has thanked: 32 times
Been thanked: 15 times

Re: Thank button feature question

#7 Post by wizard10000 »

prosilver was working, now isn't. 1920x1080 screenshot - I'm still using Edge on Windows.

Image
we see things not as they are, but as we are.
-- anais nin

User avatar
ticojohn
Posts: 1220
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 17 times
Been thanked: 40 times

Re: Thank button feature question

#8 Post by ticojohn »

@donald , I have noticed over the last week or so that the thumbs up icon seems to come and go. I use only the Firefox-ESR browser and keep my cache cleaned on a regular basis, so I doubt that it is a local browser cache issue. But then again, I am but an egg.
I am not irrational, I'm just quantum probabilistic.

User avatar
donald
Debian Developer, Site Admin
Debian Developer, Site Admin
Posts: 259
Joined: 2021-03-30 20:08
Has thanked: 45 times
Been thanked: 49 times

Re: Thank button feature question

#9 Post by donald »

@ticojohn @mm3100 I purged the forum cache, hopefully that will force a reload on your ends. Please let me know if it works or not.

User avatar
ticojohn
Posts: 1220
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 17 times
Been thanked: 40 times

Re: Thank button feature question

#10 Post by ticojohn »

donald wrote: 2021-11-26 17:35 @ticojohn @mm3100 I purged the forum cache, hopefully that will force a reload on your ends. Please let me know if it works or not.
It is working for now. Thanks @donald
I am not irrational, I'm just quantum probabilistic.

User avatar
Linuxembourg
Posts: 25
Joined: 2021-11-24 00:41
Has thanked: 4 times
Been thanked: 3 times

Re: Thank button feature question

#11 Post by Linuxembourg »

The button disappears for me when I am the OP of a thread. I am using Chromium 98. I have exactly the same issue on Firefox ESR 78

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 4545
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 39 times
Been thanked: 114 times

Re: Thank button feature question

#12 Post by sunrat »

Linuxembourg wrote: 2021-11-28 15:19 The button disappears for me when I am the OP of a thread. I am using Chromium 98. I have exactly the same issue on Firefox ESR 78
You can't thank yourself! :lol:
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

User avatar
Linuxembourg
Posts: 25
Joined: 2021-11-24 00:41
Has thanked: 4 times
Been thanked: 3 times

Re: Thank button feature question

#13 Post by Linuxembourg »

sunrat wrote: 2021-11-28 21:47
Linuxembourg wrote: 2021-11-28 15:19 The button disappears for me when I am the OP of a thread. I am using Chromium 98. I have exactly the same issue on Firefox ESR 78
You can't thank yourself! :lol:
:lol: I know but I can't thank anyone who helped me with my question!

p.H
Posts: 2568
Joined: 2017-09-17 07:12
Has thanked: 3 times
Been thanked: 53 times

Re: Thank button feature question

#14 Post by p.H »

FWIW I have the same issue in the same boards as described in the OP.
up-to-date firefox-esr in stretch i386 and bullseye amd64.
prosilver style and french language but tried various other styles and languages with no change.

mhanor
Posts: 10
Joined: 2009-04-02 19:40

Re: Thank button feature question

#15 Post by mhanor »

Hi. I have this issue, the thanks button is missing in the thread below, so I can't give a thanks. The thanks button is present on this thread though.
Can someone take a look? Thank you. This doesn't seem connected to the browser I'm using, tried Firefox unstable (Debian) and Chromium.

viewtopic.php?p=756752

User avatar
ticojohn
Posts: 1220
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 17 times
Been thanked: 40 times

Re: Thank button feature question

#16 Post by ticojohn »

This issue seems to come and go. Strange.
I am not irrational, I'm just quantum probabilistic.

mhanor
Posts: 10
Joined: 2009-04-02 19:40

Re: Thank button feature question

#17 Post by mhanor »

There are no changes for me.

Post Reply