Forum time

Code of conduct, suggestions, and information on forums.debian.net.
Post Reply
Message
Author
User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3669
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 3 times
Been thanked: 4 times

Forum time

#1 Post by sunrat »

I am mystified how the forum timestamp works. I live in Melbourne which is currently UTC +11 including daylight saving, and forum preferences are set to that. I just made a post at 11:16 AM but the forum stamped it as 9:26. :?
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

User avatar
GarryRicketson
Posts: 5872
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Forum time

#2 Post by GarryRicketson »

I don't know, my clock says it is 7:57 pm, (19:57), I am posting to see what the forum clock says.
===== edit ====
It shows my post as being made at 20:09 ,
so it seems to just be a few minuets difference for me. In your "user control panel", >preferences, is the "daylight savings in summer" option, checked ?

Clocks are generally not very accurate, I have never seen 2 clocks that show the exact same time , all the time,...but almost 2 hours, I will agree that is a big difference,...

User avatar
GarryRicketson
Posts: 5872
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Forum time

#3 Post by GarryRicketson »

Test again, my pc shows 20:10 ,.... still about the same difference.

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3669
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 3 times
Been thanked: 4 times

Re: Forum time

#4 Post by sunrat »

Test again. DST was not checked so I changed it as we are on DST now. Other forums seem to detect that automatically.

Edit: posted at 1:29 local time, forum shows 12:40. 51 minutes earlier than actual time. Just weird.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

User avatar
Head_on_a_Stick
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Forum time

#5 Post by Head_on_a_Stick »

There has been a thread about this before, iirc.

Perhaps the server is in a high gravity field and is experiencing time dilation effects.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3669
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 3 times
Been thanked: 4 times

Re: Forum time

#6 Post by sunrat »

Thanks Head_on_a_Stick. That seems to be the most likely explanation. :wink:
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

User avatar
Head_on_a_Stick
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Forum time

#7 Post by Head_on_a_Stick »

^ Sorry sunrat, that was intended as a joke :D

Thanks for humouring me though, you are very kind.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

User avatar
debiman
Posts: 3064
Joined: 2013-03-12 07:18

Re: Forum time

#8 Post by debiman »

i have set my timezone correctly, and checked "DST is in effect" (although it isn't right now, not until next spring), and still the time is 11 minutes off.

i suspect that many forum members never manually adjust their timezone (and the forum software doesn't do it automatically), so post times are all over the place.

but all that should happen in whole hours, those 11 mins suggest that the server's hardware clock is off?

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3669
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 3 times
Been thanked: 4 times

Re: Forum time

#9 Post by sunrat »

Only 11 minutes? Gravity must be heavier in Australia than where you are.

Posted at 21:14 local time. Post shows 20:25. That's 49 minutes. Maybe I mathed wrong in the earlier post or maybe gravity is fluctuating.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

User avatar
yeti
Posts: 68
Joined: 2009-03-30 14:22

Re: Forum time

#10 Post by yeti »

sunrat wrote:Only 11 minutes? Gravity must be heavier in Australia than where you are.

Posted at 21:14 local time. Post shows 20:25. That's 49 minutes. Maybe I mathed wrong in the earlier post or maybe gravity is fluctuating.
...counting the days until we see a "show your local forum time" thread...
"I have a natural instinct for science" — DJ Trump.
"Vrijdag voor VT100!" — Yeti.
"There is no PLANET-B!" — ???

User avatar
debiman
Posts: 3064
Joined: 2013-03-12 07:18

Re: Forum time

#11 Post by debiman »

sunrat wrote:Only 11 minutes? Gravity must be heavier in Australia than where you are.

Posted at 21:14 local time. Post shows 20:25. That's 49 minutes. Maybe I mathed wrong in the earlier post or maybe gravity is fluctuating.
60 minutes - 11 minutes = 49 minutes.
so i'm guessing you're actually one hour off somewhere in your settings.

i hear there's been recent changes or at least efforts to abolish DST in many countries, and not all software might have caught up with it yet. could explain an otherwise unexplainable 1 hour difference.

User avatar
llivv
Posts: 5484
Joined: 2007-02-14 18:10
Location: cold storage

Re: Forum time

#12 Post by llivv »

I update ntp manually once a month or two or three and my drift is usually not more than a few tenths of a second, And I don't have ntpd installed. I noticed in sid that ntpdate is deprecated and so I had ntpsec installed
but nptdate didn't connect to any servers. I checked the /etc/defaults/ntpsec-ntpdate config file and changed a few of the servers to connect to 0.pool.npt.org and 3.pool.ntp.org just in case the config file was read form right to left. Still no server connection. So I purged ntpsec and installed the deprecated nptdate and updated ntpdate-debian and my drift was 4 tenths of a second off the computers clock.
I also dpkg-reconfigure tzdata and switched to UTC for this test.
I'm posting to this thread at 02:51.00 UTC
lets see what happens
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.

Post Reply