500 Internal Server Error trying to attach pictures to post

Code of conduct, suggestions, and information on forums.debian.net.
Post Reply
Message
Author
User avatar
EoflaOE
Posts: 4
Joined: 2020-06-05 16:01

500 Internal Server Error trying to attach pictures to post

#1 Post by EoflaOE »

For some reason, everytime I try to attach pictures to my post, instead of attaching it, I get an error that says:

Code: Select all

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, forum-admin@forums.debian.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apache Server at forums.debian.net Port 80
When I go back and try to save the draft, I see that exact same error message, so I have to go back, copy all the text that are in the post, go back to the forum, and try to post. The pictures are never attached however.

This is serious for me, as putting the Imgur URLs to any post that have pictures as attachments is an ugly workaround for me. Can this be fixed?
Old PC: Debian testing, Windows XP SP3
New PC: Windows 10 Pro 64-bit
Aspire 5315: Linux Mint, Windows XP SP3
Travelmate 5330: Debian Buster

cuckooflew
Posts: 680
Joined: 2018-05-10 19:34
Location: Some where out west

Re: 500 Internal Server Error trying to attach pictures to p

#2 Post by cuckooflew »

No, that will not be changed, there is not enough storage space on the forums server, you need to use a storage site, and post a link to the image, it really is not that complicated :EG:
Image
This is serious for me, as putting the Imgur URLs to any post that have pictures as attachments is an ugly workaround for me.
There are other storage sites besides Imgur if that is a problem for you and you find it ugly.
Please Read What we expect you have already Done
Search Engines know a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
and
Just say NO to help vampires!

User avatar
EoflaOE
Posts: 4
Joined: 2020-06-05 16:01

Re: 500 Internal Server Error trying to attach pictures to p

#3 Post by EoflaOE »

Thanks for the answer. From now on, I have to use the workaround until it is fixed.
Old PC: Debian testing, Windows XP SP3
New PC: Windows 10 Pro 64-bit
Aspire 5315: Linux Mint, Windows XP SP3
Travelmate 5330: Debian Buster

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3764
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 3 times
Been thanked: 12 times

Re: 500 Internal Server Error trying to attach pictures to p

#4 Post by sunrat »

EoflaOE wrote: From now on, I have to use the workaround until it is fixed.
It's a feature, not a bug. :wink:
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

User avatar
efdevse
Posts: 23
Joined: 2020-06-19 21:07

Re: 500 Internal Server Error trying to attach pictures to p

#5 Post by efdevse »

I've used https://postimages.org a few times. Seems better than imgur (imo). On the picture page, you get a few pre formatted link alternatives to use… like “Thumbnail for forums” (BBCode).

Would be great if the Upload attachment tab could be removed, since it doesn't work anyway.

Post Reply