firmware: failed to load iwl-debug-yoyo.bin (-2)

Share your own howto's etc. Not for support questions!
Post Reply
Message
Author
User avatar
ticojohn
Posts: 1087
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 5 times
Been thanked: 17 times

firmware: failed to load iwl-debug-yoyo.bin (-2)

#1 Post by ticojohn »

I don't know if others are seeing the message, but on my Intel NUC, running Bullseye amd64, I have been seeing these messages at startup for quite some time.

Code: Select all

firmware: failed to load iwl-debug-yoyo.bin (-2)
firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=966218
And it really bugged the heck out of me. So I did some research and found that this message is apparently a false message as that binary doesn't exist. Go figure. Anyway, in the Debian bug report
https://bugs.debian.org/cgi-bin/bugrepo ... bug=966218
a fix for disabling that message can be found. The fix is seen in the last entry of the bug report. It entails creating a file

Code: Select all

# nano /etc/modeprobe/d/iwlwifi.conf
and then entering the following content

Code: Select all

options iwlwifi enable_ini=N
After saving and exiting nano you will need to

Code: Select all

# update-initramfs -u
This should disable those messages from appearing during startup. Worked for me. Hope others can use this information.
I am not irrational, I'm just quantum probabilistic.

Post Reply