Lenovo Thinkpad T560 SIM card nor recognized

Here you can discuss every aspect of Debian. Note: not for support requests!
Post Reply
Message
Author
skorpinok7700
Posts: 1
Joined: 2019-02-17 15:23

Lenovo Thinkpad T560 SIM card nor recognized

#1 Post by skorpinok7700 »

I use a Lenovo T560 laptop with Debian 9 Desktop Operating System. This laptop has already an integrated SIM-Card slot and WWAN hardware is present. Unfortunately, my device (Debian 9 ) doesn't recognize my SIM-Card on network manager. kindly suggest how to fix this, below are the following output.

lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 005: ID 138a:0017 Validity Sensors, Inc. Fingerprint Reader Bus 001 Device 004: ID 5986:0706 Acer, Inc Bus 001 Device 003: ID 8087:0a2b Intel Corp. Bus 001 Device 002: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

usb-devices

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh=12 D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1 P: Vendor=1d6b ProdID=0002 Rev=04.18 S: Manufacturer=Linux 4.18.0-kali2-amd64 xhci-hcd S: Product=xHCI Host Controller S: SerialNumber=0000:00:14.0 C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=01 Lev=01 Prnt=01 Port=03 Cnt=01 Dev#= 2 Spd=12 MxCh= 0 D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1 P: Vendor=045e ProdID=0745 Rev=06.76 S: Manufacturer=Microsoft S: Product=Microsoft® 2.4GHz Transceiver v8.0 C: #Ifs= 3 Cfg#= 1 Atr=a0 MxPwr=100mA I: If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=01 Driver=usbhid I: If#= 1 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=02 Driver=usbhid I: If#= 2 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=00 Prot=00 Driver=usbhid

T: Bus=01 Lev=01 Prnt=01 Port=06 Cnt=02 Dev#= 3 Spd=12 MxCh= 0 D: Ver= 2.00 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs= 1 P: Vendor=8087 ProdID=0a2b Rev=00.01 C: #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA I: If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb I: If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb

T: Bus=01 Lev=01 Prnt=01 Port=07 Cnt=03 Dev#= 4 Spd=480 MxCh= 0 D: Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs= 1 P: Vendor=5986 ProdID=0706 Rev=00.12 S: Manufacturer=SunplusIT Inc S: Product=Integrated Camera C: #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA I: If#= 0 Alt= 0 #EPs= 1 Cls=0e(video) Sub=01 Prot=00 Driver=uvcvideo I: If#= 1 Alt= 0 #EPs= 0 Cls=0e(video) Sub=02 Prot=00 Driver=uvcvideo

T: Bus=01 Lev=01 Prnt=01 Port=08 Cnt=04 Dev#= 5 Spd=12 MxCh= 0 D: Ver= 1.10 Cls=ff(vend.) Sub=11 Prot=ff MxPS= 8 #Cfgs= 1 P: Vendor=138a ProdID=0017 Rev=00.78 S: SerialNumber=7a3f29ab69b1 C: #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA I: If#= 0 Alt= 0 #EPs= 4 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)

T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=5000 MxCh= 6 D: Ver= 3.00 Cls=09(hub ) Sub=00 Prot=03 MxPS= 9 #Cfgs= 1 P: Vendor=1d6b ProdID=0003 Rev=04.18 S: Manufacturer=Linux 4.18.0-kali2-amd64 xhci-hcd S: Product=xHCI Host Controller S: SerialNumber=0000:00:14.0 C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

systemctl status ModemManager

● ModemManager.service - Modem Manager Loaded: loaded (/lib/systemd/system/ModemManager.service; enabled; vendor preset: enabled) Active: active (running) since Sun 2019-02-17 09:37:50 EST; 23min ago Main PID: 518 (ModemManager) Tasks: 3 (limit: 4915) Memory: 8.6M CGroup: /system.slice/ModemManager.service └─518 /usr/sbin/ModemManager --filter-policy=strict

User avatar
Head_on_a_Stick
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Lenovo Thinkpad T560 SIM card nor recognized

#2 Post by Head_on_a_Stick »

If that machine was introduced after Debian stretch entered the freeze (early 2017) then you will probably need the kernel from the stretch-backports repository for full support, and perhaps backported packages for your graphics stack as well.

http://forums.debian.net/viewtopic.php?f=16&t=139003
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

Post Reply