openssh error!

Here you can discuss every aspect of Debian. Note: not for support requests!
Post Reply
Message
Author
korosh111
Posts: 20
Joined: 2011-11-07 09:49

openssh error!

#1 Post by korosh111 »

i install debian x86 in my nas (ts239 PROII) with qpkg from qnapclub.eu
i want to repair it becouse of this error:
i install open ssh after that when i want to install another packages say:

Code: Select all

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 openssh-server : Depends: openssh-client (= 1:7.4p1-10+deb9u7) but 1:6.7p1-5+deb8u8 is to be installed
 openssh-sftp-server : Depends: openssh-client (= 1:7.9p1-10) but 1:6.7p1-5+deb8u8 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
and when i do: "apt --fix-broken install" it goes 13% and give me Error:

Code: Select all

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  openssh-client openssh-server
Suggested packages:
  keychain libpam-ssh monkeysphere ssh-askpass molly-guard rssh ufw
The following packages will be upgraded:
  openssh-client openssh-server
2 upgraded, 0 newly installed, 0 to remove and 125 not upgraded.
15 not fully installed or removed.
Need to get 0 B/1,220 kB of archives.
After this operation, 79.9 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Preconfiguring packages ...
(Reading database ... 20913 files and directories currently installed.)
Preparing to unpack .../openssh-server_1%3a7.9p1-10_i386.deb ...
mv: cannot move '/etc/init/ssh.conf' to '/etc/init/ssh.conf.dpkg-remove': Bad address
dpkg: error processing archive /var/cache/apt/archives/openssh-server_1%3a7.9p1-10_i386.deb (--unpack):
 new openssh-server package pre-installation script subprocess returned error exit status 1
Preparing to unpack .../openssh-client_1%3a7.9p1-10_i386.deb ...
mv: cannot move '/etc/ssh/moduli' to '/etc/ssh/moduli.dpkg-remove': Bad address
dpkg: error processing archive /var/cache/apt/archives/openssh-client_1%3a7.9p1-10_i386.deb (--unpack):
 new openssh-client package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/openssh-server_1%3a7.9p1-10_i386.deb
 /var/cache/apt/archives/openssh-client_1%3a7.9p1-10_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

korosh111
Posts: 20
Joined: 2011-11-07 09:49

Re: openssh error!

#2 Post by korosh111 »

really no help!??!

Dai_trying
Posts: 960
Joined: 2016-01-07 12:25

Re: openssh error!

#3 Post by Dai_trying »

I see both Debian jessie and stretch packages mentioned in your output so my guess would be mixed repositories, you could post your sources.list (and/or contents of sources.list.d) to confirm or debunk my theory.

korosh111
Posts: 20
Joined: 2011-11-07 09:49

Re: openssh error!

#4 Post by korosh111 »

Dai_trying wrote:I see both Debian jessie and stretch packages mentioned in your output so my guess would be mixed repositories, you could post your sources.list (and/or contents of sources.list.d) to confirm or debunk my theory.
This is /apt/sources.list

Code: Select all

#------------------------------------------------------------------------------#
#                   OFFICIAL DEBIAN REPOS
#------------------------------------------------------------------------------#

###### Debian Main Repos
deb http://deb.debian.org/debian/ stable main contrib non-free
deb-src http://deb.debian.org/debian/ stable main contrib non-free

deb http://deb.debian.org/debian/ stable-updates main contrib non-free
deb-src http://deb.debian.org/debian/ stable-updates main contrib non-free

deb http://deb.debian.org/debian-security stable/updates main
deb-src http://deb.debian.org/debian-security stable/updates main

deb http://ftp.debian.org/debian stretch-backports main
deb-src http://ftp.debian.org/debian stretch-backports main


Dai_trying
Posts: 960
Joined: 2016-01-07 12:25

Re: openssh error!

#5 Post by Dai_trying »

That actually makes it worse as you are using Buster (current Stable) repositories as well...

I would recommend a fresh installation as it would be very time consuming and troublesome to attempt to repair this system (IMO) but maybe somebody else will have a better suggestion.

korosh111
Posts: 20
Joined: 2011-11-07 09:49

Re: openssh error!

#6 Post by korosh111 »

Dai_trying wrote:That actually makes it worse as you are using Buster (current Stable) repositories as well...

I would recommend a fresh installation as it would be very time consuming and troublesome to attempt to repair this system (IMO) but maybe somebody else will have a better suggestion.
exactly
it's corect and i repair it
Thanks

Post Reply