Problem on G`MIC integration for Gimp in Buster.

If it doesn't relate to Debian, but you still want to share it, please do it here
Post Reply
Message
Author
portaro
Posts: 3
Joined: 2013-05-01 11:14

Problem on G`MIC integration for Gimp in Buster.

#1 Post by portaro »

I install Gimp default version on Buster by a synaptic package manager installation, then I install G'MIC - an framework for digital image processing that can be integrated with Gimp.

https://gmic.eu/

But for some reason when I try to use it in Gimp the tool never opens.

I'm still use Bunsenlabs, my pc is very poor to Gnome or similar type of desktops.

I think that the problem can be the gtk of the GMIC but I haven't any assurance of this.

I already put a question on bunsenlabs and I aready find a "half solution" install Gimp by appimage (in the appimage GMIC works well).

https://forums.bunsenlabs.org/viewtopic.php?id=7430

When I click on the Gmic button if I open Gimp with terminal I have this output →

Code: Select all

(gmic_gimp:23160): GLib-GObject-WARNING **: 02:52:22.438: cannot register existing type 'GtkWidget'

(gmic_gimp:23160): GLib-GObject-CRITICAL **: 02:52:22.438: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gmic_gimp:23160): GLib-GObject-WARNING **: 02:52:22.438: cannot register existing type 'GtkBuildable'

(gmic_gimp:23160): GLib-GObject-CRITICAL **: 02:52:22.438: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(gmic_gimp:23160): GLib-CRITICAL **: 02:52:22.438: g_once_init_leave: assertion 'result != 0' failed

(gmic_gimp:23160): GLib-GObject-CRITICAL **: 02:52:22.438: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gmic_gimp:23160): GLib-GObject-CRITICAL **: 02:52:22.438: g_type_register_static: assertion 'parent_type > 0' failed

If I use appimage of Gimp GMIC works well.

So I think that the problem is in relation with the gimp package provided by the default repositories of Debian.

I try to find what is the process to send bugs and I find it here → https://www.debian.org/Bugs/Reporting

But then I think maybe is better put this on the forum and then any user admin can report this.

I put an screenshot at following →

Image

trinidad
Posts: 211
Joined: 2016-08-04 14:58
Been thanked: 4 times

Re: Problem on G`MIC integration for Gimp in Buster.

#2 Post by trinidad »

You can't believe your eyes if your imagination is out of focus.

arochester
Global Moderator
Global Moderator
Posts: 2062
Joined: 2010-12-07 19:55
Has thanked: 1 time
Been thanked: 3 times

Re: Problem on G`MIC integration for Gimp in Buster.

#3 Post by arochester »

I'm still use Bunsenlabs,
Bunsenlabs has its own forum at https://forums.bunsenlabs.org/

User avatar
stevepusser
Posts: 12430
Joined: 2009-10-06 05:53
Has thanked: 8 times
Been thanked: 6 times

Re: Problem on G`MIC integration for Gimp in Buster.

#4 Post by stevepusser »

Try starting it in the terminal with

Code: Select all

env QT_QPA_PLATFORMTHEME=gtk3 gimp-2.10 
MX Linux packager and developer

portaro
Posts: 3
Joined: 2013-05-01 11:14

Re: Problem on G`MIC integration for Gimp in Buster.

#5 Post by portaro »

stevepusser wrote:Try starting it in the terminal with

Code: Select all

env QT_QPA_PLATFORMTHEME=gtk3 gimp-2.10 
It works.

Is a option to force QT to use gtk3 ?

Thanks.

:D

User avatar
Head_on_a_Stick
Posts: 13446
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Problem on G`MIC integration for Gimp in Buster.

#6 Post by Head_on_a_Stick »

Environmental variables can be exported via /etc/environment (or in individual files under /etc/environment.d/) so just add this line to that file:

Code: Select all

QT_QPA_PLATFORMTHEME=gtk3
And tell the BunsenLabs folks I said "hello".
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

User avatar
stevepusser
Posts: 12430
Joined: 2009-10-06 05:53
Has thanked: 8 times
Been thanked: 6 times

Re: Problem on G`MIC integration for Gimp in Buster.

#7 Post by stevepusser »

Just in case someone also wants to run krita-gmic with Krita, the same env command works with Krita on XFCE.
MX Linux packager and developer

Post Reply