Updates

New to Debian (Or Linux in general)? Ask your questions here!
Post Reply
Message
Author
Lonewolf71
Posts: 61
Joined: 2021-06-30 21:38
Been thanked: 2 times

Updates

#1 Post by Lonewolf71 »

How often does Debian have updates? I'm so used to Mint having the update manager every so often having quite a few updates, this doesn't happen with Debian. I check on a regular basis but everything seems to be up to date. :?

Code: Select all

family@hp-lin:~$ sudo aptitude update && sudo aptitude upgrade
Hit http://deb.debian.org/debian buster InRelease
Hit http://deb.debian.org/debian buster-updates InRelease                                                                     
Hit http://security.debian.org/debian-security buster/updates InRelease
Hit https://linux.teamviewer.com/deb stable InRelease                                                                         
Hit https://repo.nextdns.io/deb stable InRelease
                                         
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

User avatar
4D696B65
Site admin
Site admin
Posts: 2688
Joined: 2009-06-28 06:09
Been thanked: 20 times

Re: Updates

#2 Post by 4D696B65 »

The mirror I use gets updated every 6 hours. Stable only gets security updates, no new versions of packages or new features.

Lonewolf71
Posts: 61
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Updates

#3 Post by Lonewolf71 »

4D696B65 wrote: 2021-07-25 06:20 The mirror I use gets updated every 6 hours. Stable only gets security updates, no new versions of packages or new features.
Is it in the background?

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3783
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 4 times
Been thanked: 15 times

Re: Updates

#4 Post by sunrat »

Probably you have unattended-upgrades package active. There was a security upgrade for systemd and the kernel on July 20. Check if you have the current version of systemd and you will know your upgrades are happening. It should be systemd 241-7~deb10u8 .

Code: Select all

apt list --installed systemd
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

Lonewolf71
Posts: 61
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Updates

#5 Post by Lonewolf71 »

sunrat wrote: 2021-07-25 07:40 Probably you have unattended-upgrades package active. There was a security upgrade for systemd and the kernel on July 20. Check if you have the current version of systemd and you will know your upgrades are happening. It should be systemd 241-7~deb10u8 .

Code: Select all

apt list --installed systemd

Code: Select all

family@hp-lin:~$ apt list --installed systemd
Listing... Done
systemd/stable,now 241-7~deb10u8 i386 [installed]
N: There is 1 additional version. Please use the '-a' switch to see it
family@hp-lin:~$ 

Code: Select all

yaws/stable,stable 2.0.6+dfsg-1+deb10u1 all

yaz-doc/stable 5.27.1-2 all

yaz-icu/stable 5.27.1-2 i386

yaz-illclient/stable 5.27.1-2 i386

yaz/stable 5.27.1-2 i386

yazc/stable 0.4.1-1 i386

yc-el/stable 5.0.0-8 i386

ycmd/stable 0+20181101+git600f54d-0.1+b2 i386

yeahconsole/stable 0.3.4-5 i386

yelp-tools/stable 3.31.90-1 all

yelp-xsl/stable,now 3.31.90-1 all [installed,automatic]

yelp/stable,now 3.31.90-1 i386 [installed,automatic]

yersinia/stable 0.8.2-2+b1 i386

yesod/stable 1.6.0.3-4 i386

yforth/stable 0.2.1-1 i386

yhsm-daemon/stable 1.2.1-1 all

yhsm-tools/stable 1.2.1-1 all

yhsm-validation-server/stable 1.2.1-1 all

yhsm-yubikey-ksm/stable 1.2.1-1 all

yi/stable 0.18.0-1 i386

yiyantang/stable 0.7.0-5+b1 i386

ykush-control/stable 1.1.0+ds-1 i386

yodl-doc/stable 4.02.00-3 all

yodl/stable 4.02.00-3 i386

yokadi/stable 1.1.1-2 all

yorick-av/stable 0.0.5-1+b1 i386

yorick-cubeview/stable 2.2-2 all

yorick-curses/stable 0.1-6+b2 i386

yorick-data/stable 2.2.04+dfsg1-10 all

yorick-dev/stable 2.2.04+dfsg1-10 i386

yorick-doc/stable 2.2.04+dfsg1-10 all

yorick-full/stable 2.2.04+dfsg1+full i386

yorick-gl/stable 1.1+cvs20070922+dfsg-6.1 i386

yorick-gy/stable 0.0.5-1 i386

yorick-gyoto/stable 1.3.1-1 i386

yorick-hdf5/stable 0.8.0-8+b1 i386

yorick-imutil/stable 0.5.7-3 i386

yorick-mira/stable 1.1.0+git20170124.3bd1c3~dfsg1-2 all

yorick-ml4/stable 0.6.0-3 i386

yorick-mpeg/stable 0.1-3 i386

yorick-mpy-common/stable 2.2.04+dfsg1-10 all

yorick-mpy-mpich2/stable 2.2.04+dfsg1-10 i386

yorick-mpy-openmpi/stable 2.2.04+dfsg1-10 i386

yorick-optimpack/stable 1.3.2+dfsg+1.4.0-1 i386

yorick-soy/stable 1.4.0-3 i386

yorick-spydr/stable 0.8.2-3 all

yorick-svipc/stable 0.16-3 i386

yorick-yao/stable 5.4.0-1 i386

yorick-yeti-fftw/stable 6.4.0-1 i386

yorick-yeti-regex/stable 6.4.0-1 i386

yorick-yeti-tiff/stable 6.4.0-1 i386

yorick-yeti/stable 6.4.0-1 i386

yorick-ygsl/stable 1.2.1-1+b1 i386

yorick-ynfft/stable 1.0.3-1 i386

yorick-yutils/stable 1.5.2-1 all

yorick-z/stable 1.2.0+cvs20080115-5+b2 i386

yorick/stable 2.2.04+dfsg1-10 i386

yoshimi-data/stable 1.5.10.1-1 all

yoshimi-doc/stable 1.5.10.1-1 all

yoshimi/stable 1.5.10.1-1 i386

yosys-dev/stable 0.8-1 i386

yosys-doc/stable 0.8-1 all

yosys/stable 0.8-1 i386

yotta-doc/stable 0.18.5-2 all

yotta/stable 0.18.5-2 all

youtube-dl/stable,now 2019.01.17-1.1 all [installed,automatic]

yowsup-cli/stable 2.5.7-4 all

yrmcds/stable 1.1.8-1.1 i386

ytalk/stable 3.3.0-9+b3 i386

ytnef-tools/stable 1.9.3-1 i386

ytree/stable 1.94-2+b1 i386

yubikey-luks/stable 0.5.1+29.g5df2b95-1 all

yubikey-manager/stable 2.1.0-1 all

yubikey-personalization-gui/stable 3.1.24-1 i386

yubikey-personalization/stable 1.19.3-3+deb10u1 i386

yubikey-server-c/stable 0.5-1.1 i386

yubikey-val/stable 2.38-2 all

yubiserver/stable 0.6-3.1 i386

yudit-common/stable 2.9.6-8 all

yudit-doc/stable 2.9.6-8 all

yudit/stable 2.9.6-8 i386

yui-compressor/stable 2.4.8-2 all

yum-utils/stable 1.1.31-4 all

yum/stable 3.4.3-3 all

yydebug/stable 1.1.0-11 all

z-push-backend-caldav/stable 2.4.5-2 all

z-push-backend-carddav/stable 2.4.5-2 all

z-push-backend-combined/stable 2.4.5-2 all

z-push-backend-galsearch-ldap/stable 2.4.5-2 all

z-push-backend-imap/stable 2.4.5-2 all

z-push-backend-kopano/stable 2.4.5-2 all

z-push-backend-ldap/stable 2.4.5-2 all

z-push-common/stable 2.4.5-2 all

z-push-ipc-memcached/stable 2.4.5-2 all

z-push-kopano-gab2contacts/stable 2.4.5-2 all

z-push-kopano-gabsync/stable 2.4.5-2 all

z-push-state-sql/stable 2.4.5-2 all

z-push/stable 2.4.5-2 all

z3/stable 4.4.1-1~deb10u1 i386

z80asm/stable 1.8-1+b2 i386

z80dasm/stable 1.1.5-1 i386

z8530-utils2/stable 3.0-1-9 i386

z88-data/stable 13.0.0+dfsg2-6 all

z88-doc/stable 13.0.0+dfsg2-6 all

z88/stable 13.0.0+dfsg2-6 i386

zabbix-agent/stable 1:4.0.4+dfsg-1 i386

zabbix-cli/stable 1.7.0-1 all

zabbix-frontend-php/stable 1:4.0.4+dfsg-1 all

zabbix-java-gateway/stable 1:4.0.4+dfsg-1 all

zabbix-proxy-mysql/stable 1:4.0.4+dfsg-1 i386

zabbix-proxy-pgsql/stable 1:4.0.4+dfsg-1 i386

zabbix-proxy-sqlite3/stable 1:4.0.4+dfsg-1 i386

zabbix-server-mysql/stable 1:4.0.4+dfsg-1 i386

zabbix-server-pgsql/stable 1:4.0.4+dfsg-1 i386

zalign/stable 0.9.1-4 i386

zam-plugins/stable 3.9~repack3-1 i386

zanshin/stable 0.5.0-2 i386

zapping/stable 0.10~cvs6-16 i386

zaqar-common/stable 7.0.0-1 all

zaqar-server/stable 7.0.0-1 all

zatacka/stable 0.1.8-5.2 i386

zathura-cb/stable 0.1.8-2 i386

zathura-dev/stable 0.4.3-1 i386

zathura-djvu/stable 0.2.8-1 i386

zathura-pdf-poppler/stable 0.2.9-1 i386

zathura-ps/stable 0.2.6-1 i386

zathura/stable 0.4.3-1 i386

zaz-data/stable 1.0.0~dfsg1-5 all

zaz/stable 1.0.0~dfsg1-5+b1 i386

zbackup/stable 1.4.4-3+b1 i386

zbar-tools/stable 0.22-1 i386

zdbsp/stable 1.19+20181027+dfsg.1-2 i386

zeal/stable 1:0.6.1-1 i386

zec/stable 0.12-5 all

zegrapher/stable 3.0.2-1 i386

zeitgeist-core/stable 1.0.1-1 i386

zeitgeist-datahub/stable 1.0.1-1 i386

zeitgeist-explorer/stable 0.2-1.2 all

zeitgeist/stable 1.0.1-1 all

zemberek-java-demo/stable 2.1.1-8.2 all

zemberek-server/stable 0.7.1-12.2 all

zenity-common/stable,now 3.30.0-2 all [installed,automatic]

zenity/stable,now 3.30.0-2 i386 [installed,automatic]

zenlisp/stable 2013.11.22-2+b1 i386

zenmap/stable 7.70+dfsg1-6+deb10u2 all

zephyr-clients/stable 3.1.2-1+b3 i386

zephyr-server-krb5/stable 3.1.2-1+b3 i386

zephyr-server/stable 3.1.2-1+b3 i386

zeroc-glacier2/stable 3.7.2-4 i386

zeroc-ice-all-dev/stable 3.7.2-4 all

zeroc-ice-all-runtime/stable 3.7.2-4 all

zeroc-ice-compilers/stable 3.7.2-4 i386

zeroc-ice-slice/stable 3.7.2-4 all

zeroc-ice-utils-java/stable 3.7.2-4 all

zeroc-ice-utils/stable 3.7.2-4 i386

zeroc-icebox/stable 3.7.2-4 i386

zeroc-icebridge/stable 3.7.2-4 i386

zeroc-icegrid/stable 3.7.2-4 i386

zeroc-icegridgui/stable 3.7.2-4 all

zeroc-icepatch2/stable 3.7.2-4 i386

zerofree/stable 1.1.1-1 i386

zfs-fuse/stable 0.7.0-19 i386

zfsnap/stable 1.11.1-5.1 all

zftp/stable 20061220+dfsg3-4.4 i386

zgen/stable 0~20150919-3 all

zh-autoconvert/stable 0.3.16-5 i386

zhcon-data/stable,now 1:0.2.6-16 all [installed,automatic]

zhcon/stable,now 1:0.2.6-16 i386 [installed,automatic]

zile/stable 2.4.14-7+b1 i386

zim/stable 0.68-1 all

zimpl/stable 3.3.6-1 i386

zimwriterfs/stable 1.2-1 i386

zinnia-utils/stable 0.06-4 i386

zip/stable,now 3.0-11+b1 i386 [installed,automatic]

zipalign/stable 1:8.1.0+r23-2 i386

zipcmp/stable 1.5.1-4 i386

zipmerge/stable 1.5.1-4 i386

zipper.app/stable 1.5-3 i386

ziproxy/stable 3.3.1-2.1 i386

ziptime/stable 1:8.1.0+r23-2 i386

ziptool/stable 1.5.1-4 i386

zita-ajbridge/stable 0.7.0-1 i386

zita-alsa-pcmi-utils/stable 0.2.0-4 i386

zita-at1/stable 0.6.0-1.1 i386

zita-bls1/stable 0.1.0-3.1 i386

zita-lrx/stable 0.1.0-3 i386

zita-mu1/stable 0.2.2-3 i386

zita-njbridge/stable 0.4.1-1 i386

zita-resampler/stable 1.6.0-2 i386

zita-rev1/stable 0.2.1-5.1 i386

zivot/stable 20013101-3.1+b3 i386

zlib1g-dbg/stable 1:1.2.11.dfsg-1 i386

zlib1g-dev/stable 1:1.2.11.dfsg-1 i386

zlib1g/stable,now 1:1.2.11.dfsg-1 i386 [installed]

zlibc/stable 0.9k-4.3 i386

zmakebas/stable 1.2-1.1+b2 i386

zmap/stable 2.1.1-2+b4 i386

zmf2epub/stable 0.9.6-2 i386

zmf2odg/stable 0.9.6-2 i386

znc-backlog/stable 0.20180824-1+b3 i386

znc-dev/stable 1.7.2-3 i386

znc-perl/stable 1.7.2-3 i386

znc-python/stable 1.7.2-3 i386

znc-tcl/stable 1.7.2-3 i386

znc/stable 1.7.2-3 i386

zoem/stable 11-166-1.2 i386

zomg/stable 0.8-3 i386

zonemaster-cli/stable 1.0.5-1 all

zookeeper-bin/stable 3.4.13-2 i386

zookeeper/stable 3.4.13-2 all

zookeeperd/stable 3.4.13-2 all

zoom-player/stable 1.1.5~dfsg-5 i386

zope-common/stable 0.5.54 all

zope-debhelper/stable 0.3.16 all

zopfli/stable 1.0.2-1 i386

zoph/stable 0.9.9-1 all

zpaq/stable 7.15-1 i386

zplug/stable 2.4.2-1 all

zpspell/stable 0.4.3-4.1+b2 i386

zram-tools/stable 0.3.2.1-1 all

zsh-antigen/stable 2.2.3-2 all

zsh-autosuggestions/stable 0.5.0-1 all

zsh-common/stable 5.7.1-1 all

zsh-dev/stable 5.7.1-1 i386

zsh-doc/stable 5.7.1-1 all

zsh-static/stable 5.7.1-1 i386

zsh-syntax-highlighting/stable 0.6.0-3 all

zsh-theme-powerlevel9k/stable 0.6.6-1 all

zsh/stable 5.7.1-1 i386

zsnes-dbg/stable 1.510+bz2-8+b3 i386

zsnes/stable 1.510+bz2-8+b3 i386

zssh/stable 1.5c.debian.1-7 i386

zstd/stable,stable 1.3.8+dfsg-3+deb10u2 i386

zsync/stable 0.6.2-3 i386

ztex-bmp/stable 20120314-2 i386

zulucrypt-cli/stable 5.4.0-3 i386

zulucrypt-gui/stable 5.4.0-3 i386

zulumount-cli/stable 5.4.0-3 i386

zulumount-gui/stable 5.4.0-3 i386

zulupolkit/stable 5.4.0-3 i386

zulusafe-cli/stable 5.4.0-3 i386

zurl/stable 1.10.0-1 i386

zutils/stable 1.8-3+b10 i386

zvbi/stable 0.2.35-16 i386

zvmcloudconnector-api/stable 1.2.3-1 all

zvmcloudconnector-common/stable 1.2.3-1 all

zynadd/stable 1+git.20100609+dfsg0-4 i386

zynaddsubfx-data/stable 3.0.3-1 all

zynaddsubfx-dssi/stable 3.0.3-1 i386

zynaddsubfx/stable 3.0.3-1 i386

zypper-common/stable 1.14.11-1 all

zypper-doc/stable 1.14.11-1 all

zypper/stable 1.14.11-1 i386

zziplib-bin/stable 0.13.62-3.2 i386

zzuf/stable 0.15-1+b1 i386

User avatar
donald
Debian Developer, Site Admin
Debian Developer, Site Admin
Posts: 166
Joined: 2021-03-30 20:08
Has thanked: 21 times
Been thanked: 28 times

Re: Updates

#6 Post by donald »

sunrat wrote: 2021-07-25 07:40 Probably you have unattended-upgrades package active. There was a security upgrade for systemd and the kernel on July 20. Check if you have the current version of systemd and you will know your upgrades are happening. It should be systemd 241-7~deb10u8 .

Code: Select all

apt list --installed systemd

Learned something new today, Thank You!

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3783
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 4 times
Been thanked: 15 times

Re: Updates

#7 Post by sunrat »

donald wrote: 2021-07-26 00:36
sunrat wrote: 2021-07-25 07:40 Probably you have unattended-upgrades package active. There was a security upgrade for systemd and the kernel on July 20. Check if you have the current version of systemd and you will know your upgrades are happening. It should be systemd 241-7~deb10u8 .

Code: Select all

apt list --installed systemd
Learned something new today, Thank You!

Code: Select all

apt list -i <package>
works the same but I posted the full option to make it easier to understand. If you omit the package name it will list all installed packages (use a pager though).

Code: Select all

apt list -i | more
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

Lonewolf71
Posts: 61
Joined: 2021-06-30 21:38
Been thanked: 2 times

Re: Updates

#8 Post by Lonewolf71 »

Thank you!

Post Reply