lost penguin user

New to Debian (Or Linux in general)? Ask your questions here!
Post Reply
Message
Author
styfir
Posts: 1
Joined: 2020-01-10 18:39

lost penguin user

#1 Post by styfir »

hi im a newbie to linux so please try and help me....
i recently bought a new chromebook and ive activated the linux on it. when i type ... cat /etc/*-release i get this info.....
PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
NAME="Debian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
VERSION_CODENAME=stretch
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"

im trying to use airmon-ng on the wifi device but its not listed and i cant find it anywhere on this chromebook

when i type sudo airmon-ng i get this...

sudo airmon-ng
ls: cannot access '/sys/class/ieee80211/': No such file or directory

PHY Interface Driver Chipset


when i type sudo ifconfig i get this ...

sudo ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 100.115.92.202 netmask 255.255.255.240 broadcast 100.115.92.207
inet6 fe80::216:3eff:fe69:4def prefixlen 64 scopeid 0x20<link>
ether 00:16:3e:69:4d:ef txqueuelen 1000 (Ethernet)
RX packets 1211 bytes 2261689 (2.1 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1158 bytes 124976 (122.0 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 2090 bytes 106018 (103.5 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 2090 bytes 106018 (103.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

as you can see there is no Wifi device listed (as far as i know)

I CAN connect to the internet wirelessly via my modem hence this post.

I want to check my network for holes and i need to activate and firstly find my wifi device - I know its in here somewhere - please help me....

User avatar
Danielsan
Posts: 637
Joined: 2010-10-10 22:36

Re: lost penguin user

#2 Post by Danielsan »

I don't have a CB but when you activate Linux on CB you are activating a container which should be isolated from the hardware. You should check here:

https://wiki.debian.org/InstallingDebia ... rch=Titles

And here:

https://wiki.archlinux.org/index.php/Ch ... s/Crostini

However it seems that exist issues exactly with the network:

https://wiki.archlinux.org/index.php/Ch ... _container

arochester
Global Moderator
Global Moderator
Posts: 2007
Joined: 2010-12-07 19:55
Has thanked: 1 time
Been thanked: 1 time

Re: lost penguin user

#3 Post by arochester »

1) Have you installed aircrack-ng?
Airmon-ng is included in the aircrack-ng package and is used to enable and disable monitor mode on wireless interfaces.
2) Do you have a separate USB Wireless dongle fitted? One wireless card will work your computer, the other wireless dongle will work aircrack/airmon.

3) What is the make and model of your chromebook?

Post Reply