How to install software from an old unsupported release?

New to Debian (Or Linux in general)? Ask your questions here!
Post Reply
Message
Author
ronaldobueno81
Posts: 1
Joined: 2020-07-30 12:00

How to install software from an old unsupported release?

#1 Post by ronaldobueno81 »

Hi Guys, I'm Ronaldo, Newbie from Debian, I am using Debian Wheezy, on my machine, I was wanting to install GNOME Web (Epiphany), And I hate Iceweasel, I tried it in the terminal, and this happened:

$ sudo apt-get install epiphany-browser
Reading package lists... Done
Building dependency tree
Reading state information... Done

And Failed to Fetch: 404 Not Found

cuckooflew
Posts: 681
Joined: 2018-05-10 19:34
Location: Some where out west

Re: How to install software from an old unsupported release?

#2 Post by cuckooflew »

Why is it necessary to be using a unsupported release ? Or is it just because you feel like it ?
And Failed to Fetch: 404 Not Found
Probably you do not have your /etc/apt/sources.list correct,...you need to find a debian archives mirror that has the packages, then use that in your sources.list file.
Unless this is really necessary, you will be better off forgetting about it. The debian archives are not hard to find, just do some searches, but keep in mind, both those browsers are not supported, and should not be used to go online.
======= edited =========
I did this for you, but if you are going to run a unsupported release, you should learn to do your own searches , you are going to need to solve various problems,...
https://wiki.debian.org/DebianWheezy#FAQ
Q) Now that wheezy is archived, how do I get packages for it?
Use the following in your sources.list:

Code: Select all

deb http://archive.debian.org/debian wheezy main 
Add contrib and non-free if needed.
The packages you want might not be available any more, if that is the case, you can still search and find down loads, you will need to compile them for your release though
Last edited by cuckooflew on 2020-07-30 18:48, edited 1 time in total.
Please Read What we expect you have already Done
Search Engines know a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
and
Just say NO to help vampires!

Bulkley
Posts: 6146
Joined: 2006-02-11 18:35

Re: How to install software from an old unsupported release?

#3 Post by Bulkley »

ronaldobueno81 wrote: And I hate Iceweasel
I did too until I found a userChrome.css that enabled me to customize the stuff that bugged me. You would have to do some searching because the one that you want might not be the one I like. It goes in ~/.mozilla/firefox/5h37af3b.default/chrome .

When I look for epiphany-browser I keep coming up with Rasberry Pi. Would that be useful? Probably not.

What's in your sources.list ?

Post Reply