[SOLVED] reboot hangs on fresh install of Bullseye

Kernels, Network, and Services configuration
Post Reply
Message
Author
User avatar
majpooper
Posts: 18
Joined: 2019-03-19 13:00

[SOLVED] reboot hangs on fresh install of Bullseye

#1 Post by majpooper »

Just installed Bullseye on a Lenovo IdeaPad 100. when I reboot it hangs to a blank screen. I have to poweroff - then power it back on.
I have set the BIOS to Legacy boot mode not UEFI. Tried a few other tings I have found - editing GRUB etc. - no joy.

Any ideas
Last edited by majpooper on 2021-08-02 21:25, edited 1 time in total.


User avatar
majpooper
Posts: 18
Joined: 2019-03-19 13:00

Re: reboot hangs on fresh install of Bullseye

#3 Post by majpooper »

THX - I have been to the first link already - the others are more about how to install Debian which is not the issue but I perused through them anyway. The installation went fine and everything seems to work fine when the system is powered up (cold boot). It is Restart (warm boot or reboot) that hangs. It looks like it is shutting down everything OK - get a lot of green OKs then some other output but it is so fast I can't tell what is really happening - And then the screen is kind of backlit and just stops . . . . nothing. I have to poweroff and then power up toget back in the system.

User avatar
majpooper
Posts: 18
Joined: 2019-03-19 13:00

Re: reboot hangs on fresh install of Bullseye

#4 Post by majpooper »

Here is the solution:
edit /etc/default/grub and add reboot=pci

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=pci"
don't forget

Code: Select all

sudo update-grub
Many thanks to rene over at the MINT forum for the solution even though this is not a Mint install but we are all in the Debian family.

Post Reply