Jessie regularly loses wifi connection[solved]

Kernels, Network, and Services configuration
Message
Author
sesselastronaut
Posts: 42
Joined: 2015-02-02 17:09

Re: Jessie regularly loses wifi connection

#31 Post by sesselastronaut »

thanks for the help! Seems like the command provide by head_on_a_stick does the trick:

Code: Select all

iw dev wlan0 set power_save off

at least I got a stable connection the last 2 days on both wireless networks I've been using.

I was wondering how to make this settings permanent?

User avatar
Head_on_a_Stick
Posts: 13760
Joined: 2014-06-01 17:46
Location: /dev/chair
Has thanked: 8 times
Been thanked: 47 times

Re: Jessie regularly loses wifi connection

#32 Post by Head_on_a_Stick »

sesselastronaut wrote:I was wondering how to make this settings permanent?
Does it not persist across reboots?

You could try v&n's suggestions given here:
http://forums.debian.net/viewtopic.php?p=573842#p573842

Or you could try my suggestion given here:
http://forums.debian.net/viewtopic.php?p=572680#p572680
"It seems that UNIX has become the victim of cancerous growth at the hands of organizations such as UCB. 4.2BSD is an order of magnitude larger than Version 5, but, Pike claims, not ten times better."

— Murray Hill, Bell Laboratories

sesselastronaut
Posts: 42
Joined: 2015-02-02 17:09

Re: Jessie regularly loses wifi connection

#33 Post by sesselastronaut »

thanks! Creating a /etc/modprobe.d/wireless_powersave.conf with

Code: Select all

options iwlwifi power_save=0
seem to have no effect - same drop-out behaviour.

I was trying v&n's suggestion however there's no "pm" directory in my /etc/, should I just create it?

v&n
Posts: 624
Joined: 2015-02-04 02:57

Re: Jessie regularly loses wifi connection

#34 Post by v&n »

The power_save parameter is already set to 'N' (or '0') as reported by the wireless-script earlier -
sesselastronaut wrote:module parameters ~~~~~~~~~~~~~~~~~~

....
iwlwifi (13): 11n_disable=8 | amsdu_size_8K=0 ....| power_save=N | swcrypto=0 | uapsd_disable=Y | wd_disable=1
..which is as expected because 'N' is the default value for that parameter as indicated by 'modinfo'. So I guess we must force it externally.
sesselastronaut wrote:I was trying v&n's suggestion however there's no "pm" directory in my /etc/, should I just create it?
Do you have 'pm-utils' package installed? Apparently not. Check with -

Code: Select all

dpkg -l | grep 'pm-utils'
If it does not return any line starting with "ii pm-utils....", then it is not installed. Regardless of whether it is installed or not, please try the 'power_scheme=1' parameter for 'iwlmvm' driver first (also suggested in my previous post).

Creating the directory/file without existence of 'pm-utils' will make no difference, because it is pm-utils that interprets and executes those scripts.

Another crude workaround, if the 'power_scheme=1' parameter doesn't help and you don't want to install pm-utils, is to simply add the command suggested by Head_on_a_Stick to you /etc/rc.local file -

Code: Select all

sudo sed -i '/^exit 0/ i iw dev wlan0 set power_save off' /etc/rc.local
The above command will insert the line "iw dev wlan0 set power_save off" just above the last line (which should ALWAYS be "exit 0") in the /etc/rc.local file. This will simply run the command at every boot automatically.

sesselastronaut
Posts: 42
Joined: 2015-02-02 17:09

Re: Jessie regularly loses wifi connection

#35 Post by sesselastronaut »

ok seems like

Code: Select all

sudo tee /etc/modprobe.d/iwlmvm.conf <<< "options iwlmvm power_scheme=1"
makes these settings permanent across reboots. Thanks once more!

v&n
Posts: 624
Joined: 2015-02-04 02:57

Re: Jessie regularly loses wifi connection

#36 Post by v&n »

sesselastronaut wrote:ok seems like

Code: Select all

sudo tee /etc/modprobe.d/iwlmvm.conf <<< "options iwlmvm power_scheme=1"
makes these settings permanent across reboots. Thanks once more!
Glad to hear that. Thank you for the confirmation, I'm sure it can help many more users.

Please consider taking time to edit your first post to add [Solved] prefix in the title. It will make the thread much more useful by indicating that this thread contains a potential solution to the problem mentioned in the title.

Post Reply