openconnect error

Kernels, Network, and Services configuration
Post Reply
Message
Author
User avatar
PsySc0rpi0n
Posts: 262
Joined: 2012-10-24 13:54
Location: Portugal

openconnect error

#1 Post by PsySc0rpi0n »

Hello.

Due to the new coVID-19 pandemic situation, I was sent home and will try to work from home.
To accomplish this I need to perform a connection to a VPN server.
At work, we all use Windows in our lpatops/desktops but I use Linux at home and I'm trying to establish this connection using 'openconnect' instead of this 'Pulse Secure' application we use at work.

When I try to connect to the VPN server URL, I get the following error:

Code: Select all

$ sudo openconnect --proto=nc https://vpn.url.here
[sudo] password for myuser:
GET https://vpn.url.here
Connected to aa.bb.cc.dd:xxx
SSL negotiation with https://vpn.url.here
Connected to HTTPS on https://vpn.url.here
Got HTTP response: HTTP/1.1 302 Found
GET https://vpn.url.here/dana-na/auth/url_1/welcome.cgi
SSL negotiation with vpn.url.here
Connected to HTTPS on vpn.url.here
frmLogin
username:XXXXXXXXX
password:
POST https://vpn.url.here/dana-na/auth/url_1/login.cgi
Failed to read from SSL socket: The TLS connection was non-properly terminated.
Error fetching HTTPS response
Failed to obtain WebVPN cookie
Anyone knows how to fix this?

reinob
Posts: 935
Joined: 2014-06-30 11:42

Re: openconnect error

#2 Post by reinob »

PsySc0rpi0n wrote: Anyone knows how to fix this?
I'm in a similar situation, with the advantage of having a preconfigured thin-client doing everything.
But I also tested the VPN connection with openconnect (for pulsesecure) and it did work fine.
In my case, the "password" is a code displayed by a hardware token. Do you have something similar?

It can be that if you enter the wrong (= not expected) password, the server terminates the connection abruptly, and that's why you get "The TLS connection was non-properly terminated."

Good luck!

Post Reply