when x does not boot

Kernels, Network, and Services configuration
Post Reply
Message
Author
milomak
Posts: 2085
Joined: 2009-06-09 22:20

when x does not boot

#1 Post by milomak »

are we in console (my vote) or terminal? i would not be asking this but there doesn't seem to be a consistent view on which is one is termed and so the google search becomes a wholly frustrating issue

the real problem is if x does not boot, what do i need to setup for console:
screen size
i have in /etc/default/grub

Code: Select all

GRUB_GFXMODE=1920x1080x32
GRUB_GFXPAYLOAD_LINUX=keep
if things go wrong i am on a 27" screen and if i see more than 10 words in a line i am lucky. what is wrong with what i have there?

scrolling
is this even possible. something says in a previous debian install many years ago i was able to do this. may have been just a good dream.
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid

sgosnell
Posts: 975
Joined: 2011-03-14 01:49

Re: when x does not boot

#2 Post by sgosnell »

You didn't give much information about what is actually happening. It seems you end up in a recovery console, or terminal, or whatever you want to call it. But that isn't enough information to start making informed guesses, just WAGs. If this is on very new hardware, it might need a newer kernel to get to a desktop. That usually is shown by a black screen with a blinking cursor at the top left. But I'm just taking random shots in the dark here, based on almost no information.
Take my advice, I'm not using it.

milomak
Posts: 2085
Joined: 2009-06-09 22:20

Re: when x does not boot

#3 Post by milomak »

i didn't describe that well

when x was not starting, i was dropping into console and that was running at something like 1024x768. i rectificied that with the below in /etc/default/grub

Code: Select all

GRUB_GFXMODE=1600x1200x24
GRUB_GFXPAYLOAD_LINUX=keep
however when i boot in recovery mode, the resolution goes back to 1024x768.

i have set /etc/default/console-setup as

Code: Select all

ACTIVE_CONSOLES="/dev/tty[1-6]"

CHARMAP="UTF-8"

CODESET="Uni1"
FONTFACE="VGA"
FONTSIZE="16x32"

VIDEOMODE="1600x1200x24"
but when i run setupcon i get

Code: Select all

Unknown video mode '1600x1200x24'
i know from running grml that console can run 133 columns and 480 rows as reported by stty size

i have even tried stty cols 133 rows 480 but that returns

Code: Select all

stty: standard input: Invalid argument
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid

User avatar
sickpig
Posts: 589
Joined: 2019-01-23 10:34

Re: when x does not boot

#4 Post by sickpig »

You can add vga=ask as a kernel parameter in your grub file. Then on the next boot select one of the supported resolutions.

milomak
Posts: 2085
Joined: 2009-06-09 22:20

Re: when x does not boot

#5 Post by milomak »

sickpig wrote:You can add vga=ask as a kernel parameter in your grub file. Then on the next boot select one of the supported resolutions.
where in /etc/default/grub?
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid

User avatar
sickpig
Posts: 589
Joined: 2019-01-23 10:34

Re: when x does not boot

#6 Post by sickpig »

in /etc/grub/default on the line which says 'GRUB_CMDLINE_LINUX_DEFAULT'
Initially on the grub menu you can press e and then add vga=ask then ctrl+x to boot to get a list of supported resolutions.
If you are happy you can make the changes permanent by editing /etc/grub/default.

Post Reply