[SOLVED] update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

Desktop Environments and Multimedia
Post Reply
Message
Author
User avatar
UX-Error
Posts: 3
Joined: 2021-07-17 13:27
Has thanked: 1 time

[SOLVED] update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

#1 Post by UX-Error »

After a "sudo apt upgrade" (Debian doesn't break so I don't keep logs, but I vaguely remember xserver was among the packages), 3 apps broke:
picom compositor,
anki flashcard learning program and
qutebrowser web browser.

picom had come from git and I have reinstalled it from git, but anki and qutebrowser had come from repo, so here I am to ask what should I do.
Below is the terminal output of launching anki and qutebrowser.

Running antiX 19 distro which is Debian 10 Buster without systemd

Thank you.

Code: Select all

> anki
qt: using qt5ct plugin                                     
qt: Unrecognized OpenGL version                            
qt: Unrecognized OpenGL version                            
qt: D-Bus global menu: no                                  
[13420:13467:0717/160131.622479:ERROR:gl_context_glx.cc(232)] Couldn't make context current with X drawable.                                                                        
[13420:13467:0717/160131.622780:ERROR:gpu_info_collector.cc(62)] gl::GLContext::MakeCurrent() failed                                                                                
[13420:13467:0717/160131.623256:ERROR:gpu_info_collector.cc(126)] Could not create context for info collection.                                                                     
qt: Unrecognized OpenGL version                            
qt: Unrecognized OpenGL version                            
qt: QQuickWidget: Failed to make context current           
qt: QQuickWidget::resizeEvent() no OpenGL context          
qt: QQuickWidget: Failed to make context current           
qt: Unrecognized OpenGL version                            
qt: Unrecognized OpenGL version                            
qt: QQuickWidget: Failed to make context current           
qt: QQuickWidget::resizeEvent() no OpenGL context          
qt: QQuickWidget: Failed to make context current           
qt: QQuickWidget: Attempted to render scene with no context
qt: QQuickWidget: Attempted to render scene with no context
qt: Unrecognized OpenGL version                            
qt: Unrecognized OpenGL version                            
qt: QQuickWidget: Failed to make context current           
qt: QQuickWidget::resizeEvent() no OpenGL context          
qt: QQuickWidget: Failed to make context current           
qt: Unrecognized OpenGL version                            
qt: Unrecognized OpenGL version                            
qt: Unrecognized OpenGL version                            
qt: Unrecognized OpenGL version                            
qt: composeAndFlush: makeCurrent() failed                  
qt: composeAndFlush: makeCurrent() failed                  
qt: QQuickWidget: Attempted to render scene with no context
qt: composeAndFlush: makeCurrent() failed                  
[13420:13467:0717/160133.073967:ERROR:gl_context_glx.cc(232)] Couldn't make context current with X drawable.                                                                        
[13420:13467:0717/160133.074071:ERROR:gles2_command_buffer_stub.cc(313)] ContextResult::kTransientFailure: Failed to make context current.                                          

Code: Select all

> qutebrowser
15:58:57 WARNING: Unrecognized OpenGL version
15:58:57 WARNING: Unrecognized OpenGL version
15:58:57 INFO: Run :adblock-update to get adblock lists.      
15:58:57 WARNING: Unrecognized OpenGL version
15:58:57 WARNING: Unrecognized OpenGL version
15:58:58 WARNING: Unrecognized OpenGL version
15:58:58 WARNING: Unrecognized OpenGL version
15:58:58 WARNING: QQuickWidget: Failed to make context current
15:58:58 WARNING: QQuickWidget::resizeEvent() no OpenGL context
15:58:58 WARNING: QQuickWidget: Failed to make context current
15:58:58 WARNING: Unrecognized OpenGL version
15:58:58 WARNING: Unrecognized OpenGL version
15:58:59 WARNING: QQuickWidget: Failed to make context current
15:58:59 WARNING: QQuickWidget::resizeEvent() no OpenGL context
15:58:59 WARNING: QQuickWidget: Failed to make context current
15:58:59 WARNING: Unrecognized OpenGL version
15:58:59 WARNING: Unrecognized OpenGL version
15:58:59 WARNING: QQuickWidget: Failed to make context current
15:58:59 WARNING: QQuickWidget::resizeEvent() no OpenGL context
15:58:59 WARNING: QQuickWidget: Failed to make context current
15:58:59 WARNING: Unrecognized OpenGL version
15:58:59 WARNING: Unrecognized OpenGL version
15:58:59 WARNING: QQuickWidget: Failed to make context current
15:58:59 WARNING: QQuickWidget::resizeEvent() no OpenGL context
15:58:59 WARNING: QQuickWidget: Failed to make context current
15:58:59 WARNING: Unrecognized OpenGL version
15:58:59 WARNING: Unrecognized OpenGL version
15:58:59 WARNING: QQuickWidget: Failed to make context current
15:58:59 WARNING: QQuickWidget::resizeEvent() no OpenGL context
15:58:59 WARNING: QQuickWidget: Failed to make context current
15:58:59 WARNING: Unrecognized OpenGL version
15:58:59 WARNING: Unrecognized OpenGL version
15:58:59 WARNING: QQuickWidget: Failed to make context current
15:58:59 WARNING: QQuickWidget::resizeEvent() no OpenGL context
15:58:59 WARNING: QQuickWidget: Failed to make context current
15:58:59 WARNING: Unrecognized OpenGL version
15:58:59 WARNING: Unrecognized OpenGL version
15:59:00 WARNING: QQuickWidget: Failed to make context current
15:59:00 WARNING: QQuickWidget::resizeEvent() no OpenGL context
15:59:00 WARNING: QQuickWidget: Failed to make context current
15:59:00 WARNING: Unrecognized OpenGL version
15:59:00 WARNING: Unrecognized OpenGL version
Last edited by UX-Error on 2021-09-11 13:35, edited 1 time in total.

arzgi
Posts: 856
Joined: 2008-02-21 17:03
Location: Finland
Been thanked: 6 times

Re: update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

#2 Post by arzgi »

UX-Error wrote: 2021-07-17 14:25 Running antiX 19 distro which is Debian 10 Buster without systemd
https://www.antixforum.com/

User avatar
stevepusser
Posts: 12430
Joined: 2009-10-06 05:53
Has thanked: 8 times
Been thanked: 6 times

Re: update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

#3 Post by stevepusser »

antiX and Debian can be very easy to break if you don't know what you're doing and add some incompatible repository. Just saying that it can't break bodes ill...do you know that apt maintains a log of all its actions, since you don't pay attention to what is being updated?

Try "cat /var/log/apt/history.log" in a terminal to view this log there.

antiX is also based on Debian, but has some major differences. It's closer than Ubuntu is, but certainly not the same thing.


antiX also ships with handy system information and troubleshooting tools; take advantage of them.
MX Linux packager and developer

User avatar
UX-Error
Posts: 3
Joined: 2021-07-17 13:27
Has thanked: 1 time

Re: update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

#4 Post by UX-Error »

Over time, additional error was found:

Code: Select all

> glxgears
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  155 (NV-GLX)
  Minor opcode of failed request:  4 ()
  Resource id in failed request:  0xd40002
  Serial number of failed request:  38
  Current serial number in output stream:  38
Which led me to How to fix "X Error of failed request: BadWindow (invalid Window parameter)" ?
I find that after every kernel upgrade I need to shut down X and re-run
the nvidia setup script
CC=/usr/bin/gcc-4.3 ./nvidia-installer.sh
or something like that.
Reinstallation of nvidia driver has resolved the issue.
Debian, you could put a message to the user that additional manual steps may be needed for the upgraded packages to work correctly, couldn't you?

User avatar
4D696B65
Site admin
Site admin
Posts: 2690
Joined: 2009-06-28 06:09
Been thanked: 21 times

Re: update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

#5 Post by 4D696B65 »

UX-Error wrote: 2021-09-11 13:33 Which led me to How to fix "X Error of failed request: BadWindow (invalid Window parameter)" ?
I find that after every kernel upgrade I need to shut down X and re-run
the nvidia setup script
CC=/usr/bin/gcc-4.3 ./nvidia-installer.sh
or something like that.
Reinstallation of nvidia driver has resolved the issue.
Debian, you could put a message to the user that additional manual steps may be needed for the upgraded packages to work correctly, couldn't you?
If you had installed nvidia driver the debian way you wouldn't have that problem. Don't blame debian for your mistakes.

User avatar
ticojohn
Posts: 1088
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 5 times
Been thanked: 17 times

Re: update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

#6 Post by ticojohn »

4D696B65 wrote: 2021-09-11 19:29 If you had installed nvidia driver the debian way you wouldn't have that problem. Don't blame debian for your mistakes.
Well said @4D696B65. I've been seeing a lot of posts recently where people were doing things that were contrary to the Debian guidelines, and then complaining about Debian. Debian is a GREAT OS. And if one follows the guidelines there are rarely any problems. That's why I use Debian. It might not be cutting edge; it just works. If I wore a hat, I would take it off to salute the whole Debian team, including those here at the forum. :D
I am not irrational, I'm just quantum probabilistic.

User avatar
stevepusser
Posts: 12430
Joined: 2009-10-06 05:53
Has thanked: 8 times
Been thanked: 6 times

Re: [SOLVED] update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

#7 Post by stevepusser »

CC=/usr/bin/gcc-4.3 ./nvidia-installer.sh
or something like that.
gcc-4.3? <Face palm>
MX Linux packager and developer

User avatar
cds60601
Global Moderator
Global Moderator
Posts: 269
Joined: 2017-11-25 05:58
Location: Tampa, Florida
Has thanked: 24 times
Been thanked: 3 times

Re: [SOLVED] update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

#8 Post by cds60601 »

stevepusser wrote: 2021-09-12 00:29
CC=/usr/bin/gcc-4.3 ./nvidia-installer.sh
or something like that.
gcc-4.3? <Face palm>
10 something, right?
Server: Debian Stable, Workstation: Debian Sid (dwm)
Laptop: Debian Sid (dwm), Pi-4: Stable (dwm)
----------------------------------------------------------------------------------
Don't Break Debian: https://wiki.debian.org/DontBreakDebian

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3794
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 5 times
Been thanked: 16 times

Re: [SOLVED] update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

#9 Post by sunrat »

cds60601 wrote: 2021-09-12 00:34
stevepusser wrote: 2021-09-12 00:29
CC=/usr/bin/gcc-4.3 ./nvidia-installer.sh
or something like that.
gcc-4.3? <Face palm>
10 something, right?
Right, current in stable:-

Code: Select all

$ gcc --version
gcc (Debian 10.2.1-6) 10.2.1 20210110
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

User avatar
UX-Error
Posts: 3
Joined: 2021-07-17 13:27
Has thanked: 1 time

Re: [SOLVED] update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

#10 Post by UX-Error »

4D696B65 wrote: 2021-09-11 19:29
UX-Error wrote: 2021-09-11 13:33 Which led me to How to fix "X Error of failed request: BadWindow (invalid Window parameter)" ?
I find that after every kernel upgrade I need to shut down X and re-run
the nvidia setup script
CC=/usr/bin/gcc-4.3 ./nvidia-installer.sh
or something like that.
Reinstallation of nvidia driver has resolved the issue.
Debian, you could put a message to the user that additional manual steps may be needed for the upgraded packages to work correctly, couldn't you?
If you had installed nvidia driver the debian way you wouldn't have that problem. Don't blame debian for your mistakes.
@4D696B65
Please shed light on what are my mistakes.
If you speak about

Code: Select all

CC=/usr/bin/gcc-4.3 ./nvidia-installer.sh
then this is an example from the answer, and not how I installed.
The driver had been and has been installed the antiX way via smxi.
I can't directly ask on https://www.antixforum.com/ since I am banned there over political quarrel, and I strongly disagree that I was ill-behaving. I tried settle the issue and got banned again. I tried asking tech-only and got banned once again.
What had I done wrong and what should I have done with my graphics issue? I sincerely want to know.
stevepusser wrote: 2021-09-12 00:29
CC=/usr/bin/gcc-4.3 ./nvidia-installer.sh
or something like that.
gcc-4.3? <Face palm>
Please notice that that page is from 2012. BTW, it shows that the issue lingers for years without fixing. This way, with all the other lingering issues, the Year of the Linux Desktop will hardly ever come true.
<Face palm>


Since some in this thread went trolling, let me join in the fun.
Please notice that not a single cool hacker guru here at the forum provided the proper or close-to-proper answer for a not-that-hard question in almost 2 months. Even those who heed Debian guidelines and RTFM with diligence.
And after my sharing the answer, some participants (and one of them at very high position at this forum) make me feel guilty for what I can't be guilty.
Oops, again do I defy Debian Community Guidelines: Dealing with trolls
:twisted:
We humans like to throw $#!t at each other, don't we?

User avatar
4D696B65
Site admin
Site admin
Posts: 2690
Joined: 2009-06-28 06:09
Been thanked: 21 times

Re: [SOLVED] update&upgrade → anki and qutebrowser: "Unrecognized OpenGL version"

#11 Post by 4D696B65 »

UX-Error wrote: 2021-09-14 21:49 @4D696B65
Please shed light on what are my mistakes.
Sure :) Do it the Debian way
https://wiki.debian.org/NvidiaGraphicsD ... ullseye.22

Post Reply