Hah! Who needs PPAs? I have my own multimedia+ repo!

Desktop Environments and Multimedia
Post Reply
Message
Author
User avatar
stevepusser
Posts: 12397
Joined: 2009-10-06 05:53
Has thanked: 6 times
Been thanked: 4 times

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

#341 Post by stevepusser »

SMPlayer updated to 21.1.0 for Debian 9 through Sid. Debian doesn't seem to have a maintainer for this package since 18.3. :(
MX Linux packager and developer

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3650
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 3 times
Been thanked: 3 times

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

#342 Post by sunrat »

I noticed Bullseye version of Audacity has leapfrogged yours:

Code: Select all

apt policy audacity
...
  Version table:
 *** 2.4.2~dfsg0-4 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
     2.4.2~dfsg0-3~obs 500
        500 http://download.opensuse.org/repositories/home:/stevepassert/Debian_Testing  Packages
Is there any chance you can package the latest v3.02 from Audacity site? It's not in Sid yet. :?: :wink:
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

User avatar
stevepusser
Posts: 12397
Joined: 2009-10-06 05:53
Has thanked: 6 times
Been thanked: 4 times

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

#343 Post by stevepusser »

I think 3.0.2's in a PPA someplace that I can copy the source file from...no--if it was ever there, it's gone. The Audacity site says it needs to build against wxwidgets >= 3.1.3, and Sid has only 3.0.5, to make it worse.
MX Linux packager and developer

User avatar
sunrat
Global Moderator
Global Moderator
Posts: 3650
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 3 times
Been thanked: 3 times

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

#344 Post by sunrat »

stevepusser wrote:I think 3.0.2's in a PPA someplace that I can copy the source file from...no--if it was ever there, it's gone. The Audacity site says it needs to build against wxwidgets >= 3.1.3, and Sid has only 3.0.5, to make it worse.
Yeah I looked at compiling it myself but abandoned the idea when I saw I had to compile WxWidgets first. No great loss, current version does what I occasionally use it for. Can wait for v3 till it's ready.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

Post Reply