cannot kill pulseaudio

Desktop Environments and Multimedia
Message
Author
morgon
Posts: 189
Joined: 2010-08-28 03:04

cannot kill pulseaudio

#1 Post by morgon »

Hi,

after hating it for a long time I have finally made my peace with pulseaudio.

Or so I had thought.

Now I have again a problem I don't understand:

On my laptop (running testing) pulseaudio is run under my user-account. I don't really know how exactly it get's started (afaik every client that needs pulseaudio will start it if it is not running), but it runs as a child process of the systemd-process (I assume it got re-parented) but trying to stop via systemd does not work. systemd does not seem to know anything about it.

So question 1: How can I find out how it actually get's started.

But my actual problem is that I cannot stop it. Either killing the process or running "pulseaudio -k" will simply result in a new process appearing.

And that is despite I have "autospawn = no" in both /etc/pulse/client.conf and ~/.config/pulse/client.conf

What is going on here? Question 2: How can I stop it?

Many thanks!

User avatar
bw123
Posts: 3798
Joined: 2011-05-09 06:02
Been thanked: 1 time

Re: cannot kill pulseaudio

#2 Post by bw123 »

There's a long thread about this, when you search the forum and find it, will you add the link to this post?
thanks.

some of these are good too
https://duckduckgo.com/html/?q=debian+kill+pulseaudio

morgon
Posts: 189
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

#3 Post by morgon »

The standard solution to this problem (which you find either here or with a search engine) is adding "autospawn = no" to the configuration.

This does (for whatever reason) not work on my system.

And please note that I am asking two questions, so as for
bw123 wrote:There's a long thread about this, when you search the forum and find it, will you add the link to this post?
my answer is: I won't link it - because it would not add any value.

User avatar
GarryRicketson
Posts: 5871
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: cannot kill pulseaudio

#4 Post by GarryRicketson »

How do you know that , if you have not looked for it ? I think it answers your questions, maybe when I have more time I will look for it for you, I vaguely remember when this same question and discussion was going on, and am pretty sure they got it solved, if you don't mind waiting I will do the searches for you and post a link to it here.
==========edited ========
Ha,ha, this is funny, it, but it was a year ago, and there are others, but the funny thing, in this thread, it is the same OP as now, and a solution was posted, but the OP never responded, don't know if they ever tried what was suggested, it might be worth a try,
http://forums.debian.net/viewtopic.php? ... 59#p655588
and scroll down, to the last post on that page, :
http://forums.debian.net/viewtopic.php? ... 59#p655767
by sunrat » 2017-10-06 01:19
Oops, helps to actually uncomment the above-mentioned parameter in daemon.conf:

Code: Select all
cat /proc/asound/card*/pcm*p/sub*/hw_params
access: MMAP_INTERLEAVED
format: S32_LE
subformat: STD
channels: 10
rate: 96000 (96000/1)


Success!

OP, I'm interested in tracking down how pulse starts too, so will do more research later.
And on the next page he gives the answers about how it starts,...

User avatar
bw123
Posts: 3798
Joined: 2011-05-09 06:02
Been thanked: 1 time

Re: cannot kill pulseaudio

#5 Post by bw123 »

The standard solution to this problem (which you find either here or with a search engine) is adding "autospawn = no" to the configuration...
No, that's not a standard solution, it is not enough. The daemon can start all kinds of ways. You would kniow that if you searched.

The easiest way I found is just remove it, do you need a soundserver on your setup?

User avatar
GarryRicketson
Posts: 5871
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: cannot kill pulseaudio

#6 Post by GarryRicketson »

The easiest way I found is just remove it,
+100, but if the OP needs it, not a option, but there are other solutions and it did not take long to find some ,...


And if that is not enough, there are plenty of good results:
how to kill pulseaudio on Debian
First hit :
https://wiki.debian.org/PulseAudio
Solving Problems

Restarting the Pulseaudio Daemon

To reread the config files ~/.config/pulse/daemon.conf and /etc/pulse/daemon.conf, do this:

Code: Select all

$ pulseaudio --kill
$ pulseaudio --start 
And if that does not work there are still more methods, the OP just needs to keep trying until they find the one that works for them.

morgon
Posts: 189
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

#7 Post by morgon »

bw123 wrote: No, that's not a standard solution, it is not enough. The daemon can start all kinds of ways. You would kniow that if you searched.
Believe me, it is the standard solution for quite common problem/feature when people find that killing one pulseaudio process it just starts a new one.
I am not talking about how it get's started here.
And this ususally works well, e.g on my PC with an (almost) identical setup.
bw123 wrote: The easiest way I found is just remove it, do you need a soundserver on your setup?
I don't want to remove it. I use it. A lot actually. It's quite powerful software actually.
It's just that sometimes I want to use jack and for that I want to shut pulseaudio down occasionally.

So (as we seem to loose focus here) my questions remain:

How can I find out how pulseaudio get's started on my system?
How can I shut it down if "autospawn = no" does not do the trick?

peter_irich
Posts: 1345
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation

Re: cannot kill pulseaudio

#8 Post by peter_irich »

Pulseaudio can be in autostart in users settings.

Peter.

User avatar
bw123
Posts: 3798
Joined: 2011-05-09 06:02
Been thanked: 1 time

Re: cannot kill pulseaudio

#9 Post by bw123 »

You say it's a standard solution, but then say it;'s not working, and then refuse to try any searches like this?

It's the 5th hit on my search link, did you read it?
http://www.linuxplanet.com/linuxplanet/ ... ls/7130/2/

Garry finds another thread from a yr ago you asking the same question... Did you even read it?
My question now becomes, are you on some serious medication that you forgot to take, or just naturally an idiot?

morgon
Posts: 189
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

#10 Post by morgon »

I did read it, it does exactly what I tried (I tried with and wiithout the demon-binary setting) and it does not work here (it should though).

This is just the "standard" thing to try.

If that is all you have to offer (and it seems you don't know anything about the problem at hand from your own experience) then why don't you look for a nicer playgound?

User avatar
bw123
Posts: 3798
Joined: 2011-05-09 06:02
Been thanked: 1 time

Re: cannot kill pulseaudio

#11 Post by bw123 »

morgon wrote:I did read it, it does exactly what I tried (I tried with and wiithout the demon-binary setting) and it does not work here (it should though).

This is just the "standard" thing to try.

If that is all you have to offer (and it seems you don't know anything about the problem at hand from your own experience) then why don't you look for a nicer playgound?
Because this is my playground. Maybe you go somewhere else unless you want me to taunt you relentlessly like this.

?

morgon
Posts: 189
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

#12 Post by morgon »

peter_irich wrote:Pulseaudio can be in autostart in users settings.
I have no autostart. I am using i3 and I don't start it from my own config-files.

It does not get started from systemd either.

morgon
Posts: 189
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

#13 Post by morgon »

bw123 wrote: Because this is my playground.
Do what you want.
It seems you have too much time on your hands, but unfortunately (for me) your contributions are not that helpful.

User avatar
bw123
Posts: 3798
Joined: 2011-05-09 06:02
Been thanked: 1 time

Re: cannot kill pulseaudio

#14 Post by bw123 »

morgon wrote:
bw123 wrote: Because this is my playground.
Do what you want.
It seems you have too much time on your hands, but unfortunately (for me) your contributions are not that helpful.
Your contributions are very helpful, even after a year where a solution is offered and you totally ignore it. The idea on a forum is, it's not about you baby, it's about future readers who will find your thread. I want them to understand why your posts are silly. I want them to find solutions where you pretend to find none.

User avatar
Head_on_a_Stick
Posts: 13446
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: cannot kill pulseaudio

#15 Post by Head_on_a_Stick »

bw123 wrote:just naturally an idiot
^ This.

I didn't know crap about acpi when I saw our OP's other thread but I managed to find the answer in a few minutes, it was very easy. Too difficult for poor old morgon though, they had to go crawling for help here :lol:
halfwit wrote:sometimes I want to use jack and for that I want to shut pulseaudio down occasionally
You do know you can run PA through JACK, right?

https://wiki.archlinux.org/index.php/Pu ... rough_JACK

There is no need to kill PA at all.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

User avatar
bw123
Posts: 3798
Joined: 2011-05-09 06:02
Been thanked: 1 time

Re: cannot kill pulseaudio

#16 Post by bw123 »

morgon wrote:
bw123 wrote: Because this is my playground.
Do what you want.
It seems you have too much time on your hands, but unfortunately (for me) your contributions are not that helpful.
p.s. That's not what you momma said last night...

User avatar
GarryRicketson
Posts: 5871
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: cannot kill pulseaudio

#17 Post by GarryRicketson »

Rather then bickering and arguing,
I don't want to remove it. I use it. A lot actually. It's quite powerful software actually.
It's just that sometimes I want to use jack and for that I want to shut pulseaudio down occasionally.
Did you try ?:

Code: Select all

$ pulseaudio --kill
#added comment, when you are ready, and want to use it simply
$ pulseaudio --start  
Then there is some contradictions, first you say:
I am not talking about how it get's started here.
But then at the bottom you do ask :
How can I find out how pulseaudio get's started on my system?
Is answered in the topic you started a year ago:
http://forums.debian.net/viewtopic.php? ... 15#p655774

Re: how to shutdown pulseaudio

Postby sunrat » 2017-10-06 04:55
It appears Pulseaudio is started at boot simply by a file pulseaudio.desktop in /etc/xdg/autostart/
From the link H_O_A_S gave:
From: https://wiki.archlinux.org/index.php/Pu ... rough_JACK
as well as a shutdown script to kill PulseAudio and the Pulse Audio Device Chooser, as another example called jack_shutdown also in the home directory:

Code: Select all

#!/bin/bash	
#Kill PulseAudio and PulseAudio Device Chooser		
pulseaudio --kill	
killall padevchooser	 
Postby morgon » 2019-02-20 15:23
I did read it, it does exactly what I tried (I tried with and wiithout the demon-binary setting) and it does not work here (it should though).

This is just the "standard" thing to try.
Several times I have seen the comment about ""standard" thing to try", and that very well may be, on standard systems, however there seem to be various good solutions, yet none seem to work on your system, since your system does not seem to be standard, maybe you should give some good details that can show us what is so different about your system, that seems to me like the key to finding out why none of the standard solutions are working,..
Postby morgon » 2019-02-20 11:41
The standard solution to this problem (which you find either here or with a search engine) is adding "autospawn = no" to the configuration.

This does (for whatever reason) not work on my system.
We know it is Debian testing, but

And that is despite I have "autospawn = no" in both /etc/pulse/client.conf and ~/.config/pulse/client.conf
For example, maybe show us the .conf files so we can see what exactly you have in them, there may be some usefull info with :

Code: Select all

 ps aux | grep pulse 
Show us , and I mean SHOW the exact out put, not just "it does not give any usefull info" or something like that. Show what the output of the command is . please, thankyou and no need to apologize for being a difficult person, I understand, often I am a extremely difficult person, even though I don't try to be, ... It seems to me though, that it might be better to just use Debian Stable (stretch), most of the "standard solutions" apply to that, Debian testing, well, you know, since it is still in the testing stages, it is not unusual for things to not work as expected, nor respond to the "standard solutions",.....
Keep bickering and arguing, and it will not surprise me at all if nobody wants to help any more, and another year will go by, by that time the problems that are in Debian testing now, may just magically disappear, but I am sure there will be new ones.
Last edited by GarryRicketson on 2019-02-20 22:20, edited 1 time in total.

morgon
Posts: 189
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

#18 Post by morgon »

I am giving up on this thread now.

I will keep an eye on this, so if someone has anything to contribute please do.

User avatar
GarryRicketson
Posts: 5871
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: cannot kill pulseaudio

#19 Post by GarryRicketson »

Well thanks for telling us, last year you didn't do that. Ok, no problem, then I will also give up on trying to sort this out, as well. All though I do think with better details on your non standard system, we could figure a way to make the standard solutions work.

morgon
Posts: 189
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

#20 Post by morgon »

Head_on_a_Stick wrote: You do know you can run PA through JACK, right?
There is no need to kill PA at all.
I know that and I even know why I don't want to do that.

It is a bit - let's say - non-standard to call someone an idiot here, but from a ****** ARSEHOLE like yourself what can you expect...

Locked