buster login: broken atomic modeset userspace.

Desktop Environments and Multimedia
Post Reply
Message
Author
marietto
Posts: 62
Joined: 2014-07-13 16:30

buster login: broken atomic modeset userspace.

#1 Post by marietto »

Hello to everyone.


I've installed a qemu / kvm debian buster / armhf VM on top of my jetson nano / arm64. This is the procedure that I have used :


stage 1 : I've created this script for the installation :


installer-buster.sh :

Code: Select all

qemu-system-aarch64 -M virt -m 2048 -smp 2 -cpu host,aarch64=off -enable-kvm \

-kernel /home/zi/Desktop/Work/I9/Arm32/debian10-buster/installer/vmlinuz \

-initrd /home/zi/Desktop/Work/I9/Arm32/debian10-buster/installer/initrd.gz \

-drive if=none,file=hda-buster.qcow2,format=qcow2,id=hd \

-device virtio-blk-device,drive=hd \

-netdev user,id=mynet \

-device virtio-net-device,netdev=mynet \

-nographic -no-reboot

stage 2 : I've created this script for the booting :


booting-buster.sh

Code: Select all

qemu-system-aarch64 -M virt -m 2048 -smp 2 -cpu host,aarch64=off -enable-kvm \

-kernel /home/zi/Desktop/Work/I9/Arm32/debian10-buster/vmlinuz-4.19.0-14-armmp-lpae \

-initrd /home/zi/Desktop/Work/I9/Arm32/debian10-buster/initrd.img-4.19.0-14-armmp-lpae \

-append 'root=/dev/vda2' \

-device usb-ehci -device usb-kbd -device usb-mouse -usb -serial stdio \

-device virtio-gpu-pci,virgl=on,xres=1920,yres=1080 -display sdl,gl=on \

-drive if=none,file=/home/zi/Desktop/Work/I9/Arm32/hda-buster.qcow2,format=qcow2,id=hd \

-device virtio-blk-device,drive=hd -netdev user,id=mynet \

-device virtio-net-device,netdev=mynet \

-bios edk2-arm-code.fd \

-no-reboot

What's the problem ? Problem is that when the login screen is shown,my mouse and my keyboard don't work. Investigating I think that I've found the reason. This is the content of :


/etc/gdm3/daemon.conf

Code: Select all

# GDM configuration storage

# See /usr/share/gdm/gdm.schemas for a list of available options.

[daemon]

# Uncomment the line below to force the login screen to use Xorg

#WaylandEnable=false

# Enabling automatic login

# AutomaticLoginEnable = true

# AutomaticLogin = user1

# Enabling timed login

# TimedLoginEnable = true

# TimedLogin = user1

# TimedLoginDelay = 10

As you can see it tells that Wayland should be enabled. I suspect that this is the reason why my mouse and keyboard don't work with a qemu and kvm Buster VM. Anyway,I've tried to do how it suggests to do,uncommenting the line below to force the login screen to use Xorg :


WaylandEnable=false


but it didn't work anyway. My mouse and keyboard still don't work. This time I can see the error message :


buster login: [ 190.296714] broken atomic modeset userspace detected, disabling atomic


so. How can I fix this bug ?

Post Reply