libwebkit update wants to install xdg-desktop-portal + more

Desktop Environments and Multimedia
Post Reply
Message
Author
User avatar
FreewheelinFrank
Posts: 387
Joined: 2010-06-07 16:59

libwebkit update wants to install xdg-desktop-portal + more

#1 Post by FreewheelinFrank »

Heads up, unforeseen consequences!

libwebkit update in XFCE Bullseye wants to install xdg-desktop-portal, pipewire and gnome-desktop libraries.

Code: Select all

root@Toshiba-laptop:~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  gnome-desktop3-data libgnome-desktop-3-19 libmanette-0.2-0 libpipewire-0.3-0
  libpipewire-0.3-modules libspa-0.2-modules libxkbregistry0 pipewire
  pipewire-bin xdg-desktop-portal xdg-desktop-portal-gtk
The following packages will be upgraded:
  dmidecode gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 isc-dhcp-client
  isc-dhcp-common libjavascriptcoregtk-4.0-18 libwebkit2gtk-4.0-37
7 upgraded, 11 newly installed, 0 to remove and 0 not upgraded.
Need to get 22.8 MB of archives.
After this operation, 15.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
That'll be a no then.

libwebkit2gtk-4.0-37 has new dependency xdg-desktop-portal.

https://bugzilla.redhat.com/show_bug.cgi?id=1845743

User avatar
craigevil
Posts: 5257
Joined: 2006-09-17 03:17
Location: Oz
Has thanked: 3 times
Been thanked: 3 times

Re: libwebkit update wants to install xdg-desktop-portal + m

#2 Post by craigevil »

Disable Recommends.

Code: Select all

Installed-Size: 58.4 MB
Depends: libjavascriptcoregtk-4.0-18 (= 2.32.1-1), bubblewrap (>= 0.3.1), xdg-dbus-proxy, libatk1.0-0 (>= 2.12.0), libc6 (>= 2.29), libcairo2 (>= 1.15.12), libegl1, libenchant-2-2 (>= 2.2.3), libfontconfig1 (>= 2.12.6), libfreetype6 (>= 2.9.1), libgcc-s1 (>= 4.0), libgcrypt20 (>= 1.8.0), libgdk-pixbuf-2.0-0 (>= 2.22.0), libgles2, libglib2.0-0 (>= 2.61.2), libgstreamer-gl1.0-0 (>= 1.14.0), libgstreamer-plugins-base1.0-0 (>= 1.14.0), libgstreamer1.0-0 (>= 1.14.0), libgtk-3-0 (>= 3.23.0), libharfbuzz-icu0 (>= 0.9.18), libharfbuzz0b (>= 1.4.2), libhyphen0 (>= 2.7.1), libicu67 (>= 67.1-1~), libjpeg62-turbo (>= 1.3.1), libmanette-0.2-0 (>= 0.1.2), libnotify4 (>= 0.7.0), libopenjp2-7 (>= 2.2.0), libpango-1.0-0 (>= 1.18.0), libpng16-16 (>= 1.6.2-1), libseccomp2 (>= 0.0.0~20120605), libsecret-1-0 (>= 0.7), libsoup2.4-1 (>= 2.69.90), libsqlite3-0 (>= 3.7.15), libstdc++6 (>= 9), libsystemd0, libtasn1-6 (>= 4.14), libwayland-client0 (>= 1.9.91), libwayland-egl1 (>= 1.15.0), libwayland-server0 (>= 1.3.92), libwebp6 (>= 0.5.1), libwebpdemux2 (>= 0.5.1), libwoff1 (>= 1.0.0), libwpe-1.0-1 (>= 1.3.0), libwpebackend-fdo-1.0-1 (>= 1.8.0), libx11-6, libxcomposite1 (>= 1:0.4.5), libxdamage1 (>= 1:1.1), libxml2 (>= 2.8), libxslt1.1 (>= 1.1.25), zlib1g (>= 1:1.2.0)
Recommends: gstreamer1.0-plugins-good, gstreamer1.0-pulseaudio | gstreamer1.0-alsa, gstreamer1.0-gl, libgl1-mesa-dri, xdg-desktop-portal-gtk, gstreamer1.0-libav
Raspberry PI 400 Distro: Raspberry Pi OS (Unstable) Kernel: 5.10.52-v8+ aarch64 DE: MATE Ram 4GB
Debian - "If you can't apt install something, it isn't useful or doesn't exist"

User avatar
FreewheelinFrank
Posts: 387
Joined: 2010-06-07 16:59

Re: libwebkit update wants to install xdg-desktop-portal + m

#3 Post by FreewheelinFrank »

Thanks. I didn't disable recommends globally but updated libwebkit2gtk-4.0-37 without installing recommended packages which fixed it for now.

Code: Select all

apt-get --no-install-recommends install libwebkit2gtk-4.0-37

Post Reply