le Wake on lan 'enabled' ne survit pas à un reset du serveur, help !

Need help with peripherals or devices?
Post Reply
Message
Author
Jeff63
Posts: 15
Joined: 2021-06-18 17:47

le Wake on lan 'enabled' ne survit pas à un reset du serveur, help !

#1 Post by Jeff63 »

Hello ^^)


j'ai un problème avec mon serveur sous Debian 10.10 : impossible de configurer le wol !

avec "ethtool enp2s0" j'ai pu voir que ma carte était configurée pour le wol au niveau du bios.

Supports Wake-on: pumbg
Wake-on: g

j'ai 'enabled' le wol avec la commande "ethtool -s enp2s0 wol g"

vérifié que ça avait été fait avec "cat /sys/class/net/enp2s0/power/wakeup" la réponse était "enabled"


j'ai rebooté le serveur et testé de nouveau avec "cat /sys/class/net/power/wakeup"

la réponse est systématiquement "disabled"


j'ai recommancé la procédure de nombreuses fois, pas moyens d'avoir le wol "enabled" en permanence !

si je shutdown ce serveur je suis obligé pour le rallumer d'avoir recours au personel du data center...


je ne comprends pas, le même serveur avec Debian 10.10 sur un Raid 6 formaté en Ext4 ça fonctionnait sans problèmes après une seulle procédure d'enable...

maintenant avec Debian 10.10 sur un LVM en Raid6 formaté en Ext4 ça ne fonctionne plus...
c'est pas un problmème de firewall étant donné que le firewall est éteint lorsque la machine l'est aussi.... et le wol est dabort géré par la carte eth, alors quoi ?


Quelqu'un peut m'aider ???


Merci d'avance,

Jeff
I have a problem with my server under Debian 10.10: cannot configure the wol!

with "ethtool enp2s0" I could see that my card was configured for the wol at the bios level.

Supports Wake-on: pumbg
Wake-on: g

I 'enabled' the wol with the command "ethtool -s enp2s0 wol g"

checked that it had been done with "cat / sys / class / net / enp2s0 / power / wakeup "the answer was" enabled "


I rebooted the server and tested again with" cat / sys / class / net / power / wakeup "

the answer is always" disabled "


I restarted the procedure many times, not means to have the wol "enabled" permanently!

if I shutdown this server I have to turn it on again to use the data center staff ...


I do not understand, the same server with Debian 10.10 on a Raid 6 formatted in Ext4 it worked without problems after only one procedure of 'enable ...

now with Debian 10.10 on an LVM in Raid6 formatted in Ext4 it no longer works ...
it's not a firewall problem given that the firewall is off when the machine is also off .... and the wol is dabort managed by the eth card, so what?


Someone can help me ???


Thanks in advance,

Jeff

arochester
Global Moderator
Global Moderator
Posts: 2060
Joined: 2010-12-07 19:55
Has thanked: 1 time
Been thanked: 3 times

Re: le Wake on lan 'enabled' ne survit pas à un reset du serveur, help !

#2 Post by arochester »

The principal language of this Forum is English.

A good translation tool is at https://www.deepl.com/translator

If you want help in French, look at:
https://debian-facile.org/
https://debian-facile.org/
https://www.debian-fr.xyz/

Jeff63
Posts: 15
Joined: 2021-06-18 17:47

SOLVED Re: le Wake on lan 'enabled' ne survit pas à un reset du serveur, help !

#3 Post by Jeff63 »

Oups! I forgot to write in english, sorry ^^)

btw,
I found the solution ! here : https://wiki.debian.org/WakeOnLan#check

-------------------------------------------------------------
Enabling WOL

ifupdown

You can check if you manage network by ifupdown with ifquery. This is the default on Debian installations.

Since squeeze ethtool parameters can be set directly from an interface configuration file. See the documentation in /usr/share/doc/ethtool/README.Debian for more information.

Add an interface config file /etc/network/interfaces.d/eth0 (or modify the global interface config file /etc/network/interfaces):

auto eth0
iface eth0 inet dhcp
ethernet-wol g

Activate it:

sudo reboot

-----------------------------------------------------


done like that (I choose to add the line

ethernet-wol g

directly to my /etc/network/interfaces file)


wol works after a shutdown of the server.

Thanks ^^)
Jeff.

Post Reply