Sound setup problem - Powerbook G4 (Powerbook6,2)

Need help with peripherals or devices?
Post Reply
Posts: 1
Joined: 2017-06-24 14:05

Sound setup problem - Powerbook G4 (Powerbook6,2)

#1 Post by Time4Tea »

Hi, I'm trying to install Debian Jessie on a 12" Apple Powerbook G4 (Powerbook6,2) and I am having problems getting the sound card to work. I've been reading around online and it seems to be a very common problem with these machines. I've tried all the remedies that I've found (including those mentioned in this thread); however, nothing so far has worked. Here is what I have tried:

Initially, it seemed that all the 'aoa' kernel modules were blacklisted, so I took those out of blacklist.local.conf and blacklisted snd-powermac instead. My blacklist.local.conf file now just has that one entry for snd-powermac. When I rebooted, I found that some of the aoa modules had been loaded and I now had a /proc/asound directory, which wasn't there before.

I added the 'snd-aoa-i2sbus' module to the /etc/modules file, because from what I had read, it seemed like it should be loaded. lsmod|grep snd now gives me this:

lee@localhost:~$ lsmod|grep snd
snd_aoa_codec_tas 9805 0
snd_aoa 13440 1 snd_aoa_codec_tas
snd_aoa_i2sbus 18288 0
snd_aoa_soundbus 3645 1 snd_aoa_i2sbus
snd_pcm 80231 1 snd_aoa_i2sbus
snd_timer 19150 1 snd_pcm
snd 58484 5 snd_aoa_i2sbus,snd_timer,snd_aoa,snd_pcm,snd_aoa_codec_tas
soundcore 5226 1 snd

However, the sound card still doesn't seem to work. cat /proc/asound/cards just gives me 'no soundcard'.

I also read about a possible kernel bug that may be causing the sound card to not be recognized, so I downloaded and installed a patched kernel from here. However, this seemed to make no difference - sound is still firmly not working.

So, I posted this because I've run out of ideas/options. If anyone has any ideas as to how I can resolve this, I'd be very interested to hear. Thanks!

Post Reply