Need help with Intel 82576 dual port nic on Debian 9 server

Need help with peripherals or devices?
Post Reply
Message
Author
User avatar
krazzyman79
Posts: 1
Joined: 2020-01-10 00:23
Location: The Great state of Texas, USA

Need help with Intel 82576 dual port nic on Debian 9 server

#1 Post by krazzyman79 »

Hello all, I am new here as a member to the forums, there is a lot of good helpful information here and I thank all of you for the contributions. having that said, I am in need of some help getting the Ethernet card in my Cisco UCS C200 server to work correctly with Debian 9 (Stretch). currently I have Debian 9 installed without the desktop environment to use as a NAS server in my home lab. the dual port nic which is built-in on the motherboard is only able to connect at 1000mbps on port 2, port 1 only seems to connect at 10mbps. I have searched online, here and afar only to come up with what I believe is a drive issue. the latest drivers available from Intel only shows to be supported in Debian 7 which I know this hardware is old but i would think it should work since at least one port connects fine. I'm not the savviest person with Linux but with the help of Google I seemed to have found my way around until now! I'm not sure where to start when trying to diagnose problems like this, any help would be very much appreciated.

again Thank you all.
Where there is a will, there is a way :D

User avatar
Head_on_a_Stick
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Need help with Intel 82576 dual port nic on Debian 9 ser

#2 Post by Head_on_a_Stick »

Can we see

Code: Select all

lspci -knn | grep -iA2 net
Might be worth trying the firmware-misc-nonfree package, only Intel 82559, 82551-F & 82551-10 are listed but you never know...
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

Post Reply