[SOLVED] no input/output sound devices after timeshift restore

Need help with peripherals or devices?
Post Reply
Message
Author
4joeyirosh1
Posts: 138
Joined: 2016-09-11 18:04
Been thanked: 2 times

[SOLVED] no input/output sound devices after timeshift restore

#1 Post by 4joeyirosh1 »

Hi!I have Debian 11 64 bit installed on my machine.I was testing timeshift restore which went successfully.However,I have lost both speaker and microphone functionality on my Debian so when I play a video there is no sound output.

When I check my sound settings,screenshot is as below

Image

When I enter alsamixer command the output is as below when I press F5 to capture all statistics

Image

When I enter pavucontrol command,output for Input and Output are as below just showing Dummy

Image

Image

Other command outputs are as below

Code: Select all

# arecord -l
**** List of CAPTURE Hardware Devices ****

Code: Select all

# lsmod | grep snd
snd_soc_skl           180224  0
snd_soc_hdac_hda       24576  1 snd_soc_skl
snd_hda_ext_core       36864  2 snd_soc_hdac_hda,snd_soc_skl
snd_soc_sst_ipc        20480  1 snd_soc_skl
snd_soc_sst_dsp        36864  1 snd_soc_skl
snd_soc_acpi_intel_match    45056  1 snd_soc_skl
snd_soc_acpi           16384  2 snd_soc_acpi_intel_match,snd_soc_skl
snd_hda_intel          57344  0
snd_intel_dspcfg       28672  2 snd_hda_intel,snd_soc_skl
soundwire_intel        45056  1 snd_intel_dspcfg
snd_soc_core          315392  3 soundwire_intel,snd_soc_hdac_hda,snd_soc_skl
snd_compress           32768  1 snd_soc_core
snd_hda_codec         172032  2 snd_hda_intel,snd_soc_hdac_hda
snd_hda_core          110592  5 snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_soc_hdac_hda,snd_soc_skl
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               135168  7 snd_hda_intel,snd_hda_codec,soundwire_intel,snd_compress,snd_soc_core,snd_soc_skl,snd_hda_core
snd_timer              49152  1 snd_pcm
snd                   110592  7 snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_compress,snd_soc_core,snd_pcm
soundcore              16384  1 snd

Code: Select all

# lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
	Subsystem: Hewlett-Packard Company Sunrise Point-LP HD Audio [103c:8215]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel, snd_soc_skl

Code: Select all

# dmesg | grep hda
[   17.319109] snd_hda_intel 0000:00:1f.3: Applying patch firmware 'hda-jack-retask.fw'
[   17.326747] snd_hda_intel 0000:00:1f.3: firmware: direct-loading firmware hda-jack-retask.fw
[   17.326986] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   17.439190] snd_hda_intel 0000:00:1f.3: CORB reset timeout#1, CORBRP = 0
[   17.440886] snd_hda_intel 0000:00:1f.3: no codecs found!

Kindly aid in restoring my original input/output sound configuration.I have restarted my machine several times but problem persists.
Last edited by 4joeyirosh1 on 2021-07-21 15:53, edited 1 time in total.

4joeyirosh1
Posts: 138
Joined: 2016-09-11 18:04
Been thanked: 2 times

Re: no input/output sound devices after timeshift restore

#2 Post by 4joeyirosh1 »

I decided to do a factory reset of BIOS Security and now I am ok.

Post Reply