No Sound on Debian 10

Need help with peripherals or devices?
Post Reply
Message
Author
kmk
Posts: 6
Joined: 2019-11-05 03:20

No Sound on Debian 10

#1 Post by kmk »

Hello,

I have a fresh installed Debian 10 on vmware esxi that seems to (as far as I can tell) detect sound card but despite my best attempts, I haven't been able to get any audio out of it.

Sound card is motherboard onboard audio (Supermicro X11SCA-F, Realtek ALC 888S).

Code: Select all

dmesg | grep sound
[    2.050084] input: HD-Audio Generic Mic as /devices/pci0000:00/0000:00:11.0/0000:02:04.0/sound/card0/input7
[    2.050321] input: HD-Audio Generic Line Out Front as /devices/pci0000:00/0000:00:11.0/0000:02:04.0/sound/card0/input8
[    2.050538] input: HD-Audio Generic Line Out Surround as /devices/pci0000:00/0000:00:11.0/0000:02:04.0/sound/card0/input9
[    2.050746] input: HD-Audio Generic Line Out CLFE as /devices/pci0000:00/0000:00:11.0/0000:02:04.0/sound/card0/input10
[    2.050954] input: HD-Audio Generic Line Out Side as /devices/pci0000:00/0000:00:11.0/0000:02:04.0/sound/card0/input11

lspci -nn |grep -i audio
02:04.0 Audio device [0403]: VMware HD Audio Controller [15ad:1977] (rev 09)
Alsa seems to init fine:

Code: Select all

alsactl init
Found hardware: "HDA-Intel" "Generic 15ad Generic" "HDA:15ad1975,15ad1975,00100103" "0x15ad" "0x1977"
Hardware is initialized using a generic method
All outputs show up fine on alsamixer, they are all maximum volume, and I'm trying to play an mp3 through aplay, play and test pattern with speaker-test. I have tried all outputs including HDMI output sound and nothing ever seems to have any sound on. Unfortunately this is where my troubleshooting skills end. There's no desktop environment installed since I intend to run this as an mpd server and no one will directly need to use it. I appreciate any assistance you can provide. Thank you.

peter_irich
Posts: 1328
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation

Re: No Sound on Debian 10

#2 Post by peter_irich »

I don't know but run
pavucontrol
and check that right card is selected.
It is comfortable use

Code: Select all

cat /proc/asound/cards
Peter.

shep
Posts: 420
Joined: 2011-03-15 15:22

Re: No Sound on Debian 10

#3 Post by shep »

There's no desktop environment installed since I intend to run this as an mpd server and no one will directly need to use it.
In your mpd.conf there is a section where you specify the audio_output.

Code: Select all

# An example of an ALSA output:
#
audio_output {
       type            "alsa"
       name            "My ALSA Device"
##      device          "hw:0,0"        # optional
##      mixer_type      "hardware"      # optional
##      mixer_device    "default"       # optional
      mixer_control   "Master"           # optional
##      mixer_index     "0"             # optional
}
There are multiple audio outputs. Oss, pulseaudio, icecast, httpd, osc and sndio to name a few.

Your issue can hinge on which output is utilized. If no audio_output is specified, mpd takes its best guess.
If your are using alsa, one common issue is multiple devices. Video Card HDMI can be one device, System-on-a-Chip can be a second device and a dedicated sound card can be a third. A Default Debian setup just uses one devices which is specified as a default.

Code: Select all

aplay -l
will list your cards.
An [file]/etc/modprobe.d[/file] entry can change the default or you can specify an alternative device in your mpd.conf.
https://wiki.archlinux.org/index.php/Ad ... sound_card
Last edited by shep on 2019-11-06 03:35, edited 1 time in total.

kmk
Posts: 6
Joined: 2019-11-05 03:20

Re: No Sound on Debian 10

#4 Post by kmk »

Thank you for responding Peter and Shep.

Output of these commands shows what I expected:

Code: Select all

MPD:~# cat /proc/asound/cards
 0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfdffc000 irq 62

MPD:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: Generic Analog [Generic Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
/etc/mpd.conf is mostly using defaults for sound output:

Code: Select all

audio_output {
        type            "alsa"
        name            "My ALSA Device"
#       device          "hw:0,0"        # optional
#       mixer_type      "hardware"      # optional
#       mixer_device    "default"       # optional
#       mixer_control   "PCM"           # optional
#       mixer_index     "0"             # optional
...
audio_output {
        type            "httpd"
        name            "My HTTP Stream"
        encoder         "vorbis"                # optional, vorbis or lame
        port            "8000"
#       bind_to_address "0.0.0.0"               # optional, IPv4 or IPv6
        quality         "5.0"                   # do not define if bitrate is defined
#       bitrate         "128"                   # do not define if quality is defined
        format          "44100:16:1"
        max_clients     "0"                     # optional 0=no limit
I'm using play to play an mp3, I get some output as if it's playing, yet nothing audible from headset plugged into any one of the outputs. I tried aplay command with the same file and it says playing raw data but still no audio.

Code: Select all

 File Size: 6.22M     Bit Rate: 202k
  Encoding: MPEG audio    Info: 2011
  Channels: 2 @ 16-bit   Track: 5/14
Samplerate: 44100Hz      Album: Born This Way (Standard Edition)
Replaygain: off         Artist: Lady Gaga
  Duration: 00:04:06.57  Title: Americano

In:19.6% 00:00:48.30 [00:03:18.27] Out:2.31M [!=====|=====!] Hd:0.1 Clip:2
I made sure I maxed out volume on alsamixer before playing too:

Code: Select all

│                                                              100      100<>100   100<>100   100<>100     100        100      100<>100     0<>0                                                              │
│                                                             Master      PCM       Front   < Surround >  Center      LFE        Side    Mic Boost 
Let me know what else I can try. Thank you for your help.

kmk
Posts: 6
Joined: 2019-11-05 03:20

Re: No Sound on Debian 10

#5 Post by kmk »

Looking around the internet I suspected I may need pulseaudio running as well, figured it was worth a shot, started it with pulseaudio -D. However after that it got worse. When I use aplay or speaker-test I get the following errors:

Code: Select all

ALSA lib pcm_pulse.c:752:(pulse_prepare) PulseAudio: Unable to create stream: No such entity

aplay: set_params:1403: Unable to install hw params:
ACCESS:  RW_INTERLEAVED
FORMAT:  U8
SUBFORMAT:  STD
SAMPLE_BITS: 8
FRAME_BITS: 8
CHANNELS: 1
RATE: 8000
PERIOD_TIME: 125000
PERIOD_SIZE: 1000
PERIOD_BYTES: 1000
PERIODS: 4
BUFFER_TIME: 500000
BUFFER_SIZE: 4000
BUFFER_BYTES: 4000
TICK_TIME: [0 0]

shep
Posts: 420
Joined: 2011-03-15 15:22

Re: No Sound on Debian 10

#6 Post by shep »

I do not run vmware but could it be interfering with sound? One way to tell is to run a live Debian Buster CD. If you have sound, then the issue is vmware. If your card does not work with Live debian buster, then post the output of lspci so the forum can see the specific hardware you are using.

peter_irich
Posts: 1328
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation

Re: No Sound on Debian 10

#7 Post by peter_irich »

You may also use ~./.asoundrc, for example

Code: Select all

pcm.!default {
type pulse
}
ctl.!default {
type pulse
}
Peter.

shep
Posts: 420
Joined: 2011-03-15 15:22

Re: No Sound on Debian 10

#8 Post by shep »

There are online guides for vmware/sound
https://www.vmware.com/support/ws3/doc/ ... ound4.html

Not sure if they apply to your specific setup.

Code: Select all

lsmod | grep '^snd' | column -t
to verify that the snd modules are being loaded.
Your dmesg indicates the card is configured "generic". It may need some tweaks.

More trouble shooting advice this the Arch wiki
https://wiki.archlinux.org/index.php/Ad ... chitecture

kmk
Posts: 6
Joined: 2019-11-05 03:20

Re: No Sound on Debian 10

#9 Post by kmk »

Thanks for the responses Peter and Shep, here's the output of that command:

Code: Select all

MPD:~# lsmod | grep 'snd' | column -t
snd_hda_codec_generic  86016   1
snd_hda_intel          45056   2
snd_hda_codec          151552  2   snd_hda_codec_generic,snd_hda_intel
snd_hda_core           94208   3   snd_hda_codec_generic,snd_hda_intel,snd_hda_codec
snd_hwdep              16384   1   snd_hda_codec
snd_pcm                114688  3   snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              36864   1   snd_pcm
snd                    94208   10  snd_hda_codec_generic,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_pcm
soundcore              16384   1   snd
The sound card on the motherboard apparently uses snd_hda_intel drivers so that part sounds about right so far. Using livecd is one thing to try for sure, but this would be a strictly command line vm, while it won't hurt to see if debian can use the sound card at all, it just wouldn't be very helpful in replicating the exact set up I need sound in. The idea was to have a no gui server controlled through an MPD client that would stream over bluetooth adapter plugged into sound output jack to stream to my receiver.

The vmware guide was mainly for vmware workstation and not esxi, esxi has no trouble adding HD Audio as an adapter to this VM, but it won't add soundblaster etc. due to not having compatible hardware, so it must be detecting the audio fine. Unfortunately all my guest o/s on it so far is FreeNAS which is based on FreeBSD and Debian, so I don't have any other O/S on it to test. Maybe I can get a Debian VM with desktop installed on a VM to test the sound.

While Arch wiki has useful information about ALSA, some parts of it assume too much about user knowledge level with the underlying OS, especially the part about selecting the default pcm through configuration file. I'll try to research a bit more about it, but I'm not sure how much it will help. I agree with you that aplay -l output showing only Generic as output doesn't sound quite right, I may be mistaken but I'd expect to see more detail than just generic. Unfortunately I don't have anything to compare it against.

kmk
Posts: 6
Joined: 2019-11-05 03:20

Re: No Sound on Debian 10

#10 Post by kmk »

I installed gnome environment on a test VM and all I got as sound output option was a dummy output, and as expected no audio is heard.

kmk
Posts: 6
Joined: 2019-11-05 03:20

Re: No Sound on Debian 10

#11 Post by kmk »

I wasn't able to get this working properly despite all of my attempts. I was able to see line out as a valid output on gnome desktop, but I couldn't get any sound out of outputs I needed. So I purchased an Audigy FX PCI Express card, assigned it to mpd vm with pci passthrough and I was able to get output through command line without much effort. Thanks for the help.

mrkapqa
Posts: 154
Joined: 2014-04-22 08:30

Re: No Sound on Debian 10

#12 Post by mrkapqa »

on Devuan 3.0 (based on Debian 10) the solution for Pulseaudio to work is the following:

Code: Select all

sudo nano /etc/pulse/client.conf.d/00-disable-autospawn.conf
comment out
autospawn=no
like

Code: Select all

#autospawn=no
save, close, reboot.

rupert
Posts: 1
Joined: 2020-03-30 11:07

Re: No Sound on Debian 10

#13 Post by rupert »

My sound wasn`t wonking on Debian GNU/Linux bullseye/sid.
I run alsamixer and all was ok, I reinstalled pulse, alsa, volti, intel drivers... and nothing.
My problem was that PulseAudio daemon was not running automatically.
To run it I execute in bash: pulseaudio
and all ok but I dont know if it's permanent and the daemon start...I should reboot...




________________________________________________________________________________________________
Official Site
Last edited by rupert on 2020-04-02 10:08, edited 1 time in total.

User avatar
Head_on_a_Stick
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: No Sound on Debian 10

#14 Post by Head_on_a_Stick »

rupert wrote:My sound wasn`t wonking on Debian GNU/Linux bullseye/sid.
So why are you trying to hi-jack a thread about Debian 10?
rupert wrote:My problem was that PulseAudio daemon was not running automatically.
http://forums.debian.net/viewtopic.php?f=7&t=145719
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

Post Reply