[solved] firefox-esr 78.3.0 annoying spinning pointer

If it doesn't relate to Debian, but you still want to share it, please do it here
Post Reply
Message
Author
User avatar
ticojohn
Posts: 1022
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 2 times
Been thanked: 7 times

[solved] firefox-esr 78.3.0 annoying spinning pointer

#1 Post by ticojohn »

I am running Debian 10.6, XFCE desktop and the lightdm display manager. After a recent system upgrade I noticed that the mouse pointer "spins" for up to a minute after launching Firefox. I tried all the usual things like disabling plugins and extensions, etc etc, but nothing helped, although starting in sfafe mode did not exhibit the spinning mouse pointer. What I did find was that editing /usr/share/applications/firefox-esr.desktop and changing StartupNotify=true to StartupNotify=false eliminated the distraction.

I changed it about a week ago and have not seen any abnormal behavior. Does anybody know of any issues with changing that variable?
Last edited by ticojohn on 2020-10-16 14:52, edited 1 time in total.
I am not irrational, I'm just quantum probabilistic.

User avatar
Head_on_a_Stick
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: firefox-esr 78.3.0 annoying spinning pointer

#2 Post by Head_on_a_Stick »

ticojohn wrote:Does anybody know of any issues with changing that variable?
Your change will be over-written when the firefox-esr package is updated. Copy the .desktop file to ~/.local/share/applications/ and edit that instead.

EDIT: and if "safe" mode fixes the problem then the cause is one of your extensions or a setting change you have made in FF.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

User avatar
stevepusser
Posts: 12408
Joined: 2009-10-06 05:53
Has thanked: 7 times
Been thanked: 5 times

Re: firefox-esr 78.3.0 annoying spinning pointer

#3 Post by stevepusser »

Does it take that long for FF to become fully active, as in loading the home page? Then the spinner may just be reflecting reality.

I've noticed that FF can take longer to load the more I use it over the months. The usual fix is to try and clean out the cruft in the ~/.mozilla folder, but back it up first.
MX Linux packager and developer

User avatar
Head_on_a_Stick
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: firefox-esr 78.3.0 annoying spinning pointer

#4 Post by Head_on_a_Stick »

I find clearing the cache can help with startup times but my SSD is so fast it doesn't make that much difference :D
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

User avatar
stevepusser
Posts: 12408
Joined: 2009-10-06 05:53
Has thanked: 7 times
Been thanked: 5 times

Re: firefox-esr 78.3.0 annoying spinning pointer

#5 Post by stevepusser »

I think ticojohn might still be using a spinny spinny drive, if I remember correctly, so optimizing the folder may help. But I don't think Bleachbit's feature for that should be done without backing it up first.
MX Linux packager and developer

User avatar
ticojohn
Posts: 1022
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 2 times
Been thanked: 7 times

Re: firefox-esr 78.3.0 annoying spinning pointer

#6 Post by ticojohn »

stevepusser wrote:I think ticojohn might still be using a spinny spinny drive, if I remember correctly, so optimizing the folder may help. But I don't think Bleachbit's feature for that should be done without backing it up first.
No, I have a SATA SSD. Firefox loads really fast, and is usable during the time that the pointer is spinning. I just find the spinning wheel to be a distraction.
Last edited by ticojohn on 2020-10-16 15:07, edited 1 time in total.
I am not irrational, I'm just quantum probabilistic.

User avatar
ticojohn
Posts: 1022
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 2 times
Been thanked: 7 times

Re: firefox-esr 78.3.0 annoying spinning pointer

#7 Post by ticojohn »

Head_on_a_Stick wrote:
ticojohn wrote:Does anybody know of any issues with changing that variable?
Your change will be over-written when the firefox-esr package is updated. Copy the .desktop file to ~/.local/share/applications/ and edit that instead.

EDIT: and if "safe" mode fixes the problem then the cause is one of your extensions or a setting change you have made in FF.
Thanks for that feedback. I have disabled and/or uninstalled extensions and addons but it had no effect. I uninstalled and then reinstalled Firefox so I would think that any config changes that I might have made would have gone away. Also, I download Firefox and put it in a directory. Running from that directory exhibits the same issue. Interestingly, if I invoke firefox-esr from the command line the spinning pointer is not there. Maybe the easiest thing to do is to edit the firefox icon that I have on the xfce panel so that it simply launches firefox-esr and doesn't launch by way of the firefox-esr.desktop file. That would eliminate any issues with the file being overwritten when updated.
I am not irrational, I'm just quantum probabilistic.

User avatar
ticojohn
Posts: 1022
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 2 times
Been thanked: 7 times

Re: firefox-esr 78.3.0 annoying spinning pointer

#8 Post by ticojohn »

stevepusser wrote:Does it take that long for FF to become fully active, as in loading the home page? Then the spinner may just be reflecting reality.

I've noticed that FF can take longer to load the more I use it over the months. The usual fix is to try and clean out the cruft in the ~/.mozilla folder, but back it up first.
Thanks stevepusser, I may try that.
I am not irrational, I'm just quantum probabilistic.

User avatar
ticojohn
Posts: 1022
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 2 times
Been thanked: 7 times

Re: firefox-esr 78.3.0 annoying spinning pointer

#9 Post by ticojohn »

stevepusser wrote: I've noticed that FF can take longer to load the more I use it over the months. The usual fix is to try and clean out the cruft in the ~/.mozilla folder, but back it up first.
Interesting. I just looked at the ~/.mozilla folder and noticed that there were two (2) key database files, key3.db and key4.db
That seems kind of strange. I don't know,yet, if that may be part of the problem. I moved the key3.db file to trash and checked that all my logins work, so I assume that the key3.db file is unnecessary. I will store it somewhere for safekeeping until I am absolutely sure it isn't required.
I am not irrational, I'm just quantum probabilistic.

User avatar
ticojohn
Posts: 1022
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 2 times
Been thanked: 7 times

Re: firefox-esr 78.3.0 annoying spinning pointer

#10 Post by ticojohn »

VIOLA! Thanks to all that the offered suggestions but mostly to stevepusser. I don't know where the second key.db file came from, probably operator error, but removing the key3.db file solved the problem. Will mark this as solved.
I am not irrational, I'm just quantum probabilistic.

trinidad
Posts: 188
Joined: 2016-08-04 14:58
Been thanked: 2 times

Re: [solved] firefox-esr 78.3.0 annoying spinning pointer

#11 Post by trinidad »

If you delete the key3.db file you will not be able to fallback to old login info from previous versions of Firefox you ran before your upgrade. I believe the cutoff was FF 55. Make sure you have all the old info you want entered into upgraded FF before you delete the old file. I had the same issue on Debian 9.9 a few upgrades ago.

TC
You can't believe your eyes if your imagination is out of focus.

User avatar
ticojohn
Posts: 1022
Joined: 2009-08-29 18:10
Location: /home/heart
Has thanked: 2 times
Been thanked: 7 times

Re: [solved] firefox-esr 78.3.0 annoying spinning pointer

#12 Post by ticojohn »

trinidad wrote:If you delete the key3.db file you will not be able to fallback to old login info from previous versions of Firefox you ran before your upgrade.
Thanks. I made sure I had everything I needed before deleting the old key.
I am not irrational, I'm just quantum probabilistic.

Post Reply