install buster with nvidia

Help with issues regarding installation of Debian
Post Reply
Message
Author
kmchen
Posts: 58
Joined: 2013-04-24 06:29

install buster with nvidia

#1 Post by kmchen »

Hi,

Tried to install Buster on a SLIMBOOK (I7) with nvidia card. Installation successfull but no X server at boot.

Followed this tuto https://linuxconfig.org/how-to-install- ... ster-linux without success. Started with default driver and ended compiling [460.39] version with no result.

Here some X logs:

Code: Select all

# cat /var/log/Xorg.0.log|grep '(EE)'
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     9.219] (EE) Failed to load module "nv" (module does not exist, 0)
[     9.222] (EE) Unable to find a valid framebuffer device
[     9.223] (EE) Screen 0 deleted because of no matching config section.
[     9.223] (EE) Screen 0 deleted because of no matching config section.
[     9.223] (EE) 
[     9.223] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[     9.223] (EE) 
[     9.223] (EE) 
[     9.223] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     9.223] (EE) 
[     9.227] (EE) Server terminated with error (1). Closing log file.
Any help greatly apreciated
Développeur WEB
http://www.webologix.com

arzgi
Posts: 850
Joined: 2008-02-21 17:03
Location: Finland
Been thanked: 6 times

Re: install buster with nvidia

#2 Post by arzgi »

Please read the FAQ: http://forums.debian.net/viewtopic.php?f=16&t=148440

And I'd advise to search also Debian wiki before some random instruction.

kmchen
Posts: 58
Joined: 2013-04-24 06:29

Re: install buster with nvidia

#3 Post by kmchen »

Did not understand "...search also Debian wiki before some random instruction"

Read the FAQ. In rescue mode logged as root with no X server runing:

Code: Select all

systemctl set-default multi-user.target
apt install firmware-linux-nonfree
...
Réception de :1 http://deb.debian.org/debian buster/non-free amd64 amd64-microcode amd64 3.20181128.1 [35,2 kB]
Réception de :2 http://deb.debian.org/debian buster/non-free amd64 firmware-amd-graphics all 20190114-2 [3 427 kB]
Réception de :3 http://deb.debian.org/debian buster/non-free amd64 firmware-misc-nonfree all 20190114-2 [3 338 kB]
Réception de :4 http://deb.debian.org/debian buster/non-free amd64 firmware-linux-nonfree all 20190114-2 [17,7 kB]
Réception de :5 http://deb.debian.org/debian buster/contrib amd64 iucode-tool amd64 2.3.1-1 [62,4 kB]
Réception de :6 http://deb.debian.org/debian buster/non-free amd64 intel-microcode amd64 3.20201118.1~deb10u1 [2 768 kB]
9 649 ko réceptionnés en 2s (5 282 ko/s)
Sélection du paquet amd64-microcode précédemment désélectionné.
(Lecture de la base de données... 206384 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-amd64-microcode_3.20181128.1_amd64.deb ...
Dépaquetage de amd64-microcode (3.20181128.1) ...
Sélection du paquet firmware-amd-graphics précédemment désélectionné.
Préparation du dépaquetage de .../1-firmware-amd-graphics_20190114-2_all.deb ...
Dépaquetage de firmware-amd-graphics (20190114-2) ...
Sélection du paquet firmware-misc-nonfree précédemment désélectionné.
Préparation du dépaquetage de .../2-firmware-misc-nonfree_20190114-2_all.deb ...
Dépaquetage de firmware-misc-nonfree (20190114-2) ...
Sélection du paquet firmware-linux-nonfree précédemment désélectionné.
Préparation du dépaquetage de .../3-firmware-linux-nonfree_20190114-2_all.deb ...
Dépaquetage de firmware-linux-nonfree (20190114-2) ...
Sélection du paquet iucode-tool précédemment désélectionné.
Préparation du dépaquetage de .../4-iucode-tool_2.3.1-1_amd64.deb ...
Dépaquetage de iucode-tool (2.3.1-1) ...
Sélection du paquet intel-microcode précédemment désélectionné.
Préparation du dépaquetage de .../5-intel-microcode_3.20201118.1~deb10u1_amd64.deb ...
Dépaquetage de intel-microcode (3.20201118.1~deb10u1) ...
Paramétrage de iucode-tool (2.3.1-1) ...
Paramétrage de intel-microcode (3.20201118.1~deb10u1) ...
update-initramfs: deferring update (trigger activated)
intel-microcode: microcode will be updated at next boot
Paramétrage de firmware-misc-nonfree (20190114-2) ...
update-initramfs: deferring update (trigger activated)
Paramétrage de amd64-microcode (3.20181128.1) ...
update-initramfs: deferring update (trigger activated)
amd64-microcode: microcode will be updated at next boot
Paramétrage de firmware-amd-graphics (20190114-2) ...
update-initramfs: deferring update (trigger activated)
Paramétrage de firmware-linux-nonfree (20190114-2) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.133+deb10u1) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-14-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
...
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
I'll see the realtek problems later. I fisrt would like to have a working Desktop.

Then reboot and still fails on boot with exactly same X logs described at first post:

Code: Select all

$ cat /var/log/Xorg.0.log|grep '(EE)'
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   192.464] (EE) Failed to load module "nv" (module does not exist, 0)
[   192.466] (EE) Unable to find a valid framebuffer device
[   192.469] (EE) Screen 0 deleted because of no matching config section.
[   192.469] (EE) Screen 0 deleted because of no matching config section.
[   192.469] (EE) 
[   192.469] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[   192.469] (EE) 
[   192.469] (EE) 
[   192.469] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   192.469] (EE) 
[   192.472] (EE) Server terminated with error (1). Closing log file.
Last edited by kmchen on 2021-02-11 18:07, edited 1 time in total.
Développeur WEB
http://www.webologix.com

User avatar
stevepusser
Posts: 12430
Joined: 2009-10-06 05:53
Has thanked: 8 times
Been thanked: 6 times

Re: install buster with nvidia

#4 Post by stevepusser »

Is this a new Slimbook? Can you give us the specs for the processor and graphics? I would bet it has both integrated and discrete GPUs. You should know that Buster, possibly even with the help of buster-backports, does not support the latest Intel and AMD graphics. If it doesn't need a newer Mesa, you may be able to get it to work with firmware, or a newer kernel and firmware from backports...BUT an answer depends on the hardware. We need to know that first.
MX Linux packager and developer

kmchen
Posts: 58
Joined: 2013-04-24 06:29

Re: install buster with nvidia

#5 Post by kmchen »

~$ sudo lshw -C display
*-display
description: VGA compatible controller
produit: UHD Graphics
fabricant: Intel Corporation
identifiant matériel: 2
information bus: pci@0000:00:02.0
version: 02
bits: 64 bits
horloge: 33MHz
fonctionnalités: pciexpress msi pm vga_controller bus_master cap_list rom
configuration : driver=i915 latency=0
ressources : irq:131 mémoire:64000000-64ffffff mémoire:40000000-4fffffff portE/S:7000(taille=64) mémoire:c0000-dffff
*-display NON-RÉCLAMÉ
description: 3D controller
produit: GP108M [GeForce MX250]
fabricant: NVIDIA Corporation
identifiant matériel: 0
information bus: pci@0000:01:00.0
version: a1
bits: 64 bits
horloge: 33MHz
fonctionnalités: pm msi pciexpress bus_master cap_list
configuration : latency=0
ressources : mémoire:65000000-65ffffff mémoire:50000000-5fffffff mémoire:60000000-61ffffff portE/S:6000(taille=128) mémoire:66000000-6607ffff
~$ cat /proc/cpuinfo | grep 'model name' | uniq
model name : Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz
Développeur WEB
http://www.webologix.com

User avatar
stevepusser
Posts: 12430
Joined: 2009-10-06 05:53
Has thanked: 8 times
Been thanked: 6 times

Re: install buster with nvidia

#6 Post by stevepusser »

All that output is not important compared to the last line:

Code: Select all

model name : Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz
Tenth generation Intel is not compatible at present with Buster or Buster backports, because of the need for a newer Mesa for the iGPU to work.

This sort of problem is coming up several times a week now in these forums. You have a choice of trying Debian testing with the non-free firmware, now that it's frozen, or a Debian-derived distro that has the necessary backports by default.
MX Linux packager and developer

Post Reply