Installing Debian 10.8.0 (Gnome)

Help with issues regarding installation of Debian
Post Reply
Posts: 2
Joined: 2021-02-27 21:25

Installing Debian 10.8.0 (Gnome)

#1 Post by colby »

I've hit a wall installing Debian 10.8.0 (Gnome) from a bootable USB and need help. The installer loads and begins the installation, and seems to complete the process, but after rebooting all that will boot up is a black screen with a blinking cursor at the top left corner that does not respond to any of my keyboard commands. The only issue I have during installation is that I cannot get the network to configure automatically (I have tried several times with no luck). I've even tried to use an ethernet connection but when that's used the installer will stop and say I need to "Configure the network"; it freezes at this point (even if left for an hour to sort itself out), is unresponsive to any keyboard commands, and does not respond to the ethernet cable being disconnected. So, I have not been able to install & reboot with a network connection. I am open to any & all suggestions as I really want to use Debian.

User avatar
Posts: 1268
Joined: 2009-04-16 18:35
Location: Kristiansand, Norway
Has thanked: 9 times
Been thanked: 19 times

Re: Installing Debian 10.8.0 (Gnome)

#2 Post by Hallvor »

Details about your hardware would be nice, for instance the output of

Code: Select all

$ lspci
You could also try installation media with non-free firmware: ... -firmware/
Lenovo ThinkPad T440S, Intel Core i7-4600U CPU @ 2.10GHz, 8 GB RAM, 256 GB SSD, Debian Bullseye (KDE)
Installing and configuring Debian Bullseye: viewtopic.php?f=16&t=150334

Global Moderator
Global Moderator
Posts: 2072
Joined: 2010-12-07 19:55
Has thanked: 2 times
Been thanked: 3 times

Re: Installing Debian 10.8.0 (Gnome)

#3 Post by arochester » ?

Don't treat your Ethernet as hot-pluggable. Try connecting the cable, then switch on.

Posts: 2
Joined: 2021-02-27 21:25

Re: Installing Debian 10.8.0 (Gnome)

#4 Post by colby »

Responding to Hallvor, here are my specs:

Processor: AMD Ryzen 3250U Picasso (2.6 GHz, 2 cores, TDP 15W)
RAM: 8 GB DDR4 2400 MHz (32 GB), 2 slots
Graphics card: AMD Radeon RX Vega 3 integrated into the processor
Storage: 1 TB at 5400 rpm 1 free M.2 SSD slot
Connectivity: 2 USB 3.0 1 USB 2.0, HDMI 1.4b, SD / SDHC / SDXC
Network: Wi-Fi ac, Bluetooth 4.1, Gigabit Ethernet

I have also just tried to install the non-free ISO to see if that helped. Although I was able to detect my network wirelessly (and even put in a password) the installer froze on the same "Configure the network" msg that I saw when trying to install via ethernet on my first attempt. I also tried to connect via ethernet with this non-free ISO & was left with the same msg as before.

As for arochester: I just tried a non-free ISO (see above) with some luck, but I am still in a similar spot. After testing the cable connection on another device to make sure it was working I tried connecting the cable during different points during the installation as well as starting the machine with & without the cable plugged in. Is that what you're referring to by 'connecting the cable, then switch on.'?

User avatar
Posts: 13446
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Installing Debian 10.8.0 (Gnome)

#5 Post by Head_on_a_Stick »

Please read the Frequently Asked Questions thread in the HowTo section of the forums.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support

Post Reply