KDE 5.20 on Bullseye

Desktop Environments and Multimedia
Post Reply
Posts: 258
Joined: 2020-10-21 21:39
Has thanked: 4 times
Been thanked: 7 times

KDE 5.20 on Bullseye

#1 Post by mm3100 »

Hello there,

I have upgraded from Buster and am asking about KDE on wayland. As for me copy/paste is not working well, that is at all. It works under xwayland. I have tried to use wl-clipboard, but even that is not working well.

So I am asking if it just me? And if there is something I could try to poke around to see what could cause such issue. Looking it up there seem to be many bug reports about it even for 5.21.

https://www.mail-archive.com/kde-bugs-d ... 34177.html
https://www.mail-archive.com/kde-bugs-d ... 47526.html

User avatar
Global Moderator
Global Moderator
Posts: 3795
Joined: 2006-08-29 09:12
Location: Melbourne, Australia
Has thanked: 5 times
Been thanked: 16 times

Re: KDE 5.20 on Bullseye

#2 Post by sunrat »

A lot of work is happening in KDE development for Wayland. You can read about it at https://pointieststick.com/
Currently Wayland is not ready for prime time in 5.21 and I wouldn't use it in 5.20 apart from for experimental purposes.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!

User avatar
Posts: 12430
Joined: 2009-10-06 05:53
Has thanked: 8 times
Been thanked: 6 times

Re: KDE 5.20 on Bullseye

#3 Post by stevepusser »

CopyQ works fine in Plasma last time I tried it, and the last release added Wayland support. It doesn't seem to be in Bullseye, though. I'll see about setting up a backports repo for it tomorrow.
MX Linux packager and developer

Post Reply