Bullseye RC2 couldn't make international keyboard work

Help with issues regarding installation of Debian
Post Reply
Message
Author
fernandocesarpinto
Posts: 9
Joined: 2021-05-13 14:44

Bullseye RC2 couldn't make international keyboard work

#1 Post by fernandocesarpinto »

When I installed Debian 11 RC2 (with Gnome) I should UK since it is my region, then I don't gave me an option to US-International key board, so I proceeded with standard GB keyboard.

I read and tried practically everything from https://wiki.debian.org/Keyboard.

1. I tried first editing myself /etc/default/keyboard and putting:

Code: Select all

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT="alt-intl"
Even after:

Code: Select all

/usr/sbin/dpkg-reconfigure -f noninteractive keyboard-configuration
or reboot, it does not work. I also tried altgr-intl instead of alt-intl.

Is it a bug? The accents don't work and I also see £ instead of #.

I also tried:

Code: Select all

setxkbmap -model pc105 -layout us -variant altgr-intl
(with and without sudo). No success.

Any idea / comments?

fernandocesarpinto
Posts: 9
Joined: 2021-05-13 14:44

Re: Bullseye RC2 couldn't make international keyboard work

#2 Post by fernandocesarpinto »

This is very sad I got no answer. Official documentation is outdated and have the obscure comment
There is much on this page that is out of date for Stretch - needs a total rewrite by someone that knows more than I do. The names for the international keyboard layouts changed between jessie and stretch - not finding documentation. ).

arzgi
Posts: 796
Joined: 2008-02-21 17:03
Location: Finland
Been thanked: 2 times

Re: Bullseye RC2 couldn't make international keyboard work

#3 Post by arzgi »

fernandocesarpinto wrote: 2021-07-08 09:14 When I installed Debian 11 RC2 (with Gnome) I should UK since it is my region, then I don't gave me an option to US-International key board, so I proceeded with standard GB keyboard.
And what did you try?
fernandocesarpinto wrote: I read and tried practically everything from https://wiki.debian.org/Keyboard.
Open terminal, and try

Code: Select all

man keyboard
there you'll find up to date info.
fernandocesarpinto wrote: Is it a bug? The accents don't work and I also see £ instead of #.
Hardly, misconfiguration more likely

Post Reply