Gnome Task Bar Won't Show Proper Locale

Desktop Environments and Multimedia
Post Reply
Message
Author
pwzhangzz
Posts: 46
Joined: 2020-11-11 17:42

Gnome Task Bar Won't Show Proper Locale

#1 Post by pwzhangzz »

OS: Bullseye, full-updated

Locale: zh_CN, ja_JP

Problem: The date and time are shown in English (en_US), not in the format expected from the locale.

(No problem with Ubuntu 20.04, for example, when logged into the Chinese locale, today's date is correctly shown as 七月十九日,not Jul 19.)

pwzhangzz
Posts: 46
Joined: 2020-11-11 17:42

Re: Gnome Task Bar Won't Show Proper Locale

#2 Post by pwzhangzz »

This problem seems to have disappeared after I downloaded and run (as a customized LiveUSB) today's hybrid iso.

pwzhangzz
Posts: 46
Joined: 2020-11-11 17:42

Re: Gnome Task Bar Won't Show Proper Locale

#3 Post by pwzhangzz »

Spoke too soon. Gnome task bar shows correct locale only booted from LiveUSB. For installed systems, it still shows English locale while in other locales.

mm3100
Posts: 255
Joined: 2020-10-21 21:39
Has thanked: 4 times
Been thanked: 7 times

Re: Gnome Task Bar Won't Show Proper Locale

#4 Post by mm3100 »

For gnome I think you need to make changes in language and localization settings. I had same issue where locales were ignored, but changes there made changes to locale as well. I am not sure about that, but can you check in settings?

pwzhangzz
Posts: 46
Joined: 2020-11-11 17:42

Re: Gnome Task Bar Won't Show Proper Locale

#5 Post by pwzhangzz »

I am using different users respectively for different locales and languages. Everything else was OK according to the anointed locale except the gnome task bar (mainly date and time--always shown in English).

Again, as mentioned above, when I logged into, say, Chinese locale in a persistent LiveUSB, everything was correctly shown in Chinese including the gnome task bar. However, in an installed system, under exactly the same configurations, everything was correctly shown in Chinese except the gnome task bar.

mm3100
Posts: 255
Joined: 2020-10-21 21:39
Has thanked: 4 times
Been thanked: 7 times

Re: Gnome Task Bar Won't Show Proper Locale

#6 Post by mm3100 »

Only thing I am finding is this
https://help.gnome.org/users/gnome-help ... ge.html.en
If there are multiple user accounts on your system, there is a separate instance of the Region & Language panel for the login screen. Click the Login Screen button at the top right to toggle between the two instances.
Googling didn't help much.

Post Reply